Sylpheed compilation and linking of libiconv...

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
Hakimoto
Moderator
Moderator
Posts: 2483
Joined: Sun Mar 30, 2003 5:29 am
Location: Kabul, Afghanistan, Asia
Contact:

Sylpheed compilation and linking of libiconv...

Unread postby Hakimoto » Sun Mar 30, 2003 5:50 am

Hi All!

Finally I have managed to get myself registered here (Hi Nekonoko!), and I will try and participate all the tidbits of SGI info that cross my way. But for now a little question for all you linking specialists out there.

I use sylpheed 0.8.11 as my email client and it compiles so sweetly under IRIX 6.5.17m. The only problem is, that I just can´t get it to recognise either my libiconv from SGI nor the self-compiled one I have in

Code: Select all

/usr/local/
.

I tried it with:

Code: Select all

--with-libiconv-prefix=/usr/local
--with-libiconv-prefix=/usr/freeware
--with-libiconv=/usr/local
--with-libiconv=/usr/freeware


What am i doing wrong? My freeware libiconv is from SGI, the self compiled one was compiled twicce, before and after gettext, due to the circular dependency. But it just doesn´t work.

This is the last step before I can finally use UTF-8 encoding for sending emails, which is really important for me. But no, it just won´t happen.

Anyone got any ideas? I would appreciate it a lot, because oon the sylpheed ml my question did not provoke any answers.

Thanks!

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8003
Joined: Thu Jan 23, 2003 2:31 am
Location: Pleasanton, California
Contact:

Re: Sylpheed compilation and linking of libiconv...

Unread postby nekonoko » Sun Mar 30, 2003 2:08 pm

Is it that the configure script is not seeing it or something else? I just tried it, and I see the following (relevant excerpts only):

Code: Select all

[Mika:~/sylpheed-0.8.11] neko 164% ./configure --with-libiconv-prefix=/usr/freeware
...
checking for iconv... yes
checking for iconv declaration...
         extern size_t iconv (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t *outbytesleft);
checking for nl_langinfo and CODESET... yes
checking for LC_MESSAGES... yes
checking for bison... bison
checking version of bison... 1.35, ok
checking whether NLS is requested... yes
checking whether included gettext is requested... no
checking for GNU gettext in libc... no
checking for GNU gettext in libintl... no
...
sylpheed 0.8.11

image support : yes (gdk-pixbuf)
GnuPG         : no
JPilot        : no
LDAP          : no
OpenSSL       : no
iconv         : yes
compface      : no
IPv6          : no

The binary will be installed in /usr/local/bin

Configure finished, type 'make' to build.
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

User avatar
Hakimoto
Moderator
Moderator
Posts: 2483
Joined: Sun Mar 30, 2003 5:29 am
Location: Kabul, Afghanistan, Asia
Contact:

Re: Sylpheed compilation and linking of libiconv...

Unread postby Hakimoto » Sun Mar 30, 2003 4:11 pm

That´s exactly it. The configure script DOES NOT see it. What can I do?

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8003
Joined: Thu Jan 23, 2003 2:31 am
Location: Pleasanton, California
Contact:

Re: Sylpheed compilation and linking of libiconv...

Unread postby nekonoko » Sun Mar 30, 2003 4:36 pm

Not sure, it seems to work fine here from what I can tell. Check status of:

Code: Select all

f 31615     3 irix_dev.sw.headers     usr/include/iconv.h
f 63628    44 eoe.sw.base             usr/bin/iconv
f 48536  1761 fw_libiconv.sw.libiconv   usr/freeware/bin/iconv
f 11136     1 fw_libiconv.sw.libiconv c usr/freeware/lib32/charset.alias
f 11136     1 fw_libiconv.sw.libiconv c usr/freeware/lib64/charset.alias
f 62231     4 fw_libiconv.sw.libiconv   usr/freeware/share/locale/de/LC_MESSAGES/libiconv.mo


Also check config.log to see what caused the problem finding iconv.
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

vegac
Posts: 732
Joined: Thu Jan 23, 2003 12:34 pm
Contact:

Unread postby vegac » Sun Mar 30, 2003 7:59 pm

When installing libiconv, is the dev-portion of it not selected by default?

I noticed a number of freeware apps didn't have that selected by default, which would explain why it doesn't think you have it...

of course that wouldn't explain why the version you compiled yourself doesn't work

User avatar
Hakimoto
Moderator
Moderator
Posts: 2483
Joined: Sun Mar 30, 2003 5:29 am
Location: Kabul, Afghanistan, Asia
Contact:

Re: Sylpheed compilation and linking of libiconv...

Unread postby Hakimoto » Mon Mar 31, 2003 1:48 am

Hi guys...

I shall check it out tonight, if I find the time, and let you know in due course. Unfortunately I don't have remote access to my Octane from work, so I can't attempt the compile.

Thanks for all the help so far.


Return to “SGI: Development”

Who is online

Users browsing this forum: No registered users and 1 guest