6.2 / 5.3 packages

IRIX and IRIX software discussion including open source and commerical offerings.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
rvic
Posts: 56
Joined: Sun Feb 08, 2009 6:55 am
Location: Romania
Contact:

Re: 6.2 / 5.3 packages

Unread postby rvic » Wed Jul 15, 2015 2:18 pm

about dillo 3 install ...
this time i did everything a little better ...
first i installed your packages .... jpeg, libiconv, png, zlib ... with "rulesoverride" on libstdc++, libgcc-s1, and gcc3.46 (it asked for them ... tgcware)
so with a little change in .cshrc like this:

setenv LD_LIBRARYN32_PATH .:/usr/lib32:/lib32:/usr/lib32/internal:/usr/java/lib32:usr/freeware/lib32:/usr/local/lib

well after run:
rld: cannot successfully map soname 'libstdc++.so.7' .... etc

fine ... installed "libstdcxx_7-4.5.2-4.tgc-irix6.2-mips3-tgcware.tardist"
add: to .cshrc "/usr/tgcware/lib" in "LD_LIBRARYN32_PATH"
then it needs "libgcc-s.so.1" ... ok installed the coresponding from tgcware ...

then run it again ..... "segmentation fault"
The only package that wasn't installed and bypassed with "rulesoverride" in inst was gcc3.46 ... and indeed it didn't need it ...

Unfortunately it didn't run ... I'm giving a little information ... my system is 6.5.15 (there was a question like why i just don't upgrade, well i don't want to... and i have another hdd with 6.5.26 and everything works fine there but i like more 6.5.15 at least for the O2)
Maybe it needs a certain version of those tgcware libs as i noticed at least 3 versions of the same libs ... and finally maybe it needs something from gcc3.46 package ...

Thank you again foetz for your effort ... and hope you can see a solution :) ... i would really like dillo3 running ...

User avatar
foetz
Moderator
Moderator
Posts: 6542
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: 6.2 / 5.3 packages

Unread postby foetz » Wed Jul 15, 2015 10:09 pm

i have no idea whether this runs on 6.5.x at all but i can give you the exact inst versions of the libs that i have installed when i fire up the indigo next time

User avatar
foetz
Moderator
Moderator
Posts: 6542
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: 6.2 / 5.3 packages

Unread postby foetz » Tue Sep 29, 2015 7:46 pm

added a mirror server. see first post

User avatar
foetz
Moderator
Moderator
Posts: 6542
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: 6.2 / 5.3 packages

Unread postby foetz » Wed Sep 14, 2016 11:10 pm

5.3
  • vim_802.tar.bz2

yay a vim update after, well, quite some time and of course we gotta have that for irix so here it is. expects to go to /usr/local and then just add the bin dir to your $PATH or link away.
this also works fine with all later irix versions.

marmotta
Posts: 97
Joined: Sat Apr 16, 2005 1:18 am
Location: Gambolò (Italy)
Contact:

Re: 6.2 / 5.3 packages

Unread postby marmotta » Wed Aug 23, 2017 2:16 pm

You can build e-uae for 6.2 or 5.3?

User avatar
foetz
Moderator
Moderator
Posts: 6542
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: 6.2 / 5.3 packages

Unread postby foetz » Thu Aug 24, 2017 12:54 pm

i'm afraid not. and i'm not sure that'd be fun on machines running 6.2 or even 5.3 either.

marmotta
Posts: 97
Joined: Sat Apr 16, 2005 1:18 am
Location: Gambolò (Italy)
Contact:

Re: 6.2 / 5.3 packages

Unread postby marmotta » Thu Aug 24, 2017 1:02 pm

You can confirm is not easy? Or if you give me the instruction (source and string) I try to compile myself ;-)

My r4400 250mhz have 6.2.... is a good idea upgrade to 6.5?

User avatar
foetz
Moderator
Moderator
Posts: 6542
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: 6.2 / 5.3 packages

Unread postby foetz » Fri Aug 25, 2017 1:21 pm

marmotta wrote:You can confirm is not easy? Or if you give me the instruction (source and string) I try to compile myself ;-)

i can't confirm either way because i never tried. i keep these archives to the essentials mostly so an emulator wouldn't qualify.

My r4400 250mhz have 6.2.... is a good idea upgrade to 6.5?

only, and that's a fat ONLY, if you need stuff that requires 6.5. otherwise it'd be a downgrade performance wise. in fact, depending on what you wanna do, i'd rather recommend to give 5.3 a try

User avatar
uunix
Donor
Donor
Posts: 1793
Joined: Sun Mar 27, 2011 12:48 pm
Location: Stourbridge / England / UK

Re: 6.2 / 5.3 packages

Unread postby uunix » Fri Aug 25, 2017 1:35 pm

foetz wrote:
marmotta wrote:You can confirm is not easy? Or if you give me the instruction (source and string) I try to compile myself ;-)

i can't confirm either way because i never tried. i keep these archives to the essentials mostly so an emulator wouldn't qualify.

My r4400 250mhz have 6.2.... is a good idea upgrade to 6.5?

only, and that's a fat ONLY, if you need stuff that requires 6.5. otherwise it'd be a downgrade performance wise. in fact, depending on what you wanna do, i'd rather recommend to give 5.3 a try

foetz is spot on about performance, of course though it depends on what you do. I personally love 6.5.30 because it's so easy. I use a 200Mhz INDY R4400 with an ev1 as composite video in to pre view video coming in off an old camcorder and it works fine, but that's really all it does.
-----------------------------------------------------------------------
Hey Ho! Pip & Dandy!
:Octane2: :O2: :Indigo: :Indy:
-----------------------------------------------------------------------

User avatar
foetz
Moderator
Moderator
Posts: 6542
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: 6.2 / 5.3 packages

Unread postby foetz » Sat Aug 26, 2017 11:06 am

uunix wrote:I personally love 6.5.30 because it's so easy. I use a 200Mhz INDY R4400 with an ev1 as composite video in to pre view video coming in off an old camcorder and it works fine, but that's really all it does.

6.5.30 on an indy?

User avatar
Dodoid
Posts: 602
Joined: Mon Jul 04, 2016 1:36 pm
Location: Ottawa, Canada
Contact:

Re: 6.2 / 5.3 packages

Unread postby Dodoid » Sat Aug 26, 2017 10:59 pm

I think he means that he prefers 6.5.30, but on his Indy, which has to run an older version, he's not bothered by the older OS because he only uses the system to capture composite video :) .
:Onyx: :O2000: :Fuel: :Octane: :Octane: :Octane: :O2: :O2: :Indigo2: :Indigo2: :Indy: :Indy:
and a small army of Image

User avatar
uunix
Donor
Donor
Posts: 1793
Joined: Sun Mar 27, 2011 12:48 pm
Location: Stourbridge / England / UK

Re: 6.2 / 5.3 packages

Unread postby uunix » Sun Aug 27, 2017 12:45 am

foetz wrote:
uunix wrote:I personally love 6.5.30 because it's so easy. I use a 200Mhz INDY R4400 with an ev1 as composite video in to pre view video coming in off an old camcorder and it works fine, but that's really all it does.

6.5.30 on an indy?

Duh.. I meant 6.5.22.. :oops: Heck I just meant 6.5.something.
-----------------------------------------------------------------------
Hey Ho! Pip & Dandy!
:Octane2: :O2: :Indigo: :Indy:
-----------------------------------------------------------------------


Return to “IRIX and Software”

Who is online

Users browsing this forum: No registered users and 2 guests