xVidGrab -- Make -- Install issues

New to SGIs? Need help getting things going? This is the forum for you!
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
Intuition
Posts: 385
Joined: Thu Oct 15, 2009 1:56 pm
Location: Marina Del Rey, CA

Re: xVidGrab -- Make -- Install issues

Unread postby Intuition » Wed Mar 07, 2018 5:27 pm

My primary goal is to simply capture the entire desktop to create video tutorials/reviews.

I haven't been able to do so by using media recorder unless it is only 720x486. I was directed towards this xVidCap as a way to do the whole desktop at 12-15 fps.

Even DmRecord was pointed to. Which I have yet to fully test properly. I think xVidCap may use dmRecord. Not sure.

I bid on a Octane Personal Video card a week ago but lost due to a refresh issue. There are two on Ebay for $400 which I am hesitant to buy at the moment. I know the Personal Video card seems to be the guarantee desktop capture solution.

Its all about getting the dekstop capture going since my phone isn't really a nice elegant way to do it.

Currently I can't fire up the video panel because it says it has no "video daemon" which is probably just because the EMXI isn't a vid capture setup like the o2 has.
Image O2 - 300mhz
Image O2 - 400mhz :1600SW: 1600sw
:Octane: 2x400mhz :O200: Origin 200 2x225mhz
aka Casey Christopher

User avatar
vishnu
Donor
Donor
Posts: 3361
Joined: Sun Mar 18, 2007 3:25 pm
Location: Minneapolis, Minnesota USA

Re: xVidGrab -- Make -- Install issues

Unread postby vishnu » Wed Mar 07, 2018 8:18 pm

I just use xv, you can grab the whole screen by clicking and dragging with the middle mouse button, or set it to grab whatever window the cursor is in after a setable delay. There's an IRIX version but IIRC it didn't work exactly right under 6.5 and so I ended up compiling it myself. If you'd rather not do that just say the word and I'll attach my version

http://www.trilon.com/xv/downloads.html#bin-distrib

EDIT: Hmmmm, not sure this is allowable given the original xv license, but it looks like some spoon has put it on github, with all the patches already applied:

https://github.com/DavidGriffith/xv

I wonder if John Bradley even knows about that... :shock:
Project:
Temporarily lost at sea...
Plan:
World domination! Or something...

:Tezro: :Octane2:

jpstewart
Donor
Donor
Posts: 458
Joined: Tue Sep 21, 2010 3:31 pm
Location: Southwestern Ontario, Canada

Re: xVidGrab -- Make -- Install issues

Unread postby jpstewart » Thu Mar 08, 2018 8:17 am

That's correct that the video panel won't come up without video daemon running, which in turn is only applicable with a hardware video capture device (O2, Octane PVO, etc.) installed.

I don't think dmrecord will capture from screen on an Octane; its man page only talks about the various video compression boards and mentions screen capture is "For O2 systems only".

I only glanced at the mediarecorder docs last night, but upon further inspection this morning, it looks like you might be right about mediarecorder's size limits for movies. It seems like there are a lot of assumptions about video output files being NTSC (or PAL) resolution or less. Full screen may not be possible with it. Even with the PVO hardware, it looks like mediarecorder will capture full screen but scale it down to an NTSC or PAL sized output file. But frankly, I'm not that familiar with mediarecorder so I'm not 100% sure.

Vishnu, cans xv capture video of the screen, too? I thought it only did still images.

I'll take another stab at getting xvidcap ported when I get a chance. Intuition, if you don't hear back from me in a week, bug me about it! (Unless somebody else takes on the project sooner!)
:Indigo2IMP: :Octane: :Indigo: :O3x0:
Sun SPARCstation 20, Blade 2500, T5240, Ultra2
HP C8000
Digital DECstation 5000/125

User avatar
Intuition
Posts: 385
Joined: Thu Oct 15, 2009 1:56 pm
Location: Marina Del Rey, CA

Re: xVidGrab -- Make -- Install issues

Unread postby Intuition » Fri Mar 09, 2018 8:22 am

I’ll try Vishnu’s solution but yes, I don’t need it to stay full res. But do need full screen.

I know a few people here have recorded full screen with PVO. I’ve seen videos on YouTube with it. I’m not looking for 24fps either. 12fps is plenty for tutorials.

Thanks for any efforts. :)
Image O2 - 300mhz
Image O2 - 400mhz :1600SW: 1600sw
:Octane: 2x400mhz :O200: Origin 200 2x225mhz
aka Casey Christopher

User avatar
vishnu
Donor
Donor
Posts: 3361
Joined: Sun Mar 18, 2007 3:25 pm
Location: Minneapolis, Minnesota USA

Re: xVidGrab -- Make -- Install issues

Unread postby vishnu » Fri Mar 09, 2018 3:17 pm

Oh, sorry guys, yeah xv will only do screenshots, but I think mediarecorder is what you want, and as far as full screen movies go, I don't think you really want to record things at 1920 by 1200 anyway:

http://nixdoc.net/man-pages/irix/man1/mediarecorder.1.html
Project:
Temporarily lost at sea...
Plan:
World domination! Or something...

:Tezro: :Octane2:

jpstewart
Donor
Donor
Posts: 458
Joined: Tue Sep 21, 2010 3:31 pm
Location: Southwestern Ontario, Canada

Re: xVidGrab -- Make -- Install issues

Unread postby jpstewart » Thu Mar 15, 2018 3:56 pm

Alas, it's time to make the post I've been dreading: I have failed.

With much effort, I got xvidcap to build on IRIX. I'd initially thought it would be a nice Saturday afternoon project. (Or less!) It ended up taking all of my free time for several days. (I was too stubborn for my own good!) The resulting diff affects around 200 lines of code. (The overhead of the patch file format means the whole thing is >1800 lines! :shock: ) But the resulting binary does not run correctly.

The xvidcap GUI spits out bus errors and dumps core. I know what "bus error" typically means, but in this case I don't know if they're a problem with my patches (I don't think anything I patched would cause that, but...), a problem with the original source (which is the most likely cause, IMHO), or a problem in one of the many GUI libraries used (some of which came from Nekoware /beta and so could well be buggy).

Running xvidcap solely from the command line with no GUI gets a little farther before it spews many warning/error messages to the terminal and successfully creates the output file. Unfortunately, that's where it hangs. The output is empty. And I have to 'killall xvidcap' in another terminal to get it to exit.

I'm afraid there's nothing more I can do at this point. If anyone else wants to pick up where I left off, let me know and I can provide some notes and my patch. Be forewarned, it's an ugly patch. It's not my best work. I'm not going to post it here for fear of being publicly shamed and having it haunt me. :lol: It was supposed to be a quick-and-dirty hack to get it running, then I'd clean things up. But since it's not running, there's no point in doing that.

I also took another stab at getting IRIX's own mediarecorder to do full screen capture, but I still can't find a way to coax it into doing anything close to full screen. Above a certain size of capture window, it gives an error and refuses to do it. That's regardless of whether I use the mediarecorder command line to specify the capture area (matching screen resolution), use the GUI to select the whole visible screen, or use the GUI to select a specific maximized window. I can't get it to do full screen, period.

When this thread started, it seemed like a fun and interesting project to try to get working. But I've got to admit defeat at this point.
:Indigo2IMP: :Octane: :Indigo: :O3x0:
Sun SPARCstation 20, Blade 2500, T5240, Ultra2
HP C8000
Digital DECstation 5000/125

User avatar
Intuition
Posts: 385
Joined: Thu Oct 15, 2009 1:56 pm
Location: Marina Del Rey, CA

Re: xVidGrab -- Make -- Install issues

Unread postby Intuition » Thu Mar 15, 2018 5:06 pm

Oh man, jpstewart I am sorry man. I didn't mean for that to turn into a total time stretch.

:shock:

I'll just break down and buy the PVO card at the end of this month and get tuts out. Thanks for trying though.
Image O2 - 300mhz
Image O2 - 400mhz :1600SW: 1600sw
:Octane: 2x400mhz :O200: Origin 200 2x225mhz
aka Casey Christopher


Return to “Getting Started, Documentation, Tips & Tricks”

Who is online

Users browsing this forum: No registered users and 2 guests