Pidgin can't find X11 development headers

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
praetor242
Posts: 207
Joined: Thu Feb 23, 2017 5:41 pm
Location: Arlington, TX

Pidgin can't find X11 development headers

Unread postby praetor242 » Thu Apr 27, 2017 7:10 pm

I'm trying to compile the most recent version of pidgin, and all goes well until it tries and finds the X11 Development headers, which I know are installed. There is stuff in /usr/include/X11 anyway. Are the headers installed in a non-standard place?

I've also set CFLAGS=-I/usr/include/X11 and no love :(

And this happens both with GCC and MIPSPro
Image - trajan - R5000 180Mhz - 128 MB RAM - 147GB HDD
Image - hadrian - R5000 180Mhz - 128 MB RAM - 76 GB HDD

User avatar
Raion-Fox
Donor
Donor
Posts: 1331
Joined: Thu Jan 30, 2014 5:01 pm
Location: near King George, Virginia
Contact:

Re: Pidgin can't find X11 development headers

Unread postby Raion-Fox » Thu Apr 27, 2017 8:30 pm

CFLAGS needs a space between the -l and the leading /
:O3x02L: R16000 700MHz 8GB RAM kanna
:Octane: R12000 300MHz SI 896MB RAM yuuka
:Octane2: R12000A 400MHz V6 2.5GB RAM
:Indy: (Acclaim) R4600 133MHz XL Graphics 32MB RAM
:Indy: (Challenge S) R4600 133MHz (MIPS III Build Server)
Thinkpad W530 i7 3940XM 3GHz, 32GB, K1000M Windows 8.1 Embedded rin
Thinkpad R40 Pentium M 1.5GHz 2GB RAM kasha

User avatar
praetor242
Posts: 207
Joined: Thu Feb 23, 2017 5:41 pm
Location: Arlington, TX

Re: Pidgin can't find X11 development headers

Unread postby praetor242 » Thu Apr 27, 2017 8:32 pm

I don't think they do. I've never put a space after the switch, and things work the way they are supposed to. I'll try it anyway. Can't hurt :D
Image - trajan - R5000 180Mhz - 128 MB RAM - 147GB HDD
Image - hadrian - R5000 180Mhz - 128 MB RAM - 76 GB HDD

User avatar
praetor242
Posts: 207
Joined: Thu Feb 23, 2017 5:41 pm
Location: Arlington, TX

Re: Pidgin can't find X11 development headers

Unread postby praetor242 » Fri Apr 28, 2017 10:29 am

I hacked it. I made a pkg-config file to point to the X11 headers and it works.
Image - trajan - R5000 180Mhz - 128 MB RAM - 147GB HDD
Image - hadrian - R5000 180Mhz - 128 MB RAM - 76 GB HDD

User avatar
Raion-Fox
Donor
Donor
Posts: 1331
Joined: Thu Jan 30, 2014 5:01 pm
Location: near King George, Virginia
Contact:

Re: Pidgin can't find X11 development headers

Unread postby Raion-Fox » Fri Apr 28, 2017 10:43 am

Great!
:O3x02L: R16000 700MHz 8GB RAM kanna
:Octane: R12000 300MHz SI 896MB RAM yuuka
:Octane2: R12000A 400MHz V6 2.5GB RAM
:Indy: (Acclaim) R4600 133MHz XL Graphics 32MB RAM
:Indy: (Challenge S) R4600 133MHz (MIPS III Build Server)
Thinkpad W530 i7 3940XM 3GHz, 32GB, K1000M Windows 8.1 Embedded rin
Thinkpad R40 Pentium M 1.5GHz 2GB RAM kasha


Return to “SGI: Development”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest