Trying to Resurrect a Macintosh Color Classic

Apple hardware/software and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
AmyBoz
Posts: 1
Joined: Thu Jul 07, 2016 11:52 am

Trying to Resurrect a Macintosh Color Classic

Unread postby AmyBoz » Thu Jul 07, 2016 11:56 am

Hi all...

I am trying to resurrect my CoCla that was in my parents (dry) basement for the past 25 years. I cleaned the logic board with compressed air. If I remove the logic board, the machine turns on, however, once the logic board is replaced, the machine refuses to turn on. I ordered a new 3.6v battery and installed it, today, and nothing has changed. I was thinking it might be the keyboard connection, as it turns on from a button on the keyboard, but I'm not even getting an orange light on the Mac to indicate that it has power with the logic board in. I'd appreciate any thoughts!

nyef
Posts: 72
Joined: Tue Apr 28, 2015 7:54 pm

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby nyef » Thu Jul 07, 2016 6:11 pm

25 years? I'd suggest that any electrolytic capacitors in the system are likely to be marginal at this point, and would be a good first thing to swap out to see if it helps.

The 3.6v battery being dead shouldn't prevent the system from starting up, it just keeps it from remembering things like which disk to boot by default, what time it is, and so on.

If I recall correctly, there may well be a second power button on the machine itself. Even with the power buttons on the keyboards, there was usually a second way to power the system up.

User avatar
ClassicHasClass
Donor
Donor
Posts: 2075
Joined: Wed Jul 25, 2012 7:12 pm
Location: Sunny So Cal
Contact:

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby ClassicHasClass » Thu Jul 07, 2016 9:56 pm

Not that I recall on my Colour Classic; there's just a master power switch. Amy, you need to get the board recapped and that should fix it. Alternatively, the motherboard from an LC575 will fit, though it doesn't match with the rear ports punchout.
smit happens.

:Fuel: bigred, 900MHz R16K, 4GB RAM, V12 DCD, 6.5.30
:Indy: indy, 150MHz R4400SC, 256MB RAM, XL24, 6.5.10
:Indigo2IMP: purplehaze, 175MHz R10000, Solid IMPACT
probably posted from Image bruce, Quad 2.5GHz PowerPC 970MP, 16GB RAM, Mac OS X 10.4.11
plus IBM POWER6 p520 * Apple Network Server 500 * RDI PrecisionBook * BeBox * Solbourne S3000 * Commodore 128 * many more...

User avatar
SiliconClassics
Posts: 1477
Joined: Sun Apr 11, 2004 5:07 pm
Location: New York
Contact:

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby SiliconClassics » Thu Jul 14, 2016 5:31 am

At this point most the electrolytic caps in almost all Color Classics have failed and need to be replaced, preferably with tantalums. That could be the root of your problem. Be sure to wash any leaked electrolyte off your motherboard and be careful when removing the old caps because it's easy to lift a pad if you do it wrong. There are some good guides online if you Google around for them.

Could also be bad caps in the analog / power board, but you should start with the motherboard and see what happens. CCs have a power switch on the back but it's just a cutoff - the system is powered on via the keyboard only.
Silicon Classics on: YouTube | Twitter | Google+

robespierre
Posts: 1554
Joined: Mon Sep 12, 2011 2:28 pm
Location: Boston

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby robespierre » Thu Jul 14, 2016 6:49 am

Apple seems to be the only company whose capacitors all leak. (It doesn't happen at all on NeXT computers, or Suns, or SGIs...)
It seems they used a harsher post-solder cleaning regimen that was destructive to the rubber seals of the capacitors.

There is no general problem with SMD capacitors leaking. You can replace them with direct substitutes.
:PI: :O2: :Indigo2IMP: :Indigo2IMP:

User avatar
ClassicHasClass
Donor
Donor
Posts: 2075
Joined: Wed Jul 25, 2012 7:12 pm
Location: Sunny So Cal
Contact:

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby ClassicHasClass » Thu Jul 14, 2016 9:10 am

It seems to be a problem mostly with the '030 Macs. Earlier systems and '040 Macs and later don't seem to suffer to near this extent, other than the infamous iMac G5 "troubles."
smit happens.

:Fuel: bigred, 900MHz R16K, 4GB RAM, V12 DCD, 6.5.30
:Indy: indy, 150MHz R4400SC, 256MB RAM, XL24, 6.5.10
:Indigo2IMP: purplehaze, 175MHz R10000, Solid IMPACT
probably posted from Image bruce, Quad 2.5GHz PowerPC 970MP, 16GB RAM, Mac OS X 10.4.11
plus IBM POWER6 p520 * Apple Network Server 500 * RDI PrecisionBook * BeBox * Solbourne S3000 * Commodore 128 * many more...

robespierre
Posts: 1554
Joined: Mon Sep 12, 2011 2:28 pm
Location: Boston

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby robespierre » Thu Jul 14, 2016 9:18 am

I've seen it happen in LC 475s and Quadra 840AVs. They eventually fixed whatever they were doing, but it wasn't until about 1995.
:PI: :O2: :Indigo2IMP: :Indigo2IMP:

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8145
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby nekonoko » Thu Jul 28, 2016 10:15 am

Another thing I've found regarding the Color Classic is sometimes you can get them going without replacing the capacitors just by cleaning up the leaking electrolyte on the motherboard with some alcohol.
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

User avatar
LarBob
Donor
Donor
Posts: 96
Joined: Sun Nov 13, 2016 6:43 am
Location: Kentucky, US

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby LarBob » Sun May 28, 2017 4:48 pm

nekonoko wrote:Another thing I've found regarding the Color Classic is sometimes you can get them going without replacing the capacitors just by cleaning up the leaking electrolyte on the motherboard with some alcohol.

Sorry for resurrecting a dead thread, but for people looking at this thread now, this is usually more of a temporary solution. Eventually you'll still need new caps.
:Octane: Aezora - 2xR10k 250 MHz - 1 GB RAM - 6.5.30

User avatar
kjaer
Posts: 424
Joined: Wed May 07, 2008 7:47 pm
Location: Seattle, WA
Contact:

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby kjaer » Mon May 29, 2017 12:09 pm

robespierre wrote:Apple seems to be the only company whose capacitors all leak. (It doesn't happen at all on NeXT computers, or Suns, or SGIs...)


That's BS. These SMT electrolytics leak in everything. They leak in Sony CD-ROM drives. They leak in Canon and Panasonic floppy disk drives. They leak in IBM PS/2 DBA hard drives. The similarly sized miniature through-hole electrolytics used in all kinds of drives leak like a bugger too.

If you look at Suns, NeXTs, SGIs of the same vintage... you'll find they haven't used any SMT electrolytics anywhere. That's why they "don't leak".
:OnyxR: :IRIS3130: :IRIS2400: :Onyx: :ChallengeL: :4D220VGX: :Indigo: :Octane: :Cube: :Indigo2IMP: :Indigo2: :Indy:

User avatar
SiliconClassics
Posts: 1477
Joined: Sun Apr 11, 2004 5:07 pm
Location: New York
Contact:

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby SiliconClassics » Fri Jun 02, 2017 9:15 am

So is it possible to resurrect dead optical drives by recapping them? I've seen tons of CD-ROM and DVD-ROM drives fail inexplicably over the years and always assumed it was the lens mechanism wearing out, but if it's just a capacitor problem then it should be easily repairable, yes?
Silicon Classics on: YouTube | Twitter | Google+

User avatar
kjaer
Posts: 424
Joined: Wed May 07, 2008 7:47 pm
Location: Seattle, WA
Contact:

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby kjaer » Fri Jun 02, 2017 10:22 am

SiliconClassics wrote:So is it possible to resurrect dead optical drives by recapping them? I've seen tons of CD-ROM and DVD-ROM drives fail inexplicably over the years and always assumed it was the lens mechanism wearing out, but if it's just a capacitor problem then it should be easily repairable, yes?


Well... The Sony mechanisms as used in the Apple CD150 and CD300 drives surely respond very well to this treatment. I'd hesitate to suggest that any (or even most) arbitrary drive failure(s) could be cured this way. The tray-loaded Toshiba drives are more prone to mechanical failure IME. And the older Sony mechanism used in the Apple CD SC has an open optical pickup and I've seen several "failures" there caused simply by dirty optics.

For example.
:OnyxR: :IRIS3130: :IRIS2400: :Onyx: :ChallengeL: :4D220VGX: :Indigo: :Octane: :Cube: :Indigo2IMP: :Indigo2: :Indy:

t-rexky
Posts: 26
Joined: Sun May 06, 2012 5:05 am
Location: Ontario, Canada

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby t-rexky » Mon Jun 05, 2017 7:45 pm

robespierre wrote:Apple seems to be the only company whose capacitors all leak. (It doesn't happen at all on NeXT computers, or Suns, or SGIs...)
It seems they used a harsher post-solder cleaning regimen that was destructive to the rubber seals of the capacitors.

There is no general problem with SMD capacitors leaking. You can replace them with direct substitutes.


Well, absolutely not true. The early SMD electrolytic capacitors are absolutely notorious for failing. NeXT used two alternate suppliers for theirs with one holding up reasonably well while the others leak like faucets. There is a large supply of new old stock NeXT sound boards and many of them are damaged because of leaked electrolyte. These are boards that have never been powered up since they left the factory.

Anyhow, have a look here for my NeXTstation Turbo Color recap: https://flic.kr/s/aHsjyr4fMY

And also here for my Sparcstation 20 PSU recap: https://flic.kr/s/aHsjS55diC

t-rexky
Posts: 26
Joined: Sun May 06, 2012 5:05 am
Location: Ontario, Canada

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby t-rexky » Mon Jun 05, 2017 7:47 pm

kjaer wrote:If you look at Suns, NeXTs, SGIs of the same vintage... you'll find they haven't used any SMT electrolytics anywhere. That's why they "don't leak".


Also absolutely not true. Please see my post above...

All of my vintage equipment has been very carefully recapped with modern equivalent electrolytics. They have been selected to fit physically and electrically, including ESR, ripple current rating, etc. Notwithstanding any potential surprises with batch issues this should make the equipment good for another ~30 years...

robespierre
Posts: 1554
Joined: Mon Sep 12, 2011 2:28 pm
Location: Boston

Re: Trying to Resurrect a Macintosh Color Classic

Unread postby robespierre » Mon Jun 05, 2017 8:58 pm

t-rexky wrote:Well, absolutely not true. The early SMD electrolytic capacitors are absolutely notorious for failing. NeXT used two alternate suppliers for theirs with one holding up reasonably well while the others leak like faucets. There is a large supply of new old stock NeXT sound boards and many of them are damaged because of leaked electrolyte. These are boards that have never been powered up since they left the factory.

Thanks for your perspective, I appreciate it. My NeXT mono slab (72-pin SIMMs) shows no signs of leakage around its SMD capacitors. I was not aware that they had other models that suffered from that problem, but I'm not surprised.
Since posting the comment you quoted, I've seen other types of equipment from the '80s that also have the problem. Even super-expensive gear from HP and Tektronix can be affected. It seems that the industry generally was still learning about the damage to the capacitors' seals caused by certain types of post-reflow cleaning. The fact that the SMDs are in close contact with the board and so are harder to clean, dry, and inspect also played a factor. Today many series advertise a "solvent resistance feature" to protect the seal from the cleaning process.
:PI: :O2: :Indigo2IMP: :Indigo2IMP:


Return to “Apple”

Who is online

Users browsing this forum: No registered users and 1 guest