NFS - giving "Invalid Argument" in 6.5.15 inst tools disc...

IRIX and IRIX software discussion including open source and commerical offerings.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
jc179
Posts: 117
Joined: Tue Feb 12, 2008 11:41 am
Location: Ancaster, Ontario, Canada

NFS - giving "Invalid Argument" in 6.5.15 inst tools disc...

Unread postby jc179 » Fri Mar 02, 2012 9:37 pm

Hi

I'm trying to reload irix on my indy; and really would like to avoid shuffling cd's. So i've booted the machine from the 6.5.15 inst tools cd, and dropped to a prompt. I have setup networking; and can ping, and tftp files back and forth, etc. When I try to mount the NFS share I get "nfs: Invalid argument". Note:my o2 6.5.22? can mount this NFS share without any issues. My command is simply "mount -t nfs 192.168.205.6:/data/sgi /a" where /data and /data/sgi are both 777'd, as well as /a on the mini root boot on the indy.

Is there some *weird* bug on 6.5.15? I've copied the line from my vfstab on the O2, "192.168.205.6:/data/sgi /data nfs ro,noquota 0 0", modified it and tried "mount /a" and get the same error "nfs: Invalid arguement".

the /etc/exports on the 205.6 NFS server is
"/data/sgi 192.168.205.0/24(no_subtree_check,ro,root_squash)" - but I have tried every possible option including sync, async; insecure, etc... :banghead:

In either case I tar'd up all the cd's contents I copied and taking the tar file over via tftp to the indy, to decompress to the hard drive and do the install that way.... Just trying to make things easier... though waiting for a 3.3 G file to copy over 10mbit also ZZZzzzz.

I've seen the posts on here regarding network installs, but the mounting stuff is completed when it boots or they're using rhosts and rlogin which seems to also be broken on the linux I'm using. I also set UDP anon ports to less than 32767 incase that was the issue, but to no avail.
edit #9999 - when I cat on my NFS server /var/lib/nfs/rmtab, I see for the indy's IP:
192.168.205.134:/data/sgi:0x00000005

I've been able to figure out that I *think* code #2 = access denied (i tried some directory that wasn't exported), but as for #5... humpf.

Any suggestions?

thanks

Jonathan
Indigo2 R10K 200 Mhz, 512 MB, Max Impact
O2 R12K 270 Mhz, 256 MB
Indy R5k 180 Mhz, XL24, 256MB
Sun Ultra1 Creator UltrasparcI 167 Mhz, 1 GB, 64bit, Custom Solaris 10 inst
Sun 280R dual 750 Mhz UltrasparcIII, 2GB
D1000 Disk array, LSI Logic FC array, Sun T3
Octane 195 Mhz single, mxe
Vax 4000 model 108, 256 mb
Alpha 500au, 18g, 512mb

robespierre
Posts: 681
Joined: Mon Sep 12, 2011 2:28 pm
Location: Boston

Re: NFS - giving "Invalid Argument" in 6.5.15 inst tools dis

Unread postby robespierre » Sat Mar 03, 2012 1:15 am

I haven't been able to use NFS from the miniroot either. Remember that NFS was a layered (read: extra cost) product, and the installer is supposed to work with minimal configuration.

Network installs use BootP to configure the network, TFTP to load the miniroot, and rshd(1M) to download software packages from the dist server. I don't think a NFS client is even supported.

You can enable all the required servers on an Irix machine (and some other Unices) by editing /etc/inetd.conf. See also the manual at http://techpubs.sgi.com/library/tpl/cgi ... /ch02.html
:PI: :O2: :Indigo2IMP: :Indigo2IMP:


Return to “IRIX and Software”

Who is online

Users browsing this forum: No registered users and 1 guest