IRIX 6.3 help, got messed up

IRIX and IRIX software discussion including open source and commerical offerings.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
geo
Posts: 525
Joined: Tue Jul 21, 2009 5:07 am
Location: Shenzhen, P.R.C

IRIX 6.3 help, got messed up

Unread postby geo » Tue Sep 27, 2011 11:50 pm

hi guys, really not my lucky day :( i tried to reconfigure the network setup of my O2 laptop but while doing it i messed up, i was stupid following the the 6.5 guide, but i was able to return it back to its original settings but i guess im too late, some weird icons appear on desktop covering the original icons like the Unix root folder, the dumpster.. at first symptom it was worst, when i access files or folders it wont let me coz i don't have permission? but only in GUI mode, and the circular icons something like the reference icon? shows up with weird names.. so i slowly return back the changes i made using command line. now i can access the filesystem, but still the icons are there :(

one file tho im not sure maybe i miss something? its the /etc/resolv.conf, it has different format than 6.5 right? geeez i really hope i still can return it back to normal

thanks in advance!
:Octane: (Sakura) :O2: (Sasuke) :1600SW: (Naruto) ... lil Jesse! (O2 laptop)
“Imagination is more important than knowledge.“ – A. Einstein

User avatar
geo
Posts: 525
Joined: Tue Jul 21, 2009 5:07 am
Location: Shenzhen, P.R.C

Re: IRIX 6.3 help, got messed up

Unread postby geo » Tue Sep 27, 2011 11:56 pm

btw, i didnt literally follow everything from the guide? i just use the guide as reference, but still im stupid not able to backup first my resolv.conf... i usually do that but geeez coz of my excitement to be able to access the network from this laptop, i committed a mortal sin as Unix user, always backup when doing something in root account..hate my clumsiness..
:Octane: (Sakura) :O2: (Sasuke) :1600SW: (Naruto) ... lil Jesse! (O2 laptop)
“Imagination is more important than knowledge.“ – A. Einstein

User avatar
geo
Posts: 525
Joined: Tue Jul 21, 2009 5:07 am
Location: Shenzhen, P.R.C

Re: IRIX 6.3 help, got messed up

Unread postby geo » Wed Sep 28, 2011 12:18 am

waaah this is exactly i'm experiencing now

http://groups.google.com/group/comp.sys ... cb2bc1313d

anyone had the same tragedy?
:Octane: (Sakura) :O2: (Sasuke) :1600SW: (Naruto) ... lil Jesse! (O2 laptop)
“Imagination is more important than knowledge.“ – A. Einstein

User avatar
jan-jaap
Posts: 4093
Joined: Thu Jun 17, 2004 11:35 am
Location: Wijchen, The Netherlands

Re: IRIX 6.3 help, got messed up

Unread postby jan-jaap » Wed Sep 28, 2011 1:25 am

Did you install any 6.3 patches or just the installation disc?
There's a 'recommended/required' patchset for 6.3, a POSIX patchset for 6.3 and a Y2K patchset for 6.3. Maybe your problem was fixed.
Now this is a deep dark secret, so everybody keep it quiet :)
It turns out that when reset, the WD33C93 defaults to a SCSI ID of 0, and it was simpler to leave it that way... -- Dave Olson, in comp.sys.sgi

Currently in commercial service: Image :Onyx2:(2x) :O3x02L:
In the museum: almost every MIPS/IRIX system.
Wanted: GM1 board for Professional Series GT graphics (030-0076-003, 030-0076-004)

User avatar
geo
Posts: 525
Joined: Tue Jul 21, 2009 5:07 am
Location: Shenzhen, P.R.C

Re: IRIX 6.3 help, got messed up

Unread postby geo » Wed Sep 28, 2011 3:59 am

jan-jaap wrote:Did you install any 6.3 patches or just the installation disc?
There's a 'recommended/required' patchset for 6.3, a POSIX patchset for 6.3 and a Y2K patchset for 6.3. Maybe your problem was fixed.


thanks for the reply jan-jaap, but i did not do a clean install and also did not install any patches, i just try to reconfigure the network of an existing running system :( but let me see maybe jesse already install some of the said patches?

if not, where can i download these patches? its in sgi support? ok let me check hope its still available but geeez if i got the patches i need to burn it to a CD and use an external CDROM drive..

hmmm is it possible in IRIX to have a backtrack mechanism? not sure if i ask the right question, just my point is can i reset the whole filesystem to a specific point of time?

will keep digging here..
:Octane: (Sakura) :O2: (Sasuke) :1600SW: (Naruto) ... lil Jesse! (O2 laptop)
“Imagination is more important than knowledge.“ – A. Einstein

SAQ
Posts: 5769
Joined: Wed Jul 19, 2006 8:37 am
Location: Renton, WA

Re: IRIX 6.3 help, got messed up

Unread postby SAQ » Wed Sep 28, 2011 8:45 am

No backtrack mechanism, but you can try a new account to see if it was in the account-specific setup files (if it is then you nuke your home directory's setup files and let IRIX recreate them).

One thing to look at is the hosts file, because if the machine isn't listed in the hosts file you'll have problems as some of the IRIX stuff "connects" to the local machine via network sockets (technically it should work via DNS, but that's a bit trickier so just use the hosts file). If that's fine continue to the other network stuff.

For 6.3 and 6.4 your best bet is to use the 6.2 help stuff if it isn't on TechPubs for 6.3 or 6.4, as both of those releases have more in common with 6.2 than 6.5.
Damn the torpedoes, full speed ahead!

Living proof that you can't keep a blithering idiot down.

:Indigo: :Octane: :Indigo2: :Indigo2IMP: :Indy: :PI: :O3x0: :ChallengeL: :O2000R: (single-CM)

User avatar
geo
Posts: 525
Joined: Tue Jul 21, 2009 5:07 am
Location: Shenzhen, P.R.C

Re: IRIX 6.3 help, got messed up

Unread postby geo » Wed Sep 28, 2011 10:24 pm

SAQ wrote:No backtrack mechanism, but you can try a new account to see if it was in the account-specific setup files (if it is then you nuke your home directory's setup files and let IRIX recreate them).

One thing to look at is the hosts file, because if the machine isn't listed in the hosts file you'll have problems as some of the IRIX stuff "connects" to the local machine via network sockets (technically it should work via DNS, but that's a bit trickier so just use the hosts file). If that's fine continue to the other network stuff.

For 6.3 and 6.4 your best bet is to use the 6.2 help stuff if it isn't on TechPubs for 6.3 or 6.4, as both of those releases have more in common with 6.2 than 6.5.


thanks saq! noted :) ok now i was able to return it back to normal coz i set everything i can remember back to its original setup. i just manually deleted the weird icons on the desktop. what i found is when i change the configuration for netork, after reboot, some "circular" icons is generated beneath each existing icons on the desktop. and those icons had weird naming like a 'y' with umlaut? hehe anyway icons was soso, worst was i cannot access folders using GUI.. but when i return every bits on network related files, it becomes ok but icons still there and need to remove manually.

one thing i noticed is even i change the domain name in resolv.conf and updated hosts file, still will use the older one. i think some running daemons need to be disabled first? coz i also notice NIS during bootup.. will keep digging and update you all..
:Octane: (Sakura) :O2: (Sasuke) :1600SW: (Naruto) ... lil Jesse! (O2 laptop)
“Imagination is more important than knowledge.“ – A. Einstein

User avatar
jan-jaap
Posts: 4093
Joined: Thu Jun 17, 2004 11:35 am
Location: Wijchen, The Netherlands

Re: IRIX 6.3 help, got messed up

Unread postby jan-jaap » Thu Sep 29, 2011 1:32 am

geo wrote:if not, where can i download these patches? its in sgi support? ok let me check hope its still available but geeez if i got the patches i need to burn it to a CD and use an external CDROM drive..

Once upon a time, they were on the SGI public ftp server, and widely mirrored. Harry 'deBug' hosted them for a while on his Nekoware mirror, but it seems the server is unreachable.

I put them on my own FTP server: ftp://ftp.jurassic.nl/pub/irix/patches/ ... _required/
Now this is a deep dark secret, so everybody keep it quiet :)
It turns out that when reset, the WD33C93 defaults to a SCSI ID of 0, and it was simpler to leave it that way... -- Dave Olson, in comp.sys.sgi

Currently in commercial service: Image :Onyx2:(2x) :O3x02L:
In the museum: almost every MIPS/IRIX system.
Wanted: GM1 board for Professional Series GT graphics (030-0076-003, 030-0076-004)

User avatar
geo
Posts: 525
Joined: Tue Jul 21, 2009 5:07 am
Location: Shenzhen, P.R.C

Re: IRIX 6.3 help, got messed up

Unread postby geo » Thu Sep 29, 2011 4:16 am

jan-jaap wrote:Once upon a time, they were on the SGI public ftp server, and widely mirrored. Harry 'deBug' hosted them for a while on his Nekoware mirror, but it seems the server is unreachable.

I put them on my own FTP server: ftp://ftp.jurassic.nl/pub/irix/patches/ ... _required/

waaah thanks jan-jaap!! you're the man! ok will try download later and burn to CD
:Octane: (Sakura) :O2: (Sasuke) :1600SW: (Naruto) ... lil Jesse! (O2 laptop)
“Imagination is more important than knowledge.“ – A. Einstein

SAQ
Posts: 5769
Joined: Wed Jul 19, 2006 8:37 am
Location: Renton, WA

Re: IRIX 6.3 help, got messed up

Unread postby SAQ » Thu Sep 29, 2011 5:19 pm

geo wrote:what i found is when i change the configuration for netork, after reboot, some "circular" icons is generated beneath each existing icons on the desktop. and those icons had weird naming like a 'y' with umlaut? hehe anyway icons was soso, worst was i cannot access folders using GUI.. but when i return every bits on network related files, it becomes ok but icons still there and need to remove manually.


Short answer: the O2 didn't know how to find itself on the network any longer, so the desktop (and system admin programs) get screwed up. Make sure you have the computer put in hosts.
Damn the torpedoes, full speed ahead!

Living proof that you can't keep a blithering idiot down.

:Indigo: :Octane: :Indigo2: :Indigo2IMP: :Indy: :PI: :O3x0: :ChallengeL: :O2000R: (single-CM)


Return to “IRIX and Software”

Who is online

Users browsing this forum: No registered users and 1 guest