Help with Octane's Digital Video card on Octane2 MXE

Video, software tools and techniques on SGI systems.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
alestes
Posts: 5
Joined: Fri Dec 26, 2008 6:50 am

Help with Octane's Digital Video card on Octane2 MXE

Unread postby alestes » Fri Jan 30, 2009 12:13 pm

Hi, I'm trying to install a Octane's Digital Video card installation on an Octane2 MXE under IRIX 6.5.28.
I did a clean installation of Irix 6.5.28.After that I tried to install all of the drivers/subsystems for OCTANE Digital Video and IMPACT Video (Overlays 6.5.28 install disk nº 2-dist/unbundled) using the software manager control panel but it tells me that there are many conflicts.
After that I tried to activate the command ¨rulesoverride¨ and after that I can install these drivers .
Then I installed physically the card into the octane2 attached to the MXE card.
After restart the system I run a shell window and I couldn't see the Octane's Digital Video card in hinv.
What I'm doing wrong?
I tested this card in another octane that runs under IRIX 6.5.17m and it works OK
Could someone tell me the correct steps that I followed for this card installation please?

Thank you

alestes
Posts: 5
Joined: Fri Dec 26, 2008 6:50 am

Help with Octane's Digital Video card on Octane2 MXE

Unread postby alestes » Sat Jan 31, 2009 3:12 am

Hi, I'm trying to install a Octane's Digital Video card installation on an Octane2 MXE under IRIX 6.5.28.
I did a clean installation of Irix 6.5.28.After that I tried to install all of the drivers/subsystems for OCTANE Digital Video and IMPACT Video (Overlays 6.5.28 install disk nº 2-dist/unbundled) using the software manager control panel but it tells me that there are many conflicts.
After that I tried to activate the command ¨rulesoverride¨ and after that I can install these drivers .
Then I installed physically the card into the octane2 attached to the MXE card.
After restart the system I run a shell window and I couldn't see the Octane's Digital Video card in hinv.
What I'm doing wrong?
I tested this card in another octane that runs under IRIX 6.5.17m and it works OK
Could someone tell me the correct steps that I followed for this card installation please?

Thank you

Moderator Edit: Merged two identical topics. <recondas>
@alestes Please do not cross post.

User avatar
recondas
Moderator
Moderator
Posts: 5312
Joined: Sun Jun 06, 2004 5:55 pm
Location: NC - USA

Re: Help with Octane's Digital Video card on Octane2 MXE

Unread postby recondas » Sat Jan 31, 2009 5:03 am

alestes wrote: I did a clean installation of Irix 6.5.28.After that I tried to install all of the drivers/subsystems for OCTANE Digital Video and IMPACT Video (Overlays 6.5.28 install disk nº 2-dist/unbundled) using the software manager control panel but it tells me that there are many conflicts. After that I tried to activate the command ¨rulesoverride¨ and after that I can install these drivers.

What conflicts did you override? I don't believe it should have been necessary to use rulesoverride to install the hardware you've described.

In most cases, the software from the unbundled directory of CD 2 of the overlay set are "updates" to software from the base IRIX 6.5 install files. In some cases the base install files are on the IRIX 6.5 base install disks, in other cases an additional CD or file is needed.

*If* the base software files were what you overrode, you have an incomplete install. The release notes for "Impactvideo" include a list of the required software subsystems <and prerequisites> http://techpubs.sgi.com/library/tpl/cgi ... nformation


You might try using the versions command <with the necessary subsystem name(s) as a modifier> to see what subsystem you do <and don't> have installed.
***********************************************************************
Welcome to ARMLand - 0/0x0d00
running...(sherwood-root 0607201829)
* InfiniteReality/Reality Software, IRIX 6.5 Release *
***********************************************************************

User avatar
joerg
Posts: 2223
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

Re: Help with Octane's Digital Video card on Octane2 MXE

Unread postby joerg » Sat Jan 31, 2009 5:25 am

You need the the "base" Octane video drivers in combination with the current files from your Overlay (/unbundeld). The first one can be fetch from Ian's "depot".

Regards
Joerg

User avatar
mapesdhs
Posts: 2299
Joined: Mon Nov 10, 2003 4:17 pm
Location: Edinburgh, Scotland
Contact:

Re: Help with Octane's Digital Video card on Octane2 MXE

Unread postby mapesdhs » Tue Feb 03, 2009 2:45 am

alestes wrote:After that I tried to activate the command ¨rulesoverride¨ and after that I can install these drivers .


Bad idea. If it's giving conflicts then something is missing. Under normal circumstances, for installing a digvid, there should
not be any conflicts, so it's more likely what you've done is override a perfectly legitimate OS warning about the sw setup not
being correct, so no wonder it's not working.

Best thing to do is remove the video drivers and try again, first install various bits that are not installed by default such as
some N32 libs, etc. And then resolve the conflicts for the digvid drivers properly, follow what they say and deal with them.

Ian.
(07/Mar/2015) FREE! (collection only) 16x Sagitta 12-bay dual-channel U160 SCSI JBOD units.
Email, phone or PM for details, or see my forum post.
mapesdhs@yahoo.com
+44 (0)131 476 0796

User avatar
jan-jaap
Posts: 4161
Joined: Thu Jun 17, 2004 11:35 am
Location: Wijchen, The Netherlands

Re: Help with Octane's Digital Video card on Octane2 MXE

Unread postby jan-jaap » Tue Feb 03, 2009 2:55 am

alestes wrote:After that I tried to activate the command ¨rulesoverride¨ and after that I can install these drivers .
Then I installed physically the card into the octane2 attached to the MXE card.

Why not install the hardware first and then the software?
Often software only installs if the hardware is present. Not sure if this is true for Digital Video, though.
Now this is a deep dark secret, so everybody keep it quiet :)
It turns out that when reset, the WD33C93 defaults to a SCSI ID of 0, and it was simpler to leave it that way... -- Dave Olson, in comp.sys.sgi

Currently in commercial service: Image :Onyx2:(2x) :O3x02L:
In the museum: almost every MIPS/IRIX system.
Wanted: GM1 board for Professional Series GT graphics (030-0076-003, 030-0076-004)

User avatar
mapesdhs
Posts: 2299
Joined: Mon Nov 10, 2003 4:17 pm
Location: Edinburgh, Scotland
Contact:

Re: Help with Octane's Digital Video card on Octane2 MXE

Unread postby mapesdhs » Tue Feb 03, 2009 3:58 am

jan-jaap wrote:Why not install the hardware first and then the software?


Must confess, that's the order in which I normally do it.

Ian.

User avatar
recondas
Moderator
Moderator
Posts: 5312
Joined: Sun Jun 06, 2004 5:55 pm
Location: NC - USA

Re: Help with Octane's Digital Video card on Octane2 MXE

Unread postby recondas » Tue Feb 03, 2009 4:35 am

alestes wrote:Hi, I'm trying to install a Octane's Digital Video card installation on an Octane2 MXE under IRIX 6.5.28.
I did a clean installation of Irix 6.5.28.After that I tried to install all of the drivers/subsystems for OCTANE Digital Video and IMPACT Video (Overlays 6.5.28 install disk nº 2-dist/unbundled) using the software manager control panel but it tells me that there are many conflicts. After that I tried to activate the command ¨rulesoverride¨ and after that I can install these drivers .
Ok - let's run through this one more time.

Those software conflicts are IRIX's way of telling you you're about to make a mistake. As administrator, you get to override IRIX, but if you do you better know more about the issue than IRIX. So in general, it's a good idea to pay attention and comply with the request IRIX has made.

What are the specific conflicts? As has already been mentioned, the 'drivers' in the Unbundled directory of the second install disk are updates to the original 'driver' files - they don't provide a complete install <and that fact may well be the source of your conflict messages>. If that is indeed the issue, then you can probably obtain the necessary original driver files here: http://futuretech.blinkenlights.nl/depot

The specific file for the Octane Digital Video Option board is:

Code: Select all

octane_iv_6.5.tar            3799040      With IRIX 6.5, for IMPACT Video and Octane Digital Video [Octane/IMPACT VIDEO for 6.5]
If you haven't already installed it, you'll also need dmedia_eoe, the base files are located on the Foundation 1 CD, the files needed to update dmedia_eoe to match your current IRIX revision are in the dist directory of the second Overlay CD <the same CD that holds the Unbundled directory>. The <software Prerequisites are listed in the release notes for "impactvideo" <there's a link in my first post>:

Code: Select all

2.4  Prerequisites

       OCTANE Digital Video and   IMPACT Video requires the following
       software:

     + OCTANE Digital Video and IMPACT Digital Media 6.5
       (impactdm),

     + Digital Media Execution Environment   6.5 (dmedia_eoe).



alestes wrote:Could someone tell me the correct steps that I followed for this card installation please?
You can download the 'Octane Digital Video and Octane Compression Installation Guide from SGI's Technical Publications Library: http://techpubs.sgi.com/library/tpl/cgi ... 7-3466-001

The installation guide describes installing the Digital Video board *before* installing the software <drivers>, so if you were attempting to install the software first, that could be another possible cause for installation conflicts.

alestes wrote:I tested this card in another octane that runs under IRIX 6.5.17m and it works OK
It is also possible that the suspect Octane has a damaged XIO connector, or the Digital Video board isn't making good contact with the XIO connector. There are a series of diagnotic LEDs on the front of the Octane - you''ll have to remove the front fascia panel to see them.

Using the information concerning which LED corresponds to which XIO slot, you might be able to determine if the Digital Video board is making contact <at a hardware level>: viewtopic.php?f=3&t=3654&p=27401&#p27401 Using that example, if you have the Digital Video board installed in XIO slot "B" <the slot numbers are printed on the carrier, and proper slot selection is covered in the Installation Guide>, you would expect that LED "QB" <right column, center LED> would be illuminated.
***********************************************************************
Welcome to ARMLand - 0/0x0d00
running...(sherwood-root 0607201829)
* InfiniteReality/Reality Software, IRIX 6.5 Release *
***********************************************************************

User avatar
mapesdhs
Posts: 2299
Joined: Mon Nov 10, 2003 4:17 pm
Location: Edinburgh, Scotland
Contact:

Re: Help with Octane's Digital Video card on Octane2 MXE

Unread postby mapesdhs » Tue Feb 03, 2009 6:12 am

And just for reference, if you're in the UK then there's my main site source at:

http://www.sgidepot.co.uk/depot/

or if you're in the US/Canada:

http://vintagecomputers.info/depot/


My site has the base driver files (ie. the drivers for the original June 1998 version of 6.5). If you're using a later
6.5.x update, eg. 6.5.26, then you must read into swmgr both the base drivers and, as recondas says, the 6.5.x
updates to those drivers which can be found on the 2nd 6.5.x Overlays CD in the /CDROM/dist/unbundled directory.

Thus, here is what I do after installing the video board in the system and assuming I already have the base driver
archive to hand (in this case from my OS installation disk mounted on /i, files included as part of my SGI Gifts CD
which is copied onto the disk under /i/cds/gifts) and the 6.5.x 2nd Overlays CD is already inside the CDROM:

Code: Select all

mkdir /usr/local/src/videodrivers
cd /usr/local/src/videodrivers
cp /i/cds/gifts/VideoDrivers/6.5/octane_iv_6.5.tar.gz .
gunzip octane_iv_6.5.tar.gz
tar -xvf octane_iv_6.5.tar
rm octane_iv_6.5.tar
cp /CDROM/dist/unbundled/impactvideo* .
cp /CDROM/dist/unbundled/impactdm* .
swmgr -f .


Then just install the products as shown, never any conflicts.


I do intend at some point to add complete 6.5.x driver bundles to my site, but that'll be a while yet. Don't have time atm.

Ian.


Return to “SGI: Video”

Who is online

Users browsing this forum: No registered users and 0 guests