Configure

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
zizban
Moderator
Moderator
Posts: 1359
Joined: Sun Dec 21, 2003 6:59 pm
Location: Cheshire, MA
Contact:

Configure

Unread postby zizban » Tue Dec 07, 2004 4:54 pm

I am trying to compile Nebula and configure barfs with an error:
ld32: FATAL 9: I/O error (/usr/lib32/mips3/ctrl.0) No such file or directory.

Configure failed program was /*confdefs.h*/

I just installed the developer base cd, did I miss something?

User avatar
Hakimoto
Moderator
Moderator
Posts: 2483
Joined: Sun Mar 30, 2003 5:29 am
Location: Kabul, Afghanistan, Asia
Contact:

Unread postby Hakimoto » Tue Dec 07, 2004 5:32 pm

Search your harddrive for that file. I had that with another program the other day (what was it... aehm... yudit? i don't remember) and the final linking looked for a shared object in a directory that doesn't exist. Dunno why, nothing as to that in the makefile. I made a symlink from the real file to the "supposed" one, it compiled, linked, complained it found ambiguous shared objects and used the real one instead. Maybe that could work for you. Make sure to remove the symlink afterwards for cleanliness.

User avatar
zizban
Moderator
Moderator
Posts: 1359
Joined: Sun Dec 21, 2003 6:59 pm
Location: Cheshire, MA
Contact:

Unread postby zizban » Tue Dec 07, 2004 6:23 pm

I ran it as root and what it really wants is a mips pro license. :?

User avatar
miunk
Posts: 346
Joined: Sun Feb 08, 2004 5:17 pm
Location: quito

Unread postby miunk » Tue Dec 07, 2004 6:46 pm

no, if you are using gcc you may need to set the CC environment variable "CC=gcc" or use a configure flag if available "--with-cc=gcc" or even edit the configure script...

You'll need to insure you installed everything correctly, devel foundation/libs, etc. If not you'll probably get "c compiler cannot create executables" error.

User avatar
zizban
Moderator
Moderator
Posts: 1359
Joined: Sun Dec 21, 2003 6:59 pm
Location: Cheshire, MA
Contact:

Unread postby zizban » Tue Dec 07, 2004 7:37 pm

Oh I remember now; I got the development base installed but the libs all conflicted with eoe.sw.base (IRIX Base Execution Enviroment 1279214320). How do I get around this?

User avatar
miunk
Posts: 346
Joined: Sun Feb 08, 2004 5:17 pm
Location: quito

Unread postby miunk » Tue Dec 07, 2004 7:51 pm

Check the libs cd. Mount it look around the filesystem. I think it is set up something like the NFS cd, where you need to point inst to a non-standard directory.

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8001
Joined: Thu Jan 23, 2003 2:31 am
Location: Pleasanton, California
Contact:

Unread postby nekonoko » Tue Dec 07, 2004 8:01 pm

zizban wrote:Oh I remember now; I got the development base installed but the libs all conflicted with eoe.sw.base (IRIX Base Execution Enviroment 1279214320). How do I get around this?


It sounds like you didn't feed your current overlay CDs alongside your development libs/IRIX base. For example - if you have IRIX 6.5.22 currently installed but with no development environment, you will need to re-insert your base IRIX 6.5 CDs (which includes your development CDs) AND your IRIX 6.5.22 overlays to resolve any conflicts.
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

User avatar
zizban
Moderator
Moderator
Posts: 1359
Joined: Sun Dec 21, 2003 6:59 pm
Location: Cheshire, MA
Contact:

Unread postby zizban » Tue Dec 07, 2004 8:24 pm

It didn't ask for any overlays but I'm game to try it. Would a clean install from scratch do any good?

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8001
Joined: Thu Jan 23, 2003 2:31 am
Location: Pleasanton, California
Contact:

Unread postby nekonoko » Tue Dec 07, 2004 11:28 pm

zizban wrote:It didn't ask for any overlays but I'm game to try it. Would a clean install from scratch do any good?


It won't specifically ask for them by name, but that's how you resolve the conflict. If you'd prefer to install from scratch that would work as well.
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

User avatar
dexter1
Moderator
Moderator
Posts: 2062
Joined: Thu Feb 20, 2003 7:57 am
Location: Voorburg, The Netherlands
Contact:

Re: Configure

Unread postby dexter1 » Wed Dec 08, 2004 6:32 am

zizban wrote:I am trying to compile Nebula ...


You should consider contacting Gandalf. He has built Nebula and wants people to test his binary.

User avatar
zizban
Moderator
Moderator
Posts: 1359
Joined: Sun Dec 21, 2003 6:59 pm
Location: Cheshire, MA
Contact:

Unread postby zizban » Wed Dec 08, 2004 8:07 am

I've tried contacting Gandalf but to no avail. Anyway, I just got my set of Irix cds and I wanted to try them out. I don't really want to clean reinstall since I've heard horror stories so I'll try Neko's suggestion first.

User avatar
semi-fly
Posts: 786
Joined: Fri Feb 21, 2003 6:29 am
Location: Ypsitucky, MI
Contact:

Unread postby semi-fly » Wed Dec 08, 2004 8:53 am

zizban wrote:I've tried contacting Gandalf but to no avail. Anyway, I just got my set of Irix cds and I wanted to try them out. I don't really want to clean reinstall since I've heard horror stories so I'll try Neko's suggestion first.


I recently had a situation similar to yours, and re-installing the development libs plus the *.22 overlays solved the problem for me. :wink:
configure complete, now type 'make' and pray.

gandalf
Posts: 116
Joined: Wed Aug 25, 2004 1:08 am
Location: Italy
Contact:

Unread postby gandalf » Thu Dec 09, 2004 4:34 pm

hmm. No avail? :)
catch me in IRC... and I'll pass you a binary.. But on the long run, you better fix up your box probably.
Zhile configure works stright away on irix 4.0, on 6.5 you need to point it to the motif includes 2.1, using the appriopriate configure options (configure --help)

-R

User avatar
zizban
Moderator
Moderator
Posts: 1359
Joined: Sun Dec 21, 2003 6:59 pm
Location: Cheshire, MA
Contact:

Unread postby zizban » Thu Dec 09, 2004 6:18 pm

I clean reinstalled, which was interesting. Could they make the install process any more cryptic? It went okay after I figured out (after an hour or so of trying) that my cd wasn't bootable. I did fubar installing the overlays to to go from 6.5.0 to 6.5.13, things you learn. So reinstalled irix again and did the overlays from miniroot.

All is well. :D

hamei
Posts: 9888
Joined: Tue Feb 24, 2004 5:10 pm

Unread postby hamei » Thu Dec 09, 2004 8:36 pm

zizban wrote: Could they make the install process any more cryptic?


If they really really tried they probably could, but now that Irix is on the back burner we'll probably have to make do with the crypticity level we already have :P


Return to “SGI: Development”

Who is online

Users browsing this forum: joostp and 1 guest