spaceball installation issue - support under blender ?

3D/2D CGI and the tools used in their creation (Maya, Photoshop, Blender, GIMP, etc.).
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
yungjoon
Posts: 97
Joined: Thu Jun 03, 2004 7:53 am
Location: France

spaceball installation issue - support under blender ?

Unread postby yungjoon » Tue Feb 19, 2008 9:59 am

Hi all,

I have 2 questions.

I tryied to install a compaq 3003 spaceball (latest xdriver) with my Octane (irix 6.5.27). During installation the driver detects correctly the spaceball on serial port 1 but after I have a blank window in xdriver control windows (can't see the test cube). Is there something to do before installation or something particuliar in installation?

Is there a way to use it in blender ?

Thanks...

jdboyd
Posts: 562
Joined: Thu Aug 21, 2003 11:47 am
Location: Southern PA

Re: spaceball installation issue - support under blender ?

Unread postby jdboyd » Tue Feb 19, 2008 3:53 pm

yungjoon wrote:Hi all,

I have 2 questions.

I tryied to install a compaq 3003 spaceball (latest xdriver) with my Octane (irix 6.5.27). During installation the driver detects correctly the spaceball on serial port 1 but after I have a blank window in xdriver control windows (can't see the test cube). Is there something to do before installation or something particuliar in installation?

Is there a way to use it in blender ?


There is a patch for that floating around that you can google, but I suspect that patch has never been tested on Irix. There are licensing issues that keep it from being integrated, as the patch relies on the official spaceball drivers.

I would love to see someone offer a patch that instead talks directly to the older serial units. Then maybe we would have a prayer of it being integrated.

User avatar
skywriter
Posts: 3104
Joined: Fri Mar 14, 2003 5:22 am
Location: living in a linux-blunderland
Contact:

Re: spaceball installation issue - support under blender ?

Unread postby skywriter » Wed Feb 20, 2008 9:15 am

way back before blender became peecee heavy, Danial Dunbar made a script & module to use dials and buttons with blender, it would have been easy then to use a space ball as well. I'm afraid we would have to add it ourselves since we seem to be the only ones blessed with superior hardware.
:Skywriter:

DECUS Member 368596

jdboyd
Posts: 562
Joined: Thu Aug 21, 2003 11:47 am
Location: Southern PA

Re: spaceball installation issue - support under blender ?

Unread postby jdboyd » Wed Feb 20, 2008 10:14 am

skywriter wrote:way back before blender became peecee heavy, Danial Dunbar made a script & module to use dials and buttons with blender, it would have been easy then to use a space ball as well. I'm afraid we would have to add it ourselves since we seem to be the only ones blessed with superior hardware.


This brings up an important looming point.

Blender is being completely redone for version 2.5. This is a good thing, except that if we don't start helping soon, we might find it is terrible to make it work on Irix. The approach being taken is to develop a new small framework for events and windows and such, and then to port the existing code base onto the new framework. I don't believe that they are looking to heavily shake up the actual scene data structures.

The relevance to the topic is that the point of the restructuring is largely to redo how events are handled to make it easier for actions to be triggered by any source, including external controllers. It should also make it simpler to support undo/redo or modeling history type actions.

User avatar
skywriter
Posts: 3104
Joined: Fri Mar 14, 2003 5:22 am
Location: living in a linux-blunderland
Contact:

Re: spaceball installation issue - support under blender ?

Unread postby skywriter » Thu Feb 21, 2008 8:33 am

the blender development community historically has not been receptive to make any allowances for IRIX. if you want it done you have to get in and do it yourself, and watch it like a hawk because people will unknowingly break it and you'll constantly be fixing things just to stay in place. adding advanced SGI/IRIX features is usually impossible due to the maintenance of the basic IRIX functionality.

this stems from the wildly variable open source framework that requires retooling everything for IRIX; both blender code and development framework.

i ran out of time years ago.


btw Ton forbid any new platform specific features like dials and buttons and spaceballs because they were not portable across platforms. apparently the fact that everything else was like that for IRIX escaped him. by that time he was off IRIX and on the Mac.
:Skywriter:

DECUS Member 368596

jdboyd
Posts: 562
Joined: Thu Aug 21, 2003 11:47 am
Location: Southern PA

Re: spaceball installation issue - support under blender ?

Unread postby jdboyd » Thu Feb 21, 2008 10:45 am

skywriter wrote:the blender development community historically has not been receptive to make any allowances for IRIX. if you want it done you have to get in and do it yourself, and watch it like a hawk because people will unknowingly break it and you'll constantly be fixing things just to stay in place. adding advanced SGI/IRIX features is usually impossible due to the maintenance of the basic IRIX functionality.

this stems from the wildly variable open source framework that requires retooling everything for IRIX; both blender code and development framework.


There aren't really much in the way of advanced Irix features that I want any more. Personally I no longer really care about trying to get movie lib support or live video output.

skywriter wrote:i ran out of time years ago.


Understandable.

skywriter wrote:btw Ton forbid any new platform specific features like dials and buttons and spaceballs because they were not portable across platforms. apparently the fact that everything else was like that for IRIX escaped him. by that time he was off IRIX and on the Mac.


I am hoping that after this redo, it will be easier to implement support for various platform specific controllers using python. The spaceball patch (which I believe is for windows) is a C patch that requires a recompile and that seems unacceptable to me.

sgefant
Posts: 31
Joined: Mon Jan 14, 2008 4:59 pm

Re: spaceball installation issue - support under blender ?

Unread postby sgefant » Fri Feb 29, 2008 1:10 pm

Some time ago I wrote a plugin for blender that uses libsball (http://jedi.ks.uiuc.edu/~johns/projects/libsball/) instead of 3Dconnexion's drivers for serial spaceball devices. Unfortunately I wasn't able to test it on IRIX, as I don't have a compiler license.

You can get the plugin here: http://www.quitch.net/~stefanga/blender/sball.tgz

Note: This requires a build of the ndof svn branch of blender. I don't think an IRIX build is available, so unless you're able to build blender yourself, it probably is easier to wait for blender 2.5...

greetings,
sgefant

User avatar
skywriter
Posts: 3104
Joined: Fri Mar 14, 2003 5:22 am
Location: living in a linux-blunderland
Contact:

Re: spaceball installation issue - support under blender ?

Unread postby skywriter » Wed Mar 05, 2008 1:01 pm

sgefant wrote: I don't think an IRIX build is available, so unless you're able to build blender yourself, it probably is easier to wait for blender 2.5...


yeah that way spend all your time trying to port all the development infrastructure build systems and freeware GNU/libtool crap that the open source crowd will change in 2.5.

you'll never get your spaceball that way.

go back to 1.80 when it was simple to build and use.
:Skywriter:

DECUS Member 368596

jdboyd
Posts: 562
Joined: Thu Aug 21, 2003 11:47 am
Location: Southern PA

Re: spaceball installation issue - support under blender ?

Unread postby jdboyd » Wed Mar 05, 2008 8:18 pm

skywriter wrote:
sgefant wrote: I don't think an IRIX build is available, so unless you're able to build blender yourself, it probably is easier to wait for blender 2.5...


yeah that way spend all your time trying to port all the development infrastructure build systems and freeware GNU/libtool crap that the open source crowd will change in 2.5.

you'll never get your spaceball that way.

go back to 1.80 when it was simple to build and use.


I didn't know that the 1.8 source was available. I though it didn't get released until somewhere in the 2.x series, like maybe 2.23?

If you know where the 1.8 source is, could you point it out so we could start a blender 1.8 neko package for MIPS3 if nothing else? That was before IrisGL support was dropped, right?

sgefant
Posts: 31
Joined: Mon Jan 14, 2008 4:59 pm

Re: spaceball installation issue - support under blender ?

Unread postby sgefant » Fri Mar 07, 2008 6:48 pm

skywriter wrote:
sgefant wrote: I don't think an IRIX build is available, so unless you're able to build blender yourself, it probably is easier to wait for blender 2.5...


yeah that way spend all your time trying to port all the development infrastructure build systems and freeware GNU/libtool crap that the open source crowd will change in 2.5.

you'll never get your spaceball that way.

go back to 1.80 when it was simple to build and use.


The problem isn't "the open source crowd" changing stuff so that blender won't work on IRIX, it's lack of developers and access to systems.

I'd be more than happy if there was a neko_blender supporting all the nifty features sgi machines provide, but if nobody is writing the code for it, it won't happen.

cheers,
sgefant

PS: don't worry, I'll get my spaceball working

User avatar
skywriter
Posts: 3104
Joined: Fri Mar 14, 2003 5:22 am
Location: living in a linux-blunderland
Contact:

Re: spaceball installation issue - support under blender ?

Unread postby skywriter » Sat Mar 08, 2008 7:45 pm

sgefant wrote:
skywriter wrote:
sgefant wrote: I don't think an IRIX build is available, so unless you're able to build blender yourself, it probably is easier to wait for blender 2.5...


yeah that way spend all your time trying to port all the development infrastructure build systems and freeware GNU/libtool crap that the open source crowd will change in 2.5.

you'll never get your spaceball that way.

go back to 1.80 when it was simple to build and use.


The problem isn't "the open source crowd" changing stuff so that blender won't work on IRIX, it's lack of developers and access to systems.

I'd be more than happy if there was a neko_blender supporting all the nifty features sgi machines provide, but if nobody is writing the code for it, it won't happen.

cheers,
sgefant

PS: don't worry, I'll get my spaceball working


why don't you write code for neko then?
i was involve with blender since 1.23. i'm well aware why the irix blender wasn't getting update because i was the only one doing it. any if you don't remember that then you really don't know what happened. hos tried for a while but lost interest. why don't you ask Ton what happened? read the blender developers list a little more carefully. i offered plenty of systems. NOBODY CARED about maintaining compatibility with IRIX.

if you're not going to help us mr post 2, then piss off back to #blenderchat. we can fix it ourselves if we care.


btw wtf reason do you have for being here for the first time after 8 years of IRIX problems?
:Skywriter:

DECUS Member 368596

sgefant
Posts: 31
Joined: Mon Jan 14, 2008 4:59 pm

Re: spaceball installation issue - support under blender ?

Unread postby sgefant » Sun Mar 09, 2008 4:09 pm

skywriter wrote:why don't you write code for neko then?
i was involve with blender since 1.23. i'm well aware why the irix blender wasn't getting update because i was the only one doing it. any if you don't remember that then you really don't know what happened. hos tried for a while but lost interest. why don't you ask Ton what happened? read the blender developers list a little more carefully. i offered plenty of systems. NOBODY CARED about maintaining compatibility with IRIX.

if you're not going to help us mr post 2, then piss off back to #blenderchat. we can fix it ourselves if we care.


I'm quite aware of the past problems, but for me currently the biggest problem is that there's only one person either willing or able to provide an IRIX build of blender. I just rencently got an IRIX machine (unfortunately without compiler license), so my interest in being able to run blender on it was rather therotical.

In what way can I help you?

skywriter wrote:btw wtf reason do you have for being here for the first time after 8 years of IRIX problems?


My main reason was to offer a way to get serial spaceballs working with blender on IRIX. Apparently interest is not as high as I thought.

greetings,
sgefant

User avatar
skywriter
Posts: 3104
Joined: Fri Mar 14, 2003 5:22 am
Location: living in a linux-blunderland
Contact:

Re: spaceball installation issue - support under blender ?

Unread postby skywriter » Sun Mar 09, 2008 8:40 pm

sgefant wrote:
My main reason was to offer a way to get serial spaceballs working with blender on IRIX. Apparently interest is not as high as I thought.

greetings,
sgefant


sgi suppport is always appreciated. there is only one of us able to commit to compiling the code and donate to the blender foundation or create a nekochan version at any one time (if that). if you can help thank you from everyone here.

a generic method of adapting spaceballs and dials + buttons would be the best. such input applicable to whatever is available to program. in the past it was whatever python could get to, which i believe is significantly enhanced over what daniel had available through the X-window protocol. i believe a simple spaceball implementation is best for object manipulation - but let the imagination fly.

i'm am very impressed with the progress with the progress the blender development team, and the open movie projects have produced. i only wish, if a bit bitterly, that more of it came back to the SGI community for the percentage donated to free the code (by me).

i maintain both windows and linux interests, but SGI is my platform of choice because of the large investment in digital audio i have.

any help is certainly appreciated. what machine did you get, what version of IRIX do you have? most importantly did you get a set of 6.5 base CD's? what spaceball model did you get? have you tried to a MIPS/GCC build? it used to be possible.
:Skywriter:

DECUS Member 368596

User avatar
squeen
Moderator
Moderator
Posts: 2932
Joined: Fri May 09, 2003 6:10 am
Location: Maryland, USA

Re: spaceball installation issue - support under blender ?

Unread postby squeen » Mon Mar 10, 2008 4:23 am

The libsball link is niffty. I use the Spaceball 5000 and I'm hoping it's supported.

With the 5000 at least, the drivers provided by the manufacturer are X11 drivers. So, you start their app and then any other app change get spaceball input via Xevents sent to it's application window. I added the code to our scene graph library in order to use the spaceball, and it works on Linux and/or IRIX 'cause it's just X events.

What is neat about libsball is that I might be able to by-pass (manually) starting their xdriver application and just have our scene graph app talk to the serial port directly.

Now the USB 5000's are probably another story...

User avatar
skywriter
Posts: 3104
Joined: Fri Mar 14, 2003 5:22 am
Location: living in a linux-blunderland
Contact:

Re: spaceball installation issue - support under blender ?

Unread postby skywriter » Mon Mar 10, 2008 11:14 am

squeen wrote:So, you start their app and then any other app change get spaceball input via Xevents sent to it's application window.


this is the way Daniel did it way back when. would be nice to get more direct path though. i remember some problems with window focus etc......
:Skywriter:

DECUS Member 368596


Return to “SGI: Computer Graphics”

Who is online

Users browsing this forum: No registered users and 0 guests