KDE 3.2

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
LoWeN
Posts: 256
Joined: Thu Aug 28, 2003 11:45 am
Location: Belgium

KDE 3.2

Unread postby LoWeN » Tue Jan 20, 2004 4:27 am

Hello,

Would anyone be interrested in trying to port KDE 3.2 to irix
as soon as it will be available?
I would but I am not sure I have enough knowledge to do that...
And the job sounds pretty big.

@+

LoWeN
UX powered

User avatar
whiter
Posts: 975
Joined: Tue Apr 29, 2003 2:02 pm
Location: Melbourne, Australia
Contact:

Unread postby whiter » Tue Jan 20, 2004 4:35 am

I'm sure some people will go give that a try. Including me :)
Shall I describe it to you? Or do you want me to get you a box?

User avatar
Dubhthach
Posts: 779
Joined: Tue Oct 07, 2003 8:16 am
Location: Bláth Cliath, Éire

Unread postby Dubhthach » Tue Jan 20, 2004 3:43 pm

Well i will say that k3b is prolly the best burner software on Linux so if that's included in your port i'd be one happy guy

Now if only someone would port gnome2.4/6 port as well, i do translation of it into irish.
Epiphany is one of the first web browsers nearly fully translated into irish

http://frink.nuigalway.ie/~dubhthach/gaeilge/epiphany1.1.3/

LoWeN
Posts: 256
Joined: Thu Aug 28, 2003 11:45 am
Location: Belgium

Unread postby LoWeN » Thu Jan 22, 2004 2:01 am

Hello,

Do you think we should try with qt 3.3? Or latest qt 3.2?

@+

LoWeN
UX powered

LoWeN
Posts: 256
Joined: Thu Aug 28, 2003 11:45 am
Location: Belgium

Unread postby LoWeN » Tue Feb 03, 2004 11:43 am

Hello,

So KDE 3.2 has been released today.
I have build qt 3.3 beta with the MIPSpro quite easily.
I must still investigate a problem with that.

Sources are already on my home dir.

So be ready for questions soon.

@+

LoWeN
UX powered

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8145
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Unread postby nekonoko » Tue Feb 03, 2004 11:59 am

Good luck with that - I can't even get KDE 3.2 to build using qt 3.3 beta on a Linux system :) I had to downgrade to qt 3.2.3 which works fine with it. I don't think the beta is ready for prime time just yet.
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

LoWeN
Posts: 256
Joined: Thu Aug 28, 2003 11:45 am
Location: Belgium

Unread postby LoWeN » Tue Feb 03, 2004 12:44 pm

Hello,

So sounds bad news... If on linux it already fails... Grrr Beta is Beta
I can give it a try with 3.2.3 just to remove the suspicion from 3.3Beta1...

But I get 3.3 compile... and first bad thing...
When I issue and ldd on libqui.so it is linked with libqt-mt.so.3 but not from my lib dir but from the lib dir of the sources??? Bweuh...
Any idea?

Ok there is a stupid -rpath pointing to the wrong place grrrrrrrrrr
One more build...

I will give a try with 3.2.3 just to see...
I have decided to go with 3.2.3... Will go with 3.3 the day it will be released.

@+

LoWeN
UX powered

LoWeN
Posts: 256
Joined: Thu Aug 28, 2003 11:45 am
Location: Belgium

Unread postby LoWeN » Thu Feb 05, 2004 5:57 am

Hello,

To contiune the game... QT 3.3 is out... :-)
So tonigh I will try with my previous learning to build a proper nice and clean QT 3.3 mips3 n32 and place it into /opt/kde.
I hope to finish with that tonight.

@+

LoWeN
UX powered

LoWeN
Posts: 256
Joined: Thu Aug 28, 2003 11:45 am
Location: Belgium

Unread postby LoWeN » Thu Feb 12, 2004 12:30 am

Hello,

Finally it arrives...

I am unable to build arts...
I can build a part of it with cc and a lot of hacking than it complains about unresolved symbols...
I hace tried with gcc and it complains on my qt library saying QString::null unresolved symbol and that during the configure...

There I have no clue to continue further...
I can of course try to build a QT 3.2.3 and give it a test...

For the rests I have sucessfully build nearly all the dependencies of the kdelibs :
openssl,pcre,libxml2,libxslt,libart-lgpl,libjpeg,libtiff,libpng,expat,graphviz,doxygen

Now I am blocked.

Any idea?

@+

LoWeN
UX powered

User avatar
whiter
Posts: 975
Joined: Tue Apr 29, 2003 2:02 pm
Location: Melbourne, Australia
Contact:

Unread postby whiter » Thu Feb 12, 2004 1:03 am

Wish I was that far already.

For some weird reason, the packages that first did compile on my system, now don't. I get the strangest errors so this is quite blocking me in my progress on anything.

I hope I don't have to reinstall my server.
Shall I describe it to you? Or do you want me to get you a box?

LoWeN
Posts: 256
Joined: Thu Aug 28, 2003 11:45 am
Location: Belgium

Unread postby LoWeN » Thu Feb 12, 2004 1:57 am

Hello,

Whiter where do you have problem?
Maybe I can help you...

@+

LoWeN
UX powered

LoWeN
Posts: 256
Joined: Thu Aug 28, 2003 11:45 am
Location: Belgium

Unread postby LoWeN » Wed Feb 25, 2004 2:54 am

Hello,

Due to a serious lack of time.
(I have to reborn my nice linux alpha system)
Due to the fact the task is too big/hard/complicated for my own tiny person.
Due to the fact that everything is ready for gnome 2.4 on nekochan.

I decide to gave up on that crazy project of mine.

@+

LoWeN
UX powered

directedition
Posts: 515
Joined: Mon Feb 03, 2003 5:20 pm
Location: Pasadena, MD
Contact:

Unread postby directedition » Wed Feb 25, 2004 8:25 am

Oh well, I was really looking forward to using JuK on IRIX.
- Jim
:Indigo: :Indigo: :Indy: :Indy: <- signed by The Screensavers :) :Indigo2IMP: (230L) (230L) :540: :1600SW: :1600SW: <- touchscreen :PI: :Octane2:

User avatar
whiter
Posts: 975
Joined: Tue Apr 29, 2003 2:02 pm
Location: Melbourne, Australia
Contact:

Unread postby whiter » Wed Feb 25, 2004 9:34 am

Well,
I'm definitely going to continue to work on this WHEN I GET MY SYSTEM TO ACT NORMAL $&#*($%#!%#!

I fear I will have to do a complete reinstall of the f*cker since the errors I am getting are just not explainable :-((
So I'll get into that on saturday, but untill then I can't do shit. grmbl :(
Shall I describe it to you? Or do you want me to get you a box?

LoWeN
Posts: 256
Joined: Thu Aug 28, 2003 11:45 am
Location: Belgium

Unread postby LoWeN » Sat Feb 28, 2004 4:54 am

Hello,

I am still finally fighting with kde 3.2.
I can't resolve my self to abandon on a failure.

And mainly with arts...

I got the following with mipspro C/C++ 7.3.1.3

cc-1239 CC: ERROR File = dispatcher.cc, Line = 1004
"cerr" is ambiguous.

cerr << "WARNING: got corrupt MCOP message !??" << endl;

It is possible to solve this by chqmging iostream in iostream.h
Sounds mipro don't know which cerr to use whem both iostream and iostream.h are included

cc-1312 CC: ERROR File = /usr/include/unistd.h, Line = 525
More than one instance of overloaded function "getdomainname" has "C" linkage.

extern int getdomainname(char *, int);

A non solution is to remove that definition out of the header file... dumb but working
Or should I really consider to update to the latest overlay since I am still using 6.5.17 and a lot of changes have occured in 6.5.18.

I didn't try it yet with gcc since I have to rebuild QT with gcc also...
And I would like to hev everything mipspro builded...

Regards,

LoWeN
UX powered


Return to “SGI: Development”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest