OS X and SMB problem...

Apple hardware/software and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
The Keeper
Posts: 1622
Joined: Mon Nov 17, 2003 10:23 pm
Location: Buffalo, NY
Contact:

OS X and SMB problem...

Unread postby The Keeper » Thu Jun 17, 2004 10:24 am

Hello all,

This isn't SGI related, but it seems to be a relatively minor issue, so please bear with me.

My G4, running 10.3.4, is unable to access my primary server, which is a box running Win2k Server, SP4. The G4 can see all of the other machines in the workgroup, but can't seem to access the Win2k server. I have the same username and password on the G4 as on the server, but when I double-click on the server (named "FREAKAZOID", btw, not sure if anyone here is up on 10-year-old Warner Brothers cartoons), I see the circular rainbow icon for a few minutes, and then it times out. I apologize for not having the specific error message written down, but it's something about how it couldn't find something.

Comments/suggestions would be appreciated.

Thanks,
Chris

User avatar
semi-fly
Posts: 786
Joined: Fri Feb 21, 2003 6:29 am
Location: Ypsitucky, MI
Contact:

Unread postby semi-fly » Fri Jul 09, 2004 7:24 am

Here's a good link for troubleshooting win 2000/win 2000 server SMB problems:

http://www.macwindows.com/panther.html

Just a few tips:

Code: Select all

November 3, 2003
Darrell Kienzle has a fix based on the NetInfo Manager:

    I read your discussion of problems with access to SMB shares in Panther. Here's something I discovered when working with one of the betas.

    Fire up NetInfo Manager and browse to /users/yourname/passwd. The passwd _should_ be "******". This is a representation of a shadow password (a feature added in Panther). If you see something like "YW3273hhs," that's a standard hashed Unix passwd (which Jaguar used).

    If you have a hashed passwd, use System Preferences to change your password (you can give it the same value it used to be). Reload NetInfo Manager and you'll see it has changed to "******"

    I found that this helped enormously when trying to connect to Windows and SAMBA shares.



Code: Select all

November 3, 2003
Sean Sperte points to the Directory Access utility:

    One thing that helped my painful SMB browsing experience in Panther was to set the correct workgroup in the Directory Access utility app (found in the Utilities folder in the Applications folder). Once I did this, problems accessing "folders" (or drives) more than one time were solved.


Basiclly, it's a pain in the booty.
configure complete, now type 'make' and pray.

vegac
Posts: 730
Joined: Thu Jan 23, 2003 12:34 pm
Contact:

Unread postby vegac » Fri Jul 09, 2004 9:43 am

I'll chime in and recommend just doing a trusty ole "Connect to server" via the Finder (cmd-k), plug in the IP, log in, let it save the values, and call it a day. I added my fileserver to the favorites list, so now mounting it as a drive is as simple as CMD-K, Return, to bring up the list and connect to it

User avatar
semi-fly
Posts: 786
Joined: Fri Feb 21, 2003 6:29 am
Location: Ypsitucky, MI
Contact:

Unread postby semi-fly » Fri Jul 09, 2004 10:37 am

vegac wrote:I'll chime in and recommend just doing a trusty ole "Connect to server" via the Finder (cmd-k), plug in the IP, log in, let it save the values, and call it a day. I added my fileserver to the favorites list, so now mounting it as a drive is as simple as CMD-K, Return, to bring up the list and connect to it


Once I mount the SMB share, I just add it to my list of start-up items - after several OS X updates I've not had any problems - the share just automatically shows up on my desktop right under my primary drive.
configure complete, now type 'make' and pray.


Return to “Apple”

Who is online

Users browsing this forum: No registered users and 1 guest