A/UX Update Help

Apple hardware/software and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
pentium
Posts: 4737
Joined: Mon Aug 28, 2006 6:29 pm
Location: Kamloops, BC

A/UX Update Help

Unread postby pentium » Wed Mar 23, 2016 11:44 am

So I pulled out a spare Quadra 700 and am trying to get an install of A/UX going. So far in terms of hit and miss there's been a lot of misses.

I started by installing 3.0.1. I partitioned it correctly on a 1gb drive and made the mac partition extra large (128mb) for extra software and stuff. The install went smoothly and I did end up with a useable system but the tune-up packages are confusing me.

So officially they are known as Tune-up 1 (two disks) and Tune-up 2 (one disk). Tune-up 1 updates to 3.0.2. Tune-up 2 updates to 3.11 but requires 3.1 and recommends the "AWS Software Upgrade" in order to proceed if you do not have 3.1. I cannot find this, assuming it was some free update in between the tune-ups.

Anyways, even applying tune-up 1 caused everything to go sideways. The machine now boots but the moment A/UX kicks in the screen begins freaking out and the ADB stops responding. Eventually you're dumped to a text prompt because A/UX has given up fighting with the Toolbox for some reason and there's nothing I can do from there because with no ADB the keyboard is dead. Did I simply apply the patch incorrectly?

Also, I've noticed that unless I write protect the floppies the machine trashes the filesystem on the disks. I know bloody well this isn't an issue with the floppy drive as even before I started on this project the drive was removed, cleaned, lubed and tested. It was reading, writing and overall not molesting disks before.
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.

User avatar
pentium
Posts: 4737
Joined: Mon Aug 28, 2006 6:29 pm
Location: Kamloops, BC

Re: A/UX Update Help

Unread postby pentium » Thu Mar 24, 2016 1:05 pm

System ran all night with every hardware and disk exerciser and test utility I had on hand. The machine if flawless. I even had a power interruption just before I woke up this morning and the Quadra was the only machine int the house that wasn't a laptop that didn't go down.

Anyways, PRAM cleared, A/UX was reinstalled starting with the 3.0.1 install media, then the tune-up to 3.0.2, then I used buddy's 3.1 upgrade disc and now I'm trying to apply the tune-up to 3.1.1. Having been so well behaved for the last 24 hours, now it finally starts to be a pain in the ass again.

-First try, insert floppy, system locks solid

*reboot*

-Second try, insert floppy, it mounts but the updater quits with error -2somethingsomething

*reboot*

-Third try, regenerate Tune-Up diskette, insert and it mounts, run the updater and the machine locks solid.

*reboot*

-Fourth try, regenerate diskette again using a disk image from another source*, insert and it mounts and it runs and the update is successfully applied.

The floppy drive is still being a massive pain in the ass and corrupting any disk you feed it unless the write protect is set so I might just have to swap it out and hope the problem goes with it. Otherwise I think I got it sorted out now.

*Both are from the Jagubox FTP, however the working disk image was in /Apple.fixes/supported/3.1/aws-tune.0/, the image that was causing me problems was in /Apple.fixes/supported/aws-tuneup-2.0/.
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.


Return to “Apple”

Who is online

Users browsing this forum: No registered users and 1 guest