Fibre - Fabric Mode?

Additional operating system/hardware discussion (Windows, Linux, *BSD and others)
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
uunix
Donor
Donor
Posts: 1772
Joined: Sun Mar 27, 2011 12:48 pm
Location: Stourbridge / England / UK

Fibre - Fabric Mode?

Unread postby uunix » Wed Sep 06, 2017 12:54 am

Thought I would start a new thread on my fibre story, since this next stumbling block isn't anything to with the cards not actually working.

So here is the setup so far.
Equipment:
SUN T3 - 9 Drives, 2 Volumes with 4 Slices each configured for masking and permissions based on the WWN, so no sharing.
Brocade Silkworm 3850
Octane 1 - Discreet - 6.5.30
Octane 2 - Discreet - 6.5.30
Octane 3 - Normal - 6.5.30


SUN T3 Connected to the Brocade Silkworm 3850
Octane1 connected to the Silkworm 3850
Octane2 connected to the Silkworm 3850
Octane3 connected to the Silkworm 3850

So each Octane is given it's own slice from the T3 via the switch, which does work and they are correctly separated, so no problem there.

hinv on each machine produces the same output (differing only on the controller number, example, Octane 2 produces

Code: Select all

Integral SCSI controller 7: Version Fibre Channel QL2342 Port 2
  Fabric Disk: node 50020f2000006d0f port 300000000 lun 1 on SCSI controller 7

It's been given the fabric address, which is where my problem start.
XLV can use this fine, in fact, Octane 3 has it mounted and working as an XLM drive, but alas, sw_config from discreet cannot see it. Nor can fx.
[Edit - Gateway mode is not want I need, it just allows you connect to another Fabric.]
I have read about fabric mode and gateway mode on the switch itself, which if I am correct, would mean the drive is presented differently?
The Brocade 3850 though does not support Gateway mode, but I am still unsure if this the right route anyway.
I see no ability to configure the slices to be presented via any alias on the SUN T3.

So I am a little stuck, how to either get the switch to present the LUNS / SLICES differently, Configure the T3, or get IRIX to recognize the drives the same as XVM does?

Thoughts?
-----------------------------------------------------------------------
Hey Ho! Pip & Dandy!
:Octane2: :O2: :Indigo: :Indy:
-----------------------------------------------------------------------

Return to “Miscellaneous Operating Systems/Hardware”

Who is online

Users browsing this forum: No registered users and 1 guest