gAIM defeats me

IRIX and IRIX software discussion including open source and commerical offerings.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
themacosxflies
Posts: 943
Joined: Fri Apr 09, 2004 6:53 am
Location: great empire in the distant past
Contact:

gAIM defeats me

Unread postby themacosxflies » Tue Nov 23, 2004 7:00 am

Hi all,

I had downloaded a couple of gAIM version to let me keep in contact with my buddies since my PowerBook is on repair, but I was not able to get it working.

I got this message:

Code: Select all

1870:gaim: rld: Fatal Error: Cannot Successfully map soname 'libgtk-x11-2.0.so.1' under any of the filenames
/usr/freeware/lib32/libgtk-x11-2.0.so.1:/usr/freeware/gaim-0.75/lib/libgtk-x11-2.0.so.1
:/usr/lib32/libgtk-x11-2.0.so.1:/usr/lib32/internal/libgtk-x11-2.0.so.1
:/usr/Softimage/Soft3D_3.9.2/3D/dso/libgtk-x11-2.0.so.1
:/usr/Softimage/Soft3D_3.9.2/3D/custom/bin/libgtk-x11-2.0.so.1
:/usr/Softimage/Soft3D_3.9.2/3D/custom/dso/libgtk-x11-2.0.so.1
:/usr/Softimage/Soft3D_3.9.2/Particle/dso/libgtk-x11-2.0.so.1
:/usr/Softimage/Soft3D_3.9.2/3D/dso/softGraphicOGL/libgtk-x11-2.0.so.1
:/usr/lib/libgtk-x11-2.0.so.1:/usr/lib/internal/libgtk-x11-2.0.so.1:/lib/libgtk-x11-2.0.so.1
:/usr/java/lib/libgtk-x11-2.0.so.1:/usr/local/lib/libgtk-x11-2.0.so.1
:/usr/freeware/lib/libgtk-x11-2.0.so.1:/lib32/libgtk-x11-2.0.so.1:/opt/lib32/libgtk-x11-2.0.so.1
:/usr/freeware/lib32/libgtk-x11-2.0.so.1.1:/usr/freeware/gaim-0.75/lib/libgtk-x11-2.0.so.1.1
:/usr/lib32/libgtk-x11-2.0.so.1.1:/usr/lib32/internal/libgtk-x11-2.0.so.1.1
:/usr/Softimage/Soft3D_3.9.2/3D/dso/libgtk-x11-2.0.so.1.1
:/usr/Softimage/Soft3D_3.9.2/3D/custom/bin/libgtk-x11-2.0.so.1.1
:/usr/Softimage/Soft3D_3.9.2/3D/custom/dso/libgtk-x11-2.0.so.1.1
:/usr/Softimage/Soft3D_3.9.2/Particle/dso/libgtk-x11-2.0.so.1.1
:/usr/Softimage/Soft3D_3.9.2/3D/dso/softGraphicOGL/libgtk-x11-2.0.so.1.1
:/usr/lib/libgtk-x11-2.0.so.1.1:/usr/lib/internal/libgtk-x11-2.0.so.1.1:/lib/libgtk-x11-2.0.so.1.1
:/usr/java/lib/libgtk-x11-2.0.so.1.1:/usr/local/lib/libgtk-x11-2.0.so.1.1
:/usr/freeware/lib/libgtk-x11-2.0.so.1.1:/lib32/libgtk-x11-2.0.so.1.1:/opt/lib32/libgtk-x11-2.0.so.1.1:


since it was a tardist file, what could be wrong?

thanks.
We are here on Earth to do good to others. What the others are here for, I don't know.

_SmUrf_
Posts: 14
Joined: Tue Jul 06, 2004 2:09 pm
Location: brussels
Contact:

Unread postby _SmUrf_ » Tue Nov 23, 2004 7:38 am

check if you have GTK 2.0 installed :D

Revlef
Posts: 108
Joined: Fri Mar 19, 2004 12:25 pm
Location: Arnhem, the Netherlands

Unread postby Revlef » Tue Nov 23, 2004 8:03 am

Hi,

and did you use the fixed version of wilhelm ?

this version works for me but i had to install the freeware dependancies

http://www.nekochan.net/wiki/downloads/index ... 2Fwilhelm/

good luck.

regards, revlef

User avatar
themacosxflies
Posts: 943
Joined: Fri Apr 09, 2004 6:53 am
Location: great empire in the distant past
Contact:

Unread postby themacosxflies » Tue Nov 23, 2004 9:43 am

_SmUrf_ wrote:check if you have GTK 2.0 installed :D


that smile denotes GTK is mandatory and I must have know about it, right? :D

where could I get it?

thanks :wink:
We are here on Earth to do good to others. What the others are here for, I don't know.

User avatar
themacosxflies
Posts: 943
Joined: Fri Apr 09, 2004 6:53 am
Location: great empire in the distant past
Contact:

Unread postby themacosxflies » Tue Nov 23, 2004 9:45 am

Revlef wrote:Hi,

and did you use the fixed version of wilhelm ?

this version works for me but i had to install the freeware dependancies

http://www.nekochan.net/wiki/downloads/index ... 2Fwilhelm/

good luck.

regards, revlef


Yes, I did it, but I can not remember it asking me about those dependancies...

Thank you very much.
We are here on Earth to do good to others. What the others are here for, I don't know.

_SmUrf_
Posts: 14
Joined: Tue Jul 06, 2004 2:09 pm
Location: brussels
Contact:

Unread postby _SmUrf_ » Tue Nov 23, 2004 3:40 pm

themacosxflies wrote:
_SmUrf_ wrote:check if you have GTK 2.0 installed :D


that smile denotes GTK is mandatory and I must have know about it, right? :D

where could I get it?

thanks :wink:

I saw it in foetz directory on neko's downloads
http://www.nekochan.net/wiki/downloads/contr ... 40.tardist
and GTK 2 is also available on sgi freewares:
http://freeware.sgi.com/Dist/fw_gtk2+-2.4.0.tardist

I dunno what kind of hardware you're using but I would highly recommend
the gtk 1.2 version of Gaim since GTk 2.0 is incredibly slow and has a lot of deps
here's GTk1.2
http://freeware.sgi.com/Dist/fw_gtk+-1. ... l1.tardist
and the version of gaim for gtk1.2:
http://www.nekochan.net/wiki/downloads/contr ... 74.tardist


I used that smiley because I was happy when I posted the message :D,
GTK is not mandatory but lot's of linux stuff like sylpheed(mail), ethereal (network), mozilla,... uses GTK 1.2
check here
to have a more complete list

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8145
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Unread postby nekonoko » Tue Nov 23, 2004 5:02 pm

themacosxflies wrote:Yes, I did it, but I can not remember it asking me about those dependancies...


That's one of the risks you take when using packages from the "contrib" directory and the main reason I don't lump everything in one big download directory. Just because it's a tardist doesn't mean the packager put the prereq checking in - the only tardists that will have that *guaranteed* are those in Nekoware and SGI Freeware.

Now I'm not saying don't use the contrib packages - they can be useful - just setting some expectations in regards to tardist features :)

That said, any reason you're not using Nekoware Gaim?
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

User avatar
GeneratriX
Posts: 4250
Joined: Tue Oct 21, 2003 2:07 am
Location: Rosario / Santa Fe / República Argentina

GeneratrixWare

Unread postby GeneratriX » Tue Nov 23, 2004 6:51 pm

nekonoko wrote:Just because it's a tardist doesn't mean the packager put the prereq checking in - the only tardists that will have that *guaranteed* are those in Nekoware and SGI Freeware.


Add "GeneratrixWare" Neko! :lol:
My tardist releases are all having full prereq cheking!
Cheers! ;)

User avatar
themacosxflies
Posts: 943
Joined: Fri Apr 09, 2004 6:53 am
Location: great empire in the distant past
Contact:

Unread postby themacosxflies » Wed Nov 24, 2004 3:25 am

_SmUrf_ wrote:
I dunno what kind of hardware you're using but I would highly recommend
the gtk 1.2 version of Gaim since GTk 2.0 is incredibly slow and has a lot of deps
here's GTk1.2
http://freeware.sgi.com/Dist/fw_gtk+-1. ... l1.tardist
and the version of gaim for gtk1.2:
http://www.nekochan.net/wiki/downloads/contr ... 74.tardist


OK, I donwloaded and installed both but the console message remains here annoying me :?

_SmUrf_ wrote:I used that smiley because I was happy when I posted the message :D,


Cool :)
We are here on Earth to do good to others. What the others are here for, I don't know.

User avatar
themacosxflies
Posts: 943
Joined: Fri Apr 09, 2004 6:53 am
Location: great empire in the distant past
Contact:

Unread postby themacosxflies » Wed Nov 24, 2004 3:26 am

nekonoko wrote:
That said, any reason you're not using Nekoware Gaim?


Oh, but then, those I have downloaded are not Nekoware ? :oops:
We are here on Earth to do good to others. What the others are here for, I don't know.

User avatar
Hakimoto
Moderator
Moderator
Posts: 2648
Joined: Sun Mar 30, 2003 4:29 am
Location: Nijmegen, Netherlands, Europe
Contact:

Unread postby Hakimoto » Wed Nov 24, 2004 7:50 am

Angel, uninstall all the gaim stuff you've installed so far. Then grab this:

http://www.nekochan.net/downloads/Nekoware/beta/neko_gaim-1.0.0.tardist

That will do the trick. Make sure you fulfil its dependecies and you're set to go.

If problems still persist, let us know what your LD_LIBRARY_PATH is.
The Bandito wrote:In a few years, no doubt, you'll be able to buy a computer,
software and operating system that will match the capabilities
of your current Amiga at about the price you paid for the
Amiga way back when. But you can smile to yourself, knowing
that you were touching the future years before the rest of
the world. And that other computers and operating systems
will do with brute force what the Amiga did years before with
grace, elegance and style.


Eroteme.ch - my end of the internet...

User avatar
themacosxflies
Posts: 943
Joined: Fri Apr 09, 2004 6:53 am
Location: great empire in the distant past
Contact:

Unread postby themacosxflies » Wed Nov 24, 2004 9:16 am

Hakimoto wrote:Angel, uninstall all the gaim stuff you've installed so far. Then grab this:

http://www.nekochan.net/downloads/Nekoware/beta/neko_gaim-1.0.0.tardist

That will do the trick. Make sure you fulfil its dependecies and you're set to go.

If problems still persist, let us know what your LD_LIBRARY_PATH is.


Thanks Hakimoto,

Software Manager found 2 conflicts, seems that I lack:

neko_gaim.sw.lib

and

neko_gaim.sw.eoe

so far I choose to 'also install neko...' but I would like to know where get them.

Thanks again.
We are here on Earth to do good to others. What the others are here for, I don't know.

User avatar
Hakimoto
Moderator
Moderator
Posts: 2648
Joined: Sun Mar 30, 2003 4:29 am
Location: Nijmegen, Netherlands, Europe
Contact:

Unread postby Hakimoto » Wed Nov 24, 2004 10:02 am

Angel, that is odd. Those subsystems are part of the tardist. Make sure that all subsystems have ticks in the boxes for them... this shouldn't happen...
The Bandito wrote:In a few years, no doubt, you'll be able to buy a computer,
software and operating system that will match the capabilities
of your current Amiga at about the price you paid for the
Amiga way back when. But you can smile to yourself, knowing
that you were touching the future years before the rest of
the world. And that other computers and operating systems
will do with brute force what the Amiga did years before with
grace, elegance and style.


Eroteme.ch - my end of the internet...

User avatar
joerg
Donor
Donor
Posts: 2229
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

Unread postby joerg » Fri Nov 26, 2004 7:48 am

themacosxflies wrote:
Hakimoto wrote:Angel, uninstall all the gaim stuff you've installed so far. Then grab this:

http://www.nekochan.net/downloads/Nekoware/beta/neko_gaim-1.0.0.tardist

That will do the trick. Make sure you fulfil its dependecies and you're set to go.

If problems still persist, let us know what your LD_LIBRARY_PATH is.


Thanks Hakimoto,

Software Manager found 2 conflicts, seems that I lack:

neko_gaim.sw.lib

and

neko_gaim.sw.eoe

so far I choose to 'also install neko...' but I would like to know where get them.

Thanks again.



The gaim tardist for the nekoware distribution is packaged by me. I can say its compiling with the rpath and using all libs coming from neko.


Code: Select all

# cd /usr/nekoware/bin/
# ldd gaim
        libX11.so.1  =>  /usr/lib32/libX11.so.1
        libgtk-x11-2.0.so.1  =>  /usr/nekoware/lib/libgtk-x11-2.0.so.1
        libgdk-x11-2.0.so.1  =>  /usr/nekoware/lib/libgdk-x11-2.0.so.1
        libatk-1.0.so.1  =>      /usr/nekoware/lib/libatk-1.0.so.1
        libgdk_pixbuf-2.0.so.1  =>       /usr/nekoware/lib/libgdk_pixbuf-2.0.so.1
        libpangoxft-1.0.so.1  =>         /usr/nekoware/lib/libpangoxft-1.0.so.1
        libpangox-1.0.so.1  =>   /usr/nekoware/lib/libpangox-1.0.so.1
        libpango-1.0.so.1  =>    /usr/nekoware/lib/libpango-1.0.so.1
        libgobject-2.0.so.1  =>  /usr/nekoware/lib/libgobject-2.0.so.1
        libgmodule-2.0.so.1  =>  /usr/nekoware/lib/libgmodule-2.0.so.1
        libglib-2.0.so.1  =>     /usr/nekoware/lib/libglib-2.0.so.1
        libao.so.3  =>   /usr/nekoware/lib/libao.so.3
        libdl.so  =>     /usr/lib32/libdl.so
        libpthread.so  =>        /usr/lib32/libpthread.so
        libaudiofile.so.1  =>    /usr/nekoware/lib/libaudiofile.so.1
        libm.so  =>      /usr/lib32/libm.so
        libintl.so.4  =>         /usr/nekoware/lib/libintl.so.4
        libiconv.so.3  =>        /usr/nekoware/lib/libiconv.so.3
        libc.so.1  =>    /usr/lib32/libc.so.1
        libnsl.so  =>    /usr/lib32/libnsl.so
        libXext.so  =>   /usr/lib32/libXext.so
        libXft.so.2  =>  /usr/nekoware/lib/libXft.so.2
        libfreetype.so.7  =>     /usr/nekoware/lib/libfreetype.so.7
        libz.so  =>      /usr/nekoware/lib/libz.so
        libXrender.so.1  =>      /usr/nekoware/lib/libXrender.so.1
        libfontconfig.so.2  =>   /usr/nekoware/lib/libfontconfig.so.2
        libpangoft2-1.0.so.1  =>         /usr/nekoware/lib/libpangoft2-1.0.so.1
        libexpat.so.1  =>        /usr/nekoware/lib/libexpat.so.1


Code: Select all

# versions -n | grep gaim
I  neko_gaim                     1  gaim-0.82.1 multi-protocol instant messaging
I  neko_gaim.man                 1  Man Pages
I  neko_gaim.man.manpages           1  Man Pages
I  neko_gaim.sw                  1  Software
I  neko_gaim.sw.eoe              1  execution only env
I  neko_gaim.sw.hdr              1  header files
I  neko_gaim.sw.lib              1  shared libraries



Code: Select all

# versions -n | grep gaim
I  neko_gaim                     2  gaim-1.0.0 multi-protocol instant messaging
I  neko_gaim.man                 2  Man Pages
I  neko_gaim.man.manpages           2  man Pages
I  neko_gaim.opt                 2  optional software
I  neko_gaim.opt.dist            2  distribution files
I  neko_gaim.opt.relnotes           2  release notes
I  neko_gaim.opt.src             2  original source code
I  neko_gaim.sw                  2  Software
I  neko_gaim.sw.eoe              2  execution only env
I  neko_gaim.sw.hdr              2  header files
I  neko_gaim.sw.lib              2  shared libraries

Code: Select all

# cat /usr/nekoware/dist/neko_gaim.spec
product neko_gaim
    id "gaim-1.0.0 multi-protocol instant messaging"
    image sw
        id "Software"
        version 2
        order 9999
        subsys eoe default
            id "execution only env"
            replaces self
            prereq (
                neko_gaim.sw.lib 2 maxint
                neko_gtk.sw.lib 2 maxint
                neko_atk.sw.lib 2 maxint
                neko_gtk.sw.lib 2 maxint
                neko_pango.sw.lib 2 maxint
                neko_glib.sw.lib 2 maxint
                neko_libao.sw.lib 1 maxint
                neko_libaudiofile.sw.lib 1 maxint
                neko_gettext.sw.lib 2 maxint
                neko_libiconv.sw.lib 2 maxint
                neko_libxft.sw.lib 1 maxint
                neko_freetype2.sw.lib 2 maxint
                neko_zlib.sw.lib 2 maxint
                neko_libxrender.sw.lib 2 maxint
                neko_fontconfig.sw.lib 2 maxint
                neko_expat.sw.lib 2 maxint
            )
            exp neko_gaim.sw.eoe


You cant install Gaim eoe without the neko_gaim.sw.lib. I have installed it 5min. ago without any kind of problem.

regards
Joerg

User avatar
themacosxflies
Posts: 943
Joined: Fri Apr 09, 2004 6:53 am
Location: great empire in the distant past
Contact:

Unread postby themacosxflies » Thu Dec 02, 2004 11:27 am

OK, gaim is running, was a matter of get new IRIX overlays, thanks all
We are here on Earth to do good to others. What the others are here for, I don't know.


Return to “IRIX and Software”

Who is online

Users browsing this forum: No registered users and 2 guests