Page 1 of 1

xmms problems

Posted: Wed Mar 26, 2003 7:37 pm
by armoury
Greetings all... Sorry for all the stupid questions of late. I've run into some oddities while trying to run xmms and play a mp3 file. It starts fine, but when I try to load a file I get the following:

indigo2 14% /usr/freeware/bin/xmms
sh: unzip: not found
Bus error (core dumped)
indigo2 15%


Any suggestions? unzip is installed, yet it gets that error. Should I have /usr/freeware/bin/ in my path? I had some problems getting the path set anyway, no matter what I tried or whose instructions I followed it didn't quite work properly (still gotta fiddle with that a bit).

Once again, thanks :-)

Best Regards:

Eric

Posted: Wed Mar 26, 2003 7:52 pm
by semi-fly
Hello,
Can you confirm that 'unzip' is actually working? Make sure you can decompress some *.zip files (unzip -v -v; create a *.zip file with 'zip file.zip file'), and re-run the FixPath shell script located in /usr/freeware/bin; I don't run XMMS my self, but this looks like a path-related issue. :)

Posted: Wed Mar 26, 2003 8:14 pm
by Shtoink
I ran into that when setting up a new account as well

What I did to solve it was setup bash as my default shell and then runt the "fixpath" utility that usually resides in the /usr/freeware/bin folder. I'm not sure if you have to install that utility manually or it get installed with something, but that's how I fixed that problem. I'm sure there are more ways than just that, but htat's the easiest way I know of.

Posted: Thu Mar 27, 2003 5:40 am
by armoury
I got rid of the unzip issue by just making a symlink to unzip in the freeware directory. The "bus error" is the part that's really makin me wonder though...

Peculiar...

Posted: Thu Mar 27, 2003 7:26 am
by vegac
I get similar errors though without the bit about unzip, on some of my songs playing with XMMS...
Some mp3s, just won't play with it, causing core dumps...

Odd, because on my linux box XMMS will play them fine, as will mpg123 on my SGI...

Posted: Thu Mar 27, 2003 8:56 am
by armoury
It appeared to just be the mp3 I was playing. AMP plays it, but not XMMS. I did get a different mp3 to load up, and it *looks* like it's playing by the analyzer hoppin 'round, but there's just static coming out of the speaker. I did change the player pref to IRIX-audio so it should be using the right thing... Odd...

Posted: Thu Mar 27, 2003 9:18 am
by nekonoko
I'm not sure why the error comes up when when you are attempting to play an mp3, but xmms needs unzip to support WinAMP style skins, which are basically standard zipfiles with graphics elements bundled inside.

CRASHING XMMS FIX

Posted: Mon Mar 31, 2003 12:32 am
by lisp
Yes, XMMS *will* crash on certain mp3s.

But *only* if you have ID3v2 support enabled.

Disable it and the problem goes away.