Disable nis

IRIX and IRIX software discussion including open source and commerical offerings.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
jessedewaard
Posts: 23
Joined: Mon Mar 14, 2016 1:08 pm
Location: The Netherlands

Disable nis

Unread postby jessedewaard » Mon Feb 05, 2018 1:27 pm

I recently decided to play with my SGI Octane again but is still contains the IRIX installation from the previous owner.
Apparently the previous owner used nis, i never heard of it but it prevents me from using passwd to change my root password?

When i use passwd i get the following error:
can't get master for passwd file

I disabled yp in chkconfig, hoping that it would solve my problem bit it didn't.

This is my nsswitch.conf file (if it helps at all)

#
# This is the SGI default nsswitch.conf file. This file determines
# the maps that will be maintained by nsd, which methods will be
# used to lookup information for a map, and what order the methods
# are called in.
#
# For details on this file see the nsswitch.conf(4) manual page.
#
# After editing this file the nsd daemon must be sent a SIGHUP signal for
# it to notice. Do a "killall -HUP nsd".
#
#bootparams: files nis
capability: files nis
clearance: files nis
ethers: files nis
group: files nis
hosts: files nis dns
mac: files nis
mail(null_extend_key): ndbm(file=/etc/aliases) nis
netgroup: nis
#netid.byname: nis
networks: files nis
passwd: files(compat) [notfound=return] nis
protocols: nis [success=return] files
rpc: files nis
services: files nis
shadow(mode=0700): files
#ypservers: nis
octane 26#


So my question is how do i completely get rid of nis and use all the local files (passwd, groups e.t.c)?

Thanks

User avatar
dexter1
Moderator
Moderator
Posts: 2773
Joined: Thu Feb 20, 2003 6:57 am
Location: Zoetermeer, The Netherlands

Re: Disable nis

Unread postby dexter1 » Mon Feb 05, 2018 1:50 pm

Oh man, that was a long time ago i used NIS at the uni. Have a look at your /etc/passwd file and make sure there is a regular entry for root, not just a line with +:+::: or something similar.
Other places where NIS (or YellowPages as it is used to be called) leaves its mark is /etc/yp.conf and /var/yp/ypmake
And putting root in the NIS password list means that by cracking that account, you have root on all machines in the domain. Safe to say that's not really smart.
:Crimson: :PI: :Indigo: :O2: :Indy: :Indigo2: :Indigo2IMP:

User avatar
miod
Posts: 528
Joined: Fri Oct 09, 2009 2:44 am
Location: Clermont-Ferrand (France)
Contact:

Re: Disable nis

Unread postby miod » Mon Feb 05, 2018 10:52 pm

dexter1 wrote:Oh man, that was a long time ago i used NIS at the uni. Have a look at your /etc/passwd file and make sure there is a regular entry for root, not just a line with +:+::: or something similar.

Systems using /etc/nsswitch.conf usually do not need such a line.

To the OP: can you check if `passwd` is not aliased to `yppasswd`? That would explain it trying to reach the NIS server.
:Indigo:R3000 (alas, dead) :Indigo:R4000 x4 :Indigo2:R4400 :Indigo2IMP:R4400 x2 :Indigo2:R8000 :Indigo2IMP:R10000 :Indy:R4000PC :Indy:R4000SC :Indy:R4400SC :Indy:R4600 :Indy:R5000SC :O2:R5000 x3 :O2:RM7000 :Octane:2xR10000 :Octane:R12000 :O200:2xR12000 :O200: - :O200:2x2xR10000 :Fuel:R16000 :O3x0:4xR16000 :A350:
among more than 150 machines : Apollo, Data General, Digital, HP, IBM, MIPS before SGI, Motorola, NeXT, SGI, Solbourne, Sun...

User avatar
foetz
Moderator
Moderator
Posts: 6668
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: Disable nis

Unread postby foetz » Tue Feb 06, 2018 12:45 am

you could also uninstall nis by looking for "nfs.sw.nis". that does of course not change config files that have been edited to support nis manually but since it won't work anymore finding the remains might be easier.

jessedewaard
Posts: 23
Joined: Mon Mar 14, 2016 1:08 pm
Location: The Netherlands

Re: Disable nis

Unread postby jessedewaard » Thu Feb 08, 2018 1:50 pm

Thanks for the reply's

My passwd file did indeed contain a +:+::: line and i removed it, sadly without any result.
My system does not contain a /etc/yp.conf but /var/yp does exist including a ypmake script
Also the passwd file is not aliased to anything.

My /etc/nsswitch.conf looks like this:

#bootparams: files nis
capability: files nis
clearance: files nis
ethers: files nis
group: files nis
hosts: files nis dns
mac: files nis
mail(null_extend_key): ndbm(file=/etc/aliases) nis
netgroup: nis
#netid.byname: nis
networks: files nis
passwd: files(compat) [notfound=return] nis
protocols: nis [success=return] files
rpc: files nis
services: files nis
shadow(mode=0700): files
#ypservers: nis

This is still default right?

What can i try next?


Return to “IRIX and Software”

Who is online

Users browsing this forum: No registered users and 1 guest