Page 1 of 1

SGI L2 Emulator

Posted: Tue Oct 24, 2017 4:31 am
by jwhat
Hi Nekochaners,

while trying to get my Onyx's up and running I was doing a bit of reading on L2 Controllers as they appear every now and then on eBay very cheap and there was mention of l2 emulator "I had also reflashed L1 firmware from software L2 emulator, but could not re-enable" in this thread: viewtopic.php?t=16727613.

This sounded interesting and so on also reading that L2 is based on a PowerPC (now OpenPower I believe) device running Linux, my assumption was that someone had managed to get L2 Firmware up and running on "PearPC" .. but this was not the case after much googling on L2 emulator and PearPC, I end up back at Nekochan reading this thread: viewtopic.php?f=3&t=16719038

Turns out the L2 Emulator is actually some software that SGI developed for its engineering and runs on i386 Linux box. So now how to you get this running:

I downloaded CD tar file and have tried a number of builds, with Fedora, going from R12 -> R10 -> R1.

There are a couple of problems:

1. Original CD software is built for Linux 2.4 Kernel but that was only used back in R1 and all later version use 2.6 and higher kernels
2. SGI software has mandatory ksh (Korne Shell) dependency and this is pretty much dead code that is not available as package on R12, but is available in R10
3. Users reported problem with VMWare USB and Fedora R1.

Having no luck with R12 or R10, my R1 install is almost..... running

I am running on VMWare Fusion.

To get this going I:

1. Downloaded R1 iso from Fedora Archive
2. Created new VM with iso CDROM boot, selecting Developer options on install to ensure I got gcc and other tools (initially I tried to do minimal install to get package footprint small, but this resulted in no being able to load new packages
3. Note that at this point the only way to get software onto machine was by burning iso CD images with software as R1 Fedora has no network driver that works initially
4. Did VMWare Tools install, which then failed and directed me to VMWare KB saying I need to use different VMWare Tools CD, for pre glib 2.5 case
5. Got VMWare Tools complied, but only after first loading "kernel-source" rpm and could now get network connectivity
7. Got error on build SGI software, as I there was no "ksh" which is in package "pdksh"
8. Then SGI software all installed and built without a hickup
9. Now running the emulator on Fedora R1:

Image

The picture just has the L2 emulator (/stand/sysco/bin/l2 ), talking to the the l2gui (/stand/sysco/bin/l2gui ).

But I cannot get any thing when I plug into L1 USB port of Onyx, I get nothing...

So i tested the USB by plugging in USB Key and this gets detected so problem is not that VMWare is failing to talk to USB port...as you can see from syslog result which shows Toshiba key being loaded....
So like problem is with SGI driver / VMWare interaction.

Has anyone tried this recently and got it going ?

Cheers,


jwhat.

Re: SGI L2 Emulator

Posted: Tue Oct 24, 2017 4:55 am
by jan-jaap
It's been years since I last messed with this -- and that was on a real PC (some PIII junk box). Just want to tell you to pay attention when hooking up bricks to this thing; normally the bricks will assume the system serial# of the L2 and you didn't assign an SSN to your virtual L2.

NB: should you decide to get one of those cheap 'real' L2 units, they need 48VDC power, normally supplied by an O3K power brick. But it's possible to use a regular power adapter ('wall wart') as long as it provides 48VDC. There's big D shell connector on the L2 unit, and you need to make your own adapter for the power. I still have some of the D shell connectors and back shell to do exactly this.