Page 1 of 1

Java

Posted: Thu May 18, 2017 1:33 pm
by uunix
I've always dismissed any install conflicts with JAVA, since I DON'T NEED JAVA!!!

Well I do now.. ahem..

So, am I right, latest Version of IRIX JAVA is 1.4 ?

Need to get my FUEL in the 20th century.

Cheers

Re: Java

Posted: Thu May 18, 2017 1:37 pm
by dexter1

Re: Java

Posted: Thu May 18, 2017 1:40 pm
by Raion-Fox
You mean 21st century.

And yeah, currently we don't have any Java past 1.4, which was released in 2002. If you want to try your hand at compiling a later version of OpenJDK, I'd start with OpenJDK 6, the earliest OpenJDK release that's still supported, here's the info for it. http://openjdk.java.net/projects/mips-port/

Re: Java

Posted: Thu May 18, 2017 1:56 pm
by uunix
Thanks both, and yes Mr Fox, 21st century.. jeeze time flies.

I don't want to go too modern, the device I'm connecting to has an old version of Java.

Re: Java

Posted: Thu May 18, 2017 7:53 pm
by praetor242
First Java...and then...MINECRAFT on an Onyx :D

Re: Java

Posted: Fri May 19, 2017 9:34 am
by Kotomo
praetor242 wrote:First Java...and then...MINECRAFT on an Onyx :D

3. .....
4. Profit.

Sorry, I had to. :lol:

Re: Java

Posted: Sat May 20, 2017 8:07 am
by LarBob
praetor242 wrote:First Java...and then...MINECRAFT on an Onyx :D

If you actually wanted to get later versions of MC running, LWJGL would have to compile for MIPS. I know never versions of MC won't work on PPC machines as there isn't a version of LWJGL compiled for the machines.