Trying to install Supertux. libtiff.so.3 not found strikes again!

IRIX and IRIX software discussion including open source and commerical offerings.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
Dodoid
Posts: 603
Joined: Mon Jul 04, 2016 1:36 pm
Location: Ottawa, Canada
Contact:

Trying to install Supertux. libtiff.so.3 not found strikes again!

Unread postby Dodoid » Wed Oct 05, 2016 3:02 pm

Trying to install Supertux on 6.5.30. Downloaded and installed all dependencies using nekodeps.pl. tiff installed normally, as expected. However, when I attempt to run Supertux, it requires libtiff.so.3. /usr/nekoware/lib/libtiff.so.3 is there, but it is a symlink to /usr/nekoware/lib/libtiff.so.6. Specifically, Supertux wants version "sgi3.7", which 6.0 presumably is not. Does anyone have a copy of the real libtiff.so.3, or know how to make it work with libtiff.so.6.0?
:Onyx: :O2000: :Fuel: :Octane: :Octane: :Octane: :O2: :O2: :Indigo2: :Indigo2: :Indy: :Indy:
and a small army of Image

User avatar
necron2600
Posts: 262
Joined: Tue May 26, 2015 10:38 pm
Location: Boston

Re: Trying to install Supertux. libtiff.so.3 not found strikes again!

Unread postby necron2600 » Wed Oct 05, 2016 8:43 pm

libtiff3.tar
libtiff.so.3.8
(580 KiB) Downloaded 18 times


I ended up placing a bunch of older libs in /opt/lib32/ and adding that to my lib path for many other pieces of software:
$ ls /opt/lib32/
libFLAC++.so.7.0 liblber-2.3.so.1.14 libtheoradec.so.2.4
libFLAC.so.5 libldap-2.3.so.1.14 libtiff.so.3
libcurl.so.4 liblzo2.a libtiff.so.3.8
libgcc_s.so.1 liblzo2.la
libguile-ltdl.so.2.0 libstdc++.so.7
libguile.so.13.0 libtheoradec.so.2

My supertux install works fine (with libtiff.so.3.8 in library path), except for sound. its all hissing instead of proper sound.


Return to “IRIX and Software”

Who is online

Users browsing this forum: No registered users and 1 guest