Page 1 of 3

6.5 packages

Posted: Wed Jan 08, 2014 9:40 pm
by foetz
figured one thread for the updates is probably the best way. everything is built with MIPSpro unless noted otherwise. the base dir is:

http://www.nekochan.net/downloads/index.php?path=foetz/

>> you can always use "rulesoverride" and ignore my deps as long as you have adequate replacements <<

MIRROR

Code: Select all

r-a-c.de/dist/sgi/6.5/

append the package name since there's no listing


let's get right to it. new today:
  • uncrustify
  • f90ppr

these are source code formatters for terminal use. uncrustify is a terribly "modern" c++ junk but compared to using a java based ide for formatting it's still a blessing :P as an exception i used g++ for this one but no worries, it doesn't require any gnu libs.
f90ppr is the same but only for fortran and also written in fortran. i uploaded a 64bit and 32bit version, both mips4 and i used a lot of the specials mipspro has to offer so these 2 should run like hell :P

a version of f90ppr for 6.2 is likely to follow more or less soon but no luck with uncrustify which seems to require a quite recent g++. anyhow the 6.2 version of f90ppr should then also work for those of you running 6.5 with mips3.

Re: 6.5 packages

Posted: Thu Jan 09, 2014 10:21 pm
by vishnu
I should post some screenshots of the horribly formatted code written by the tiny subset of mechanical engineers at my place of employ who have decided they can program... :lol:

Re: 6.5 packages

Posted: Fri Jan 10, 2014 6:55 am
by foetz
haha, they might wanna make use of it :P

Re: 6.5 packages

Posted: Wed Jan 15, 2014 2:48 pm
by foetz
  • snappy_111.tardist
  • fltk_132.tardist

the second one should be clear and the first one is google's compression lib.

Re: 6.5 packages

Posted: Thu Jan 16, 2014 6:26 pm
by rvic
Thank you for the effort

Are these packages for 6.5.22 minimum or they could be installed in let's say 6.5.15 ?

Are there any packages for the lesser versions of 6.5 irix ... prior to 6.5.22 ?

Or should i use the 6.2 ones ... actually that's what i did until now.
For me 6.5.15 seems the best overall distribution ... in speed and stability ... i own an O2.

Thank you

Re: 6.5 packages

Posted: Thu Jan 16, 2014 7:16 pm
by foetz
rvic wrote:Thank you for the effort

Are these packages for 6.5.22 minimum or they could be installed in let's say 6.5.15 ?

i'm not sure actually :P
for some it might come down to a try but unless something is used that only existed in a version above 6.5.15 it should be fine.

Re: 6.5 packages

Posted: Mon Feb 10, 2014 7:46 pm
by foetz
algol68g_28.tar.bz2

for more info: http://jmvdveer.home.xs4all.nl/

Re: 6.5 packages

Posted: Sun Feb 23, 2014 6:03 pm
by PymbleSoftware
foetz wrote:algol68g_28.tar.bz2

for more info: http://jmvdveer.home.xs4all.nl/



I think it was built without (or with broken) thread support or something. This from a quad 1GHz Tezro with 8Gb RAM:

Code: Select all

cat test2.agl && bin/a68g test2.agl

MODE SIEVER = STRUCT (SEMA full, empty, REF INT n);
PROC make siever = SIEVER: (LEVEL 0, LEVEL 1, NEW INT);
PROC start siever = (SIEVER s, INT n) VOID:
  (n MOD 2 /= 0 | DOWN empty OF s; n OF s := n; UP full OF s);
PROC next unmarked = (SIEVER s) INT:
  (DOWN full OF s; INT n = n OF s; UP empty OF s; n);
PROC sieve = (SIEVER current) VOID:
  (INT n = next unmarked (current);
  print ((whole (n, -int width), new line));
  SIEVER new = make siever;
  PAR (
    DO IF INT i = next unmarked (current);
      i MOD n /= 0
      THEN start siever (new, i)
      FI
    OD,
    sieve (new)
  )
);
SIEVER first = make siever;
INT n := 1;
PAR (DO n PLUSAB 1; start siever (first, n) OD, sieve (first))



         3
         5
         7
        11
        13
        17
        19
        23
        29
        31
18        sieve (new)
          1         
a68g: runtime error: 1: cannot create thread (not enough space) (detected in
VOID collateral-clause starting at "(" in line 12).
tezro:~/local-code/algol>


R.

Re: 6.5 packages

Posted: Sun Feb 23, 2014 9:19 pm
by foetz
i only used regular configure options and didn't modify any source so as i said via pm already i'm not related to the project in any way and it did classify irix as unsupported platform. there were no errors and my thread related stuff works fine for any other program so you might wanna talk with the author about any issues that might come up

Re: 6.5 packages

Posted: Sun Feb 23, 2014 11:19 pm
by hamei
foetz wrote:... you might wanna talk with the author about any issues that might come up

Don't know if this applies but when I was messing with GraphicsMagicke I was told that threads in Irix and Open MP clash. Last time I talked to the head guy, he was working on this but up til now, you can't compile GM with both threads and OpenMP.

Seems odd since SGI was the mom of OpenMP but like a wilful child, it's forgotten its loving parents :(

Re: 6.5 packages

Posted: Mon Feb 24, 2014 12:36 am
by jan-jaap
The problem is that IRIX supports two thread models: traditional (sproc) threads and POSIX threads. You cannot mix thread models in a single IRIX process.

Several libraries in IRIX use sproc threads internally, probably because they date back to IRIX 5.3 or early 6.x days. For a developer this means that if you decide to use this library, and your code is threaded, it must use sproc threads.

Needless to say, these days everything assumes pthreads.

Re: 6.5 packages

Posted: Mon Feb 24, 2014 2:23 am
by hamei
jan-jaap wrote:The problem is that IRIX supports two thread models: traditional (sproc) threads and POSIX threads. You cannot mix thread models in a single IRIX process.

Thanks, j-j. Good to know the reason ... is there an easy way to know which libaries use which threads ?

Re: 6.5 packages

Posted: Mon Feb 24, 2014 5:03 am
by jan-jaap
I guess you should run

Code: Select all

/usr/bin/nm -u
against /usr/lib32/*.so and grep for sproc ?

On my Origin 350 (IRIX 6.5.30) these libraries show up:

Code: Select all

libC.so
libcl.so
libdmnet.so
libdplace.so
libdprof.so
libftn.so
libil.so
libinstr.so
libmoviefile.so
libmovieplay.so
libmp.so
libmp_pthreads.so
libnanothread.so
libpthread.so
libss.so
libvkSGI.so

Several of these belong to the WorkShop debugger. Before you ask: I don't know why libmp_pthreads.so and libpthread.so match :P

But man(5) pthreads is clear:

Code: Select all

      Using sprocs
          The sproc(2) model of threading is incompatible with POSIX threads.
          Attempts by an sproc process to create pthreads and vice-versa will
          be rejected.

Re: 6.5 packages

Posted: Fri Sep 19, 2014 10:55 pm
by foetz
  • dillo304_fltk-gcc.tar.bz2

this is a double pack containing fltk 1.3.2 static libs and dillo 3.0.4. as the name suggests both compiled with neko gcc 4.7.
fltk is without docs and the fluid program, just the libs. it defaults to /usr/local/dillo3. you can put it anywhere as long as you edit fltk-config accordingly.
dillo has the vsnprintf changes applied but also a much lighter version of the downloads.cc patch as well as 2 ssl related dialogs disabled. the latter makes duckduckgo or ixquick actually usable because these dialogs have no "don't ask again" option. they affect occurences of X509_V_ERR_SELF_SIGNED_CERT_IN_CHAIN and X509_V_ERR_UNABLE_TO_GET_ISSUER_CERT_LOCALLY

Re: 6.5 packages

Posted: Sat Sep 20, 2014 4:54 pm
by vishnu
Just for funzies I'm still working on a MIPSPro compile of dillo that I pulled from the tip of their svn on August 30th...