Nekochan Net

Official Chat Channel: #nekochan // irc.nekochan.net
It is currently Tue Jul 29, 2014 2:56 pm

All times are UTC - 8 hours


Forum rules


Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.



Post new topic Reply to topic  [ 25 posts ]  Go to page 1, 2  Next
Author Message
Unread postPosted: Fri Jan 06, 2012 8:09 am 
Offline
User avatar

Joined: Tue Jul 15, 2008 4:48 pm
Posts: 1887
Location: P.O. Box 121, Pymble, Sydney, NSW 2073, Australia.
Code:
firefox
 1670:/usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin: rld: Fatal Error: attempted access to unresolvable symbol in /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin: sqlite3_enable_shared_cache
root@[tezro]:~/# ldd /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin
        libm.so  =>      /usr/lib32/libm.so     
 1671: 01:27:47 /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin: rld: Fatal Error exit/longjmp: Cannot Successfully map soname 'libsmime3.so' under any of the filenames ../../dist/bin/libsmime3.so:/usr/nekoware/lib/libsmime3.so:/usr/apple/shake3.5//lib//libsmime3.so:/usr/lib32/libsmime3.so:/usr/lib32/internal/libsmime3.so:/lib32/libsmime3.so:/opt/lib32/libsmime3.so:
 1671:/usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin: rld: Fatal Error: Cannot Successfully map soname 'libsmime3.so' under any of the filenames ../../dist/bin/libsmime3.so:/usr/nekoware/lib/libsmime3.so:/usr/apple/shake3.5//lib//libsmime3.so:/usr/lib32/libsmime3.so:/usr/lib32/internal/libsmime3.so:/lib32/libsmime3.so:/opt/lib32/libsmime3.so:


Uninstall SQ Lite 3 and Python module sql lite 3 and problem goes away.

I was in as root to do admin and install/remove software.

Please check that you do no break other packages when you create nekoware.

I have not found any reference to this in the forums but I guess it is self evident for most developers.

I haven't seen any nekoware updates lately and I think the problem has existed for a while now.

R.

_________________
死の神はりんごだけ食べる

開いた括弧は必ず閉じる -- あるプログラマー

:Tezro: :Tezro: :Onyx2R: :Onyx2RE: :Onyx2: :O3x04R: :O3x0: :O200: :Octane: :Octane2: :O2: :O2: :Indigo2IMP: :PI: :PI: :1600SW: :1600SW: :Indy: :Indy: :Indy: :Indy: :Indy:
:hpserv: J5600, 2 x Mac, 3 x SUN, Alpha DS20E, Alpha 800 5/550, 3 x RS/6000, Amiga 4000 VideoToaster, Amiga4000 -030, 733MHz Sam440 AmigaOS 4.1 update 1.

Sold: :Indy: :Indy: :Indy: :Indigo: Tandem Himalaya S-Series Nonstop S72000 ServerNet.

@PymbleSoftware
Current Apps -> https://itunes.apple.com/au/artist/pymb ... d553990081
Cortex ---> http://www.facebook.com/pages/Cortex-th ... 11?sk=info
Minnie ---> http://www.facebook.com/pages/Minnie-th ... 02?sk=info
Github ---> https://github.com/pymblesoftware
Visit http://www.pymblesoftware.com
Search for "Pymble", "InstaElf", "CryWhy" or "Cricket Score Sheet" in the iPad App store or search for "Pymble" or "CryWhy" in the iPhone App store.


Top
 Profile  
 
Unread postPosted: Fri Jan 06, 2012 12:55 pm 
Offline
Site Admin
Site Admin
User avatar

Joined: Thu Jan 23, 2003 1:31 am
Posts: 7970
Location: Pleasanton, California
Yep, been a known issue for quite a while: viewtopic.php?f=7&t=16724316

_________________
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.


Top
 Profile  
 
Unread postPosted: Fri Jan 06, 2012 1:37 pm 
Offline
User avatar

Joined: Tue Jul 15, 2008 4:48 pm
Posts: 1887
Location: P.O. Box 121, Pymble, Sydney, NSW 2073, Australia.
nekonoko wrote:
Yep, been a known issue for quite a while: viewtopic.php?f=7&t=16724316


Thanks nekonoko. I failed to find that in my search before posting. At least there is another link back to the original topic now.


R.

_________________
死の神はりんごだけ食べる

開いた括弧は必ず閉じる -- あるプログラマー

:Tezro: :Tezro: :Onyx2R: :Onyx2RE: :Onyx2: :O3x04R: :O3x0: :O200: :Octane: :Octane2: :O2: :O2: :Indigo2IMP: :PI: :PI: :1600SW: :1600SW: :Indy: :Indy: :Indy: :Indy: :Indy:
:hpserv: J5600, 2 x Mac, 3 x SUN, Alpha DS20E, Alpha 800 5/550, 3 x RS/6000, Amiga 4000 VideoToaster, Amiga4000 -030, 733MHz Sam440 AmigaOS 4.1 update 1.

Sold: :Indy: :Indy: :Indy: :Indigo: Tandem Himalaya S-Series Nonstop S72000 ServerNet.

@PymbleSoftware
Current Apps -> https://itunes.apple.com/au/artist/pymb ... d553990081
Cortex ---> http://www.facebook.com/pages/Cortex-th ... 11?sk=info
Minnie ---> http://www.facebook.com/pages/Minnie-th ... 02?sk=info
Github ---> https://github.com/pymblesoftware
Visit http://www.pymblesoftware.com
Search for "Pymble", "InstaElf", "CryWhy" or "Cricket Score Sheet" in the iPad App store or search for "Pymble" or "CryWhy" in the iPhone App store.


Top
 Profile  
 
Unread postPosted: Sun Jan 08, 2012 6:21 am 
Offline

Joined: Tue Feb 24, 2004 4:10 pm
Posts: 9462
PymbleSoftware wrote:
nekonoko wrote:
Yep, been a known issue for quite a while: viewtopic.php?f=7&t=16724316


Thanks nekonoko. I failed to find that in my search before posting. At least there is another link back to the original topic now.


I was thinking ... (danger, Will Robinson. Danger ! Danger !) When a package is known to be bad, would it be better to ditch it entirely or to create a "known bad" directory it could be moved to so that maybe other people wouldn't have to start from scratch when packaging problem-child applications ?


Top
 Profile  
 
Unread postPosted: Sun Jan 08, 2012 1:10 pm 
Offline
User avatar

Joined: Tue Jul 15, 2008 4:48 pm
Posts: 1887
Location: P.O. Box 121, Pymble, Sydney, NSW 2073, Australia.
hamei wrote:
PymbleSoftware wrote:
nekonoko wrote:
Yep, been a known issue for quite a while: viewtopic.php?f=7&t=16724316


Thanks nekonoko. I failed to find that in my search before posting. At least there is another link back to the original topic now.


I was thinking ... (danger, Will Robinson. Danger ! Danger !) When a package is known to be bad, would it be better to ditch it entirely or to create a "known bad" directory it could be moved to so that maybe other people wouldn't have to start from scratch when packaging problem-child applications ?



I think it might be okay if you are doing SQL lite stuff in isolation. Might be better if people can find the answers easily.. It breaks firefox which includes everything including the kitchen sink. Modern software .. if it aint got a dozen depndancies... I don't know why my previous search was unsuccessful.

Keywords: SQL Lite 3, firefox firefox-bin rld: Fatal Error sqlite3_enable_shared_cache unresolvable symbol


R.

_________________
死の神はりんごだけ食べる

開いた括弧は必ず閉じる -- あるプログラマー

:Tezro: :Tezro: :Onyx2R: :Onyx2RE: :Onyx2: :O3x04R: :O3x0: :O200: :Octane: :Octane2: :O2: :O2: :Indigo2IMP: :PI: :PI: :1600SW: :1600SW: :Indy: :Indy: :Indy: :Indy: :Indy:
:hpserv: J5600, 2 x Mac, 3 x SUN, Alpha DS20E, Alpha 800 5/550, 3 x RS/6000, Amiga 4000 VideoToaster, Amiga4000 -030, 733MHz Sam440 AmigaOS 4.1 update 1.

Sold: :Indy: :Indy: :Indy: :Indigo: Tandem Himalaya S-Series Nonstop S72000 ServerNet.

@PymbleSoftware
Current Apps -> https://itunes.apple.com/au/artist/pymb ... d553990081
Cortex ---> http://www.facebook.com/pages/Cortex-th ... 11?sk=info
Minnie ---> http://www.facebook.com/pages/Minnie-th ... 02?sk=info
Github ---> https://github.com/pymblesoftware
Visit http://www.pymblesoftware.com
Search for "Pymble", "InstaElf", "CryWhy" or "Cricket Score Sheet" in the iPad App store or search for "Pymble" or "CryWhy" in the iPhone App store.


Top
 Profile  
 
Unread postPosted: Fri Jan 27, 2012 6:23 am 
Offline

Joined: Tue Feb 24, 2004 4:10 pm
Posts: 9462
PymbleSoftware wrote:
Keywords: SQL Lite 3, firefox firefox-bin rld: Fatal Error sqlite3_enable_shared_cache unresolvable symbol

Just built SQlite 3.07.10 and installed it. Held my nose, put my right foot in the garbage can, hopped around in a circle widdershins three times and restarted Fireflop : FF didn't crash. Posting from there now.

So maybe whatever was wrong with SQLite 3 has been fixed ?


Top
 Profile  
 
Unread postPosted: Sat Jan 28, 2012 12:44 pm 
Offline
User avatar

Joined: Mon Jul 21, 2003 5:19 am
Posts: 743
neko_sqlite3-3.7.10.tardist is in /incoming - it works for me with nekoware firefox.


Top
 Profile  
 
Unread postPosted: Mon Jan 30, 2012 1:22 pm 
Offline
Site Admin
Site Admin
User avatar

Joined: Thu Jan 23, 2003 1:31 am
Posts: 7970
Location: Pleasanton, California
canavan wrote:
neko_sqlite3-3.7.10.tardist is in /incoming - it works for me with nekoware firefox.


I've moved it to /beta; thanks!

_________________
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.


Top
 Profile  
 
Unread postPosted: Mon Feb 27, 2012 6:40 pm 
Offline
User avatar

Joined: Mon Aug 28, 2006 5:29 pm
Posts: 4258
Location: Kamloops, BC
This didn't seem to fix it for me. Now it's attempted access to a new unresolvable symbol (sqlite3_os_switch).

_________________
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.


Top
 Profile  
 
Unread postPosted: Tue Feb 28, 2012 2:16 pm 
Offline
User avatar

Joined: Mon Jul 21, 2003 5:19 am
Posts: 743
Which version of firefox are you using, and do you have any LD_LIBRARY_PATH (possibly with N32 somewhere) set (you shouldn't, any nekoware package that requires it is broken and should be fixed)?


Top
 Profile  
 
Unread postPosted: Wed Feb 29, 2012 12:42 pm 
Offline
User avatar

Joined: Mon Aug 28, 2006 5:29 pm
Posts: 4258
Location: Kamloops, BC
Attempting to run 2.0.0.22 which I believe is the latest on the nekoware mirror and everything should be running at defaults. It seems that the same problem is affecting Thunderbird as well.

_________________
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.


Top
 Profile  
 
Unread postPosted: Wed Feb 29, 2012 2:28 pm 
Offline
User avatar

Joined: Mon Jul 21, 2003 5:19 am
Posts: 743
Please post the output of
Code:
ls -l /usr/nekoware/lib/libsqli*
ldd /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin
LD_LIBRARYN32_PATH=/usr/nekoware/lib/firefox-2.0.0.22pre ldd /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin
LD_LIBRARY_PATH=/usr/nekoware/lib/firefox-2.0.0.22pre ldd /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin

Then try
Code:
LD_LIBRARY_PATH=/usr/nekoware/lib/firefox-2.0.0.22pre /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin


Top
 Profile  
 
Unread postPosted: Wed Feb 29, 2012 6:56 pm 
Offline
User avatar

Joined: Mon Aug 28, 2006 5:29 pm
Posts: 4258
Location: Kamloops, BC
I have to do this through IRC because I can't post here through Netscape so expect some weird formatting.

Code:
 $ ls -l /usr/nekoware/lib/libsqli*
<Peanut> -rw-r--r--    1 root     sys       1908772 Feb 27 18:21 /usr/nekoware/lib/libsqlite3.a
<Peanut> -rwxr-xr-x    1 root     sys           861 Feb 27 18:21 /usr/nekoware/lib/libsqlite3.la
<Peanut> lrwxr-xr-x    1 root     sys            17 Mar  2  2011 /usr/nekoware/lib/libsqlite3.so -> libsqlite3.so.1.6
<Peanut> lrwxr-xr-x    1 root     sys            17 Mar  2  2011 /usr/nekoware/lib/libsqlite3.so.1 -> libsqlite3.so.1.6
<Peanut> -rwxr-xr-x    1 root     sys       1391944 Feb 27 18:21 /usr/nekoware/lib/libsqlite3.so.1.6


Code:
$ ldd /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin
<Peanut>         libm.so  =>      /usr/lib32/libm.so     
<Peanut>  1708: 18:42:43 /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin: rld: Fatal Error exit/longjmp: Cannot Successfully map soname 'libsmime3.so' under any of the filenames ../../dist/bin/libsmime3.so:/usr/nekoware/lib/libsmime3.so:/usr/lib32/libsmime3.so:/usr/lib32/internal/libsmime3.so:/lib32/libsmime3.so:/opt/lib32/libsmime3.so:
<Peanut>  1708:/usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin: rld: Fatal Error: Cannot Successfully map soname 'libsmime3.so' under any of the filenames ../../dist/bin/libsmime3.so:/usr/nekoware/lib/libsmime3.so:/usr/lib32/libsmime3.so:/usr/lib32/internal/libsmime3.so:/lib32/libsmime3.so:/opt/lib32/libsmime3.so:


Code:
$  LD_LIBRARYN32_PATH=/usr/nekoware/lib/firefox-2.0.0.22pre ldd /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin
<Peanut>         libm.so  =>      /usr/lib32/libm.so     
<Peanut>         libsmime3.so  =>         /usr/nekoware/lib/firefox-2.0.0.22pre/libsmime3.so     
<Peanut>         libssl3.so  =>   /usr/nekoware/lib/firefox-2.0.0.22pre/libssl3.so       
<Peanut>         libnss3.so  =>   /usr/nekoware/lib/firefox-2.0.0.22pre/libnss3.so       
<Peanut>         libnssutil3.so  =>       /usr/nekoware/lib/firefox-2.0.0.22pre/libnssutil3.so   
<Peanut>         libsoftokn3.so  =>       /usr/nekoware/lib/firefox-2.0.0.22pre/libsoftokn3.so   
<Peanut>         libXt.so  =>     /usr/lib32/libXt.so   
<Peanut>         libsqlite3.so  =>        /usr/nekoware/lib/libsqlite3.so       
<Peanut>         libxpcom_compat.so  =>   /usr/nekoware/lib/firefox-2.0.0.22pre/libxpcom_compat.so       
<Peanut>         libmozjs.so  =>  /usr/nekoware/lib/firefox-2.0.0.22pre/libmozjs.so     
<Peanut>         libxpcom.so  =>  /usr/nekoware/lib/firefox-2.0.0.22pre/libxpcom.so     
<Peanut>         libxpcom_core.so  =>     /usr/nekoware/lib/firefox-2.0.0.22pre/libxpcom_core.so
<Peanut>         libplds4.so  =>  /usr/nekoware/lib/firefox-2.0.0.22pre/libplds4.so     
<Peanut>         libplc4.so  =>   /usr/nekoware/lib/firefox-2.0.0.22pre/libplc4.so       
<Peanut>         libnspr4.so  =>  /usr/nekoware/lib/firefox-2.0.0.22pre/libnspr4.so     
<Peanut>         libpthread.so  =>        /usr/lib32/libpthread.so       
<Peanut>         libdl.so  =>     /usr/lib32/libdl.so   
<Peanut>         libgtk-1.2.so.1  =>      /usr/nekoware/lib/libgtk-1.2.so.1     
<Peanut>         libgdk-1.2.so.1  =>      /usr/nekoware/lib/libgdk-1.2.so.1     
<Peanut>         libgmodule-1.2.so.1  =>  /usr/nekoware/lib/libgmodule-1.2.so.1 
<Peanut>         libglib-1.2.so.1  =>     /usr/nekoware/lib/libglib-1.2.so.1     
<Peanut>         libintl.so.9  =>         /usr/nekoware/lib/libintl.so.9
<Peanut>         libXext.so  =>   /usr/lib32/libXext.so 
<Peanut>         libX11.so.1  =>  /usr/lib32/libX11.so.1
<Peanut>         libsocket.so  =>         /usr/lib32/libsocket.so       
<Peanut>         libfastm.so  =>  /usr/lib32/libfastm.so
<Peanut>         libCsup.so  =>   /usr/lib32/libCsup.so 
<Peanut>         lib
<Peanut> libC.so.2  =>    /usr/lib32/libC.so.2   
<Peanut>         libCio.so.1  =>  /usr/lib32/libCio.so.1
<Peanut>         libc.so.1  =>    /usr/lib32/libc.so.1   
<Peanut>         libgen.so  =>    /usr/lib32/libgen.so   delay-load
<Peanut>         libintl.so.4  =>         /usr/nekoware/lib/libintl.so.4
<Peanut>         libiconv.so.3  =>        /usr/nekoware/lib/libiconv.so.3


Code:
$ LD_LIBRARY_PATH=/usr/nekoware/lib/firefox-2.0.0.22pre ldd /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin
<Peanut>         libm.so  =>      /usr/lib32/libm.so     
<Peanut>         libsmime3.so  =>         /usr/nekoware/lib/firefox-2.0.0.22pre/libsmime3.so     
<Peanut>         libssl3.so  =>   /usr/nekoware/lib/firefox-2.0.0.22pre/libssl3.so       
<Peanut>         libnss3.so  =>   /usr/nekoware/lib/firefox-2.0.0.22pre/libnss3.so       
<Peanut>         libnssutil3.so  =>       /usr/nekoware/lib/firefox-2.0.0.22pre/libnssutil3.so   
<Peanut>         libsoftokn3.so  =>       /usr/nekoware/lib/firefox-2.0.0.22pre/libsoftokn3.so   
<Peanut>         libXt.so  =>     /usr/lib32/libXt.so   
<Peanut>         libsqlite3.so  =>        /usr/nekoware/lib/libsqlite3.so       
<Peanut>         libxpcom_compat.so  =>   /usr/nekoware/lib/firefox-2.0.0.22pre/libxpcom_compat.so       
<Peanut>         libmozjs.so  =>  /usr/nekoware/lib/firefox-2.0.0.22pre/libmozjs.so     
<Peanut>         libxpcom.so  =>  /usr/nekoware/lib/firefox-2.0.0.22pre/libxpcom.so     
<Peanut>         libxpcom_core.so  =>     /usr/nekoware/lib/firefox-2.0.0.22pre/libxpcom_core.so
<Peanut>         libplds4.so  =>  /usr/nekoware/lib/firefox-2.0.0.22pre/libplds4.so     
<Peanut>         libplc4.so  =>   /usr/nekoware/lib/firefox-2.0.0.22pre/libplc4.so       
<Peanut>         libnspr4.so  =>  /usr/nekoware/lib/firefox-2.0.0.22pre/libnspr4.so   libpthread.so  =>        /usr/lib32/libpthread.so       
<Peanut>         libdl.so  =>     /usr/lib32/libdl.so   
<Peanut>         libgtk-1.2.so.1  =>      /usr/nekoware/lib/libgtk-1.2.so.1     
<Peanut>         libgdk-1.2.so.1  =>      /usr/nekoware/lib/libgdk-1.2.so.1     
<Peanut>         libgmodule-1.2.so.1  =>  /usr/nekoware/lib/libgmodule-1.2.so.1 
<Peanut>         libglib-1.2.so.1  =>     /usr/nekoware/lib/libglib-1.2.so.1     
<Peanut>         libintl.so.9  =>         /usr/nekoware/lib/libintl.so.9
<Peanut>         libXext.so  =>   /usr/lib32/libXext.so 
<Peanut>         libX11.so.1  =>  /usr/lib32/libX11.so.1
<Peanut>         libsocket.so  =>         /usr/lib32/libsocket.so       
<Peanut>         libfastm.so  =>  /usr/lib32/libfastm.so
<Peanut>         libCsup.so  =>   /usr/lib32/libCsup.so 
<Peanut>         libC.so
<Peanut> ibC.so.2  =>    /usr/lib32/libC.so.2   
<Peanut>         libCio.so.1  =>  /usr/lib32/libCio.so.1
<Peanut>         libc.so.1  =>    /usr/lib32/libc.so.1   
<Peanut>         libgen.so  =>    /usr/lib32/libgen.so   delay-load
<Peanut>         libintl.so.4  =>         /usr/nekoware/lib/libintl.so.4
<Peanut>         libiconv.so.3  =>        /usr/nekoware/lib/libiconv.so.3


Code:
$ LD_LIBRARY_PATH=/usr/nekoware/lib/firefox-2.0.0.22pre /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin
<Peanut>  1716:/usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin: rld: Fatal Error: attempted access to unresolvable symbol in /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin: sqlite3_os_switch


From what the folks on the IRC are telling me, either my hair is on fire or there is something missing from sqlite3 that everyone else somehow, possibly from files left over from upgrading an older version of sqlite still have, hence how they are not getting the same problem. sqlite3_os_switch was removed back in 3.5.0.

_________________
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.


Top
 Profile  
 
Unread postPosted: Wed Feb 29, 2012 9:32 pm 
Offline

Joined: Sat Feb 05, 2011 4:04 pm
Posts: 59
Location: Central CONUS
I talked with Pentium about this on IRC, and came to the conclusion that it's not a library path issue, but an issue with sqlite3_os_switch itself. That was an internal, undocumented function that was removed in the transition between 3.4.2 and 3.5.0 of SQlite. The call to sqlite3_os_switch was removed from Firefox sometime before 3.0, but it strongly appears that the .22pre version in nekoware still has the call.

Basically, I don't see how Firefox2 could possibly be working with sqlite above 3.4.2, since it relies on functions that are, quite simply, gone; Pentium's problem should affect anyone using Nekoware Firefox and the beta sqlite.


Top
 Profile  
 
Unread postPosted: Wed Feb 29, 2012 10:03 pm 
Offline

Joined: Tue Feb 24, 2004 4:10 pm
Posts: 9462
pentium wrote:
Code:
$ LD_LIBRARY_PATH=/usr/nekoware/lib/firefox-2.0.0.22pre /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin
<Peanut>  1716:/usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin: rld: Fatal Error: attempted access to unresolvable symbol in /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin: sqlite3_os_switch

Try (c shell or tcshell) :

Code:
urchin 10% setenv LD_LIBRARY_PATH /usr/nekoware/lib/firefox-2.0.0.22pre
urchin 11% /usr/nekoware/lib/firefox-2.0.0.22pre/firefox-bin

If I try to run it your way I get a bunch of error messages about missing "libsmime"

Kira wrote:
Basically, I don't see how Firefox2 could possibly be working with sqlite above 3.4.2, since it relies on functions that are, quite simply, gone; Pentium's problem should affect anyone using Nekoware Firefox and the beta sqlite.

Quite possibly. But this sqlite version does permit fireflop to start and run and not crash. I have no idea if it actually does anything, but at least it doesn't blow up the 'flop ....

Edit : those useless assbreath Down's Syndrome poster children at Fireflop ... :evil:

http://aplawrence.com/Web/firefox-sqlite.html

tastes great, less filling !

http://downloadsquad.switched.com/2009/ ... databases/

Morons. Absolute useless godforsaken morons. Let's fix fireflop 2 for Irix and let the mouth-breathers run FF3+ ....


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 25 posts ]  Go to page 1, 2  Next

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group