Page 1 of 1

Irix 5.3 Variants

Posted: Sat May 29, 2010 5:11 am
by cris_adder
Just wanted to ask if the Irix 5.3 variants are backward compatible on hardware. For example Irix 5.3 for R5000 will also on R4600, R4400, etc...

Thanks..

Re: Irix 5.3 Variants

Posted: Sat May 29, 2010 7:05 am
by SAQ
To an extent. IRIX 5.3 for Indy including R5000 works on all Indys (R4k, R5k), and may work on Indigo2 (probably will), but it will not work on any non-FastForward/IP22 (Indy IP24 is a small IP22) machine.

While it would have been very nice for SGI to qualify all releases for all supported systems, it would have taken way too much time to run the tests against everything, especially for the 5.3 releases.

Note that this doesn't work for everything, you want to look for the "including" (Indy including R5k) as there are some releases that are for a specific hardware version and won't work on others (the confusingly named "IRIX 5.3 for all Indigo2 IMPACT" only works on IP22 IMPACT machines and no others). The naming isn't even constant - IRIX 6.2 for Indigo2 R10k will work on Indigo2 R4k and Indy, but doesn't have the "including", so I guess you just have to know. Gerhard's pages are a good start, as are SGIs release notes and whatever is printed on the CD (sometimes a supported system list is printed)

Re: Irix 5.3 Variants

Posted: Sat May 29, 2010 8:41 pm
by cris_adder
Thanks... this help to explain why my Indgio2 impact Irix 5.3 is has weird behavior on my Indy...

Cheers

Re: Irix 5.3 Variants

Posted: Sun May 30, 2010 6:22 am
by skywriter
i have a copy of irix 5.3 w/XFS that installed on every r4k/r3k i ever tried it on; indy, indigo 1&2, crimson, skywriter, PI/2x, 4d/xxx, etc...

Re: Irix 5.3 Variants

Posted: Sun May 30, 2010 8:15 am
by SAQ
skywriter wrote:i have a copy of irix 5.3 w/XFS that installed on every r4k i ever tried it on; indy r4, indigo 1&2, crimson, skywriter, etc...


Supposedly that version has issues with the 2MB cache processor cards, R5k, and IMPACT graphics, other than that it's pretty general.

Re: Irix 5.3 Variants

Posted: Wed Feb 01, 2017 8:40 am
by gijoe77
SAQ wrote:
skywriter wrote:i have a copy of irix 5.3 w/XFS that installed on every r4k i ever tried it on; indy r4, indigo 1&2, crimson, skywriter, etc...


Supposedly that version has issues with the 2MB cache processor cards, R5k, and IMPACT graphics, other than that it's pretty general.


would this be one of those cases where you should install irix 5.3 w/XFS on a 200MHz module, get all the patches, then put in the 250MHz module?

Re: Irix 5.3 Variants

Posted: Wed Feb 01, 2017 9:26 am
by foetz
officially the 4400/250 was only supported with 6.2 and later but has been added to 5.3 via patches. patches the installation cds don't have hence it doesn't work.
for details about all versions see http://www.sgistuff.net/software/irixhistory/index.html

Re: Irix 5.3 Variants

Posted: Thu Feb 09, 2017 7:51 am
by SAQ
A while back I was working on a "5.3 with XFS for everything" that included a rebuilt miniroot that supported 2MB SC. I got that part working before life intervened, but there was some funkiness in the later install packages that wouldn't work right. I suppose I could get back to it and see if I can get it polished up and turned into an .efsimg.

Other than that yes, you can install on a 1MB SC (PM1, 2 or 3), patch, then turbo it with your PM5. You have to have an earlier R4k PM for this to work, however.