Error starting xchat 2.4.0 on Octane

IRIX and IRIX software discussion including open source and commerical offerings.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
chatuser
Posts: 68
Joined: Sat Dec 09, 2006 7:26 am
Location: Spain

Error starting xchat 2.4.0 on Octane

Unread postby chatuser » Mon Dec 18, 2006 2:04 pm

I finally received my new Octane some days ago and I'm triying to install xchat 2.4.0 from Nekochan freeeware.

When I'm trying to start xchat the program displays an error about pango and another one about fonts, I had a similar problem installing the same version for mips3 on my Indy.

I can use a workaround installing xchat 1.8.10 from freeware.sgi.com but the version is very old.

Could somebody tell me if it is possible make this version work ?

Thanks in advance.
:Indy: Indy R4400 150 MHz, 256 MB, Indy 24-bit, IRIX 6.5.22m/Debian GNU/Linux
:Octane2: Octane2 R12K 400 MHz, 1 GB, VPro V6, IRIX 6.5.30
IBM 44p 170 POWER3-II 400 MHz, 1 GB, Matrox G200 (GXT130P), AIX 5.3/Debian GNU/Linux
:hpserv: HP C3750+C3600 2GB, HP-UX 11v1/Debian GNU/Linux

User avatar
VenomousPinecone
Posts: 2180
Joined: Mon Jun 20, 2005 2:10 pm
Location: Groom Lake, NV

Unread postby VenomousPinecone » Mon Dec 18, 2006 3:50 pm

We need some things first, such as version of irix.

Also, what are the exact errors that you are getting, verbatim.

User avatar
chatuser
Posts: 68
Joined: Sat Dec 09, 2006 7:26 am
Location: Spain

Unread postby chatuser » Wed Dec 20, 2006 8:40 am

Ok, this is the output:

octane 8% xchat

(xchat:1695): Pango-WARNING **: No builtin or dynamically loaded modules
were found. Pango will not work correctly. This probably means
there was an error in the creation of:
'/usr/nekoware/etc/pango/pango.modules'
You may be able to recreate this file by running pango-querymodules.
Fontconfig error: Cannot load default config file
No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual
page and on http://fontconfig.org
octane 9% uname -R
6.5 6.5.22m
octane 10% uname -aR
IRIX64 octane 6.5 6.5.22m 10070055 IP30
octane 11%


I'm using IRIX 6.5.22m on an Octane2. I have deleted all the freeware installed and I have installed neko_xchat-2.4.0.tardist and necessary dependencies.

Thanks in advance.
:Indy: Indy R4400 150 MHz, 256 MB, Indy 24-bit, IRIX 6.5.22m/Debian GNU/Linux
:Octane2: Octane2 R12K 400 MHz, 1 GB, VPro V6, IRIX 6.5.30
IBM 44p 170 POWER3-II 400 MHz, 1 GB, Matrox G200 (GXT130P), AIX 5.3/Debian GNU/Linux
:hpserv: HP C3750+C3600 2GB, HP-UX 11v1/Debian GNU/Linux

User avatar
joerg
Donor
Donor
Posts: 2229
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

Unread postby joerg » Wed Dec 20, 2006 11:11 am

Run 'pango-querymodules' as root and try again.

The first start of xchat takes ages because it buildung up a fontcache or similar.

regards
Joerg

User avatar
chatuser
Posts: 68
Joined: Sat Dec 09, 2006 7:26 am
Location: Spain

Unread postby chatuser » Thu Dec 21, 2006 8:08 am

octane 1# pango-querymodules
pango-querymodules: Command not found.
octane 2#

I have checked that neko_pango-1.10.1.tardist is installed.

I have searched the file but it is absent on my system:

octane 5# find / -name "pango-querymodules"
octane 6#

How can I install this utility ?

----------------------------

Don't ask me how, but I have REINSTALLED the neko_pango-1.10.1.tardist pakage and now the binary file is there :shock:

When I run xchat the output is this one:

Fontconfig error: Cannot load default config file
No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual
page and on http://fontconfig.org

Suggestions ?
:Indy: Indy R4400 150 MHz, 256 MB, Indy 24-bit, IRIX 6.5.22m/Debian GNU/Linux
:Octane2: Octane2 R12K 400 MHz, 1 GB, VPro V6, IRIX 6.5.30
IBM 44p 170 POWER3-II 400 MHz, 1 GB, Matrox G200 (GXT130P), AIX 5.3/Debian GNU/Linux
:hpserv: HP C3750+C3600 2GB, HP-UX 11v1/Debian GNU/Linux

User avatar
joerg
Donor
Donor
Posts: 2229
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

Unread postby joerg » Thu Dec 21, 2006 8:32 am

Install and configure fontconfig. Btw. we also have GAIM in nekoware which is also a IRC client.

regards
Joerg

User avatar
chatuser
Posts: 68
Joined: Sat Dec 09, 2006 7:26 am
Location: Spain

Unread postby chatuser » Thu Dec 21, 2006 8:59 am

Thanks for your help, joerg

Just some minutes ago I have reinstalled neko_pango and neko_fontconfig and all is working now.

I don't know why but reinstalling these packages the errors disappear.

Thanks for you help 8) , I was going crazy
:Indy: Indy R4400 150 MHz, 256 MB, Indy 24-bit, IRIX 6.5.22m/Debian GNU/Linux
:Octane2: Octane2 R12K 400 MHz, 1 GB, VPro V6, IRIX 6.5.30
IBM 44p 170 POWER3-II 400 MHz, 1 GB, Matrox G200 (GXT130P), AIX 5.3/Debian GNU/Linux
:hpserv: HP C3750+C3600 2GB, HP-UX 11v1/Debian GNU/Linux

User avatar
hamei
Posts: 10476
Joined: Tue Feb 24, 2004 4:10 pm
Location: over the rainbow

Unread postby hamei » Thu Dec 21, 2006 2:41 pm

joerg wrote: Btw. we also have GAIM in nekoware which is also a IRC client.

And for the true turkeys like me, there is always Chatzilla !

User avatar
ClassicHasClass
Donor
Donor
Posts: 2191
Joined: Wed Jul 25, 2012 7:12 pm
Location: Sunny So Cal
Contact:

Re: Error starting xchat 2.4.0 on Octane

Unread postby ClassicHasClass » Sat Apr 20, 2013 10:19 am

This needs to go in a FAQ somewhere. I got the exact same error trying to get firefox3 running, and I had to reinstall not only pango and fontconfig but also gtk2.
smit happens.

:Fuel: bigred, 900MHz R16K, 4GB RAM, V12 DCD, 6.5.30
:Indy: indy, 150MHz R4400SC, 256MB RAM, XL24, 6.5.10
:Indigo2IMP: purplehaze, 175MHz R10000, Solid IMPACT
probably posted from Image bruce, Quad 2.5GHz PowerPC 970MP, 16GB RAM, Mac OS X 10.4.11
plus IBM POWER6 p520 * Apple Network Server 500 * RDI PrecisionBook * BeBox * Solbourne S3000 * Commodore 128 * many more...

User avatar
vishnu
Donor
Donor
Posts: 3361
Joined: Sun Mar 18, 2007 3:25 pm
Location: Minneapolis, Minnesota USA

Re: Error starting xchat 2.4.0 on Octane

Unread postby vishnu » Sat Apr 20, 2013 2:36 pm

ClassicHasClass wrote:This needs to go in a FAQ somewhere. I got the exact same error trying to get firefox3 running, and I had to reinstall not only pango and fontconfig but also gtk2.

It's fear of exactly this angst that has prevented me from even trying to install firefox 4 yet... :lol:

Where do you guys hang out on IRC?
Project:
Temporarily lost at sea...
Plan:
World domination! Or something...

:Tezro: :Octane2:

User avatar
joerg
Donor
Donor
Posts: 2229
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

Re: Error starting xchat 2.4.0 on Octane

Unread postby joerg » Sat Apr 20, 2013 2:39 pm

irc.nekochan.net #nekochan

User avatar
vishnu
Donor
Donor
Posts: 3361
Joined: Sun Mar 18, 2007 3:25 pm
Location: Minneapolis, Minnesota USA

Re: Error starting xchat 2.4.0 on Octane

Unread postby vishnu » Sat Apr 20, 2013 6:45 pm

I guess it's been a while since i've been on IRC, I just tried to fire up smirc (my IRC client of choice since nineteen-ninety-whatever) and it fails on all my currently installed DSO's... :shock:
Project:
Temporarily lost at sea...
Plan:
World domination! Or something...

:Tezro: :Octane2:


Return to “IRIX and Software”

Who is online

Users browsing this forum: No registered users and 1 guest