.4Dwmrc and CDROM problems (R5K O2, 6.5.20m)

Open discussion on or around SGI; software/hardware related posts should go in the appropriate subforum.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
karbak
Posts: 38
Joined: Sun Apr 13, 2003 4:46 am
Location: Pittsburgh, PA

.4Dwmrc and CDROM problems (R5K O2, 6.5.20m)

Unread postby karbak » Sat May 17, 2003 9:38 pm

I had a rather nice .4Dwmrc set up that just worked for quite a while - keybindings, root menus, the lot. One day it just stopped working - I have no idea why. I've been too busy to actually fix it for a while now. However, having recently upgraded to 6.5.20m, I looked into the problem, but haven't been able to figure out why the modifications in .4Dwmrc don't load. The file access time (as confirmed by 'stat') shows that the file is indeed read, but none of the keybindings or root menus work. I created a fresh account, and copied the file over, but no dice. Has anyone else seen this problem before ? Is there some way to get at 4Dwm's error messages (if any) ?

On a related note, the upgrade to 6.5.20m removed the CDROM icon from the desktop, and the removable media manager now claims there are no removable media devices to be found on the system. The drive works fine, and shows up in hinv. Digging through Usenet archives, I came across a potential solution - Walter Roberson notes that this may be because of 'objectserver' dying. This is however from a post made several years (and IRIX versions) ago. I'm not sure if this is still correct. Ideas ?

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8042
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Re: .4Dwmrc and CDROM problems (R5K O2, 6.5.20m)

Unread postby nekonoko » Sat May 17, 2003 10:27 pm

Just a shot in the dark here, but would you happen to have SoftWindows95 installed?
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

karbak
Posts: 38
Joined: Sun Apr 13, 2003 4:46 am
Location: Pittsburgh, PA

Re: .4Dwmrc and CDROM problems (R5K O2, 6.5.20m)

Unread postby karbak » Mon May 19, 2003 1:17 pm

nekonoko wrote:Just a shot in the dark here, but would you happen to have SoftWindows95 installed?


Bingo - yes ! But how's that related ?

-arun

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8042
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Re: .4Dwmrc and CDROM problems (R5K O2, 6.5.20m)

Unread postby nekonoko » Mon May 19, 2003 1:22 pm

SoftWindows overrides default 4Dwm keybindings for it's own ... I had this same issue myself recently.

The fix was to comment out some settings in .Xresources (and possibly .Xdefaults), e.g.:

Code: Select all

! For running SoftWindows with 4Dwm
! 4Dwm*sOftWindows*windowMenu:  SoftWindowsMenu
! 4Dwm*keyBindings:          SoftWindowsKeys
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

karbak
Posts: 38
Joined: Sun Apr 13, 2003 4:46 am
Location: Pittsburgh, PA

Re: .4Dwmrc and CDROM problems (R5K O2, 6.5.20m)

Unread postby karbak » Tue May 20, 2003 4:02 pm

nekonoko wrote:SoftWindows overrides default 4Dwm keybindings for it's own ... I had this same issue myself recently.

The fix was to comment out some settings in .Xresources (and possibly .Xdefaults), e.g.:

Code: Select all

! For running SoftWindows with 4Dwm
! 4Dwm*sOftWindows*windowMenu:  SoftWindowsMenu
! 4Dwm*keyBindings:          SoftWindowsKeys


That worked - the desktop is finally usable again. Thanks


Return to “SGI: Discussion”

Who is online

Users browsing this forum: Pontus and 1 guest