Upgrading from 6.5.2f to 6.5.16f

Open discussion on or around SGI; software/hardware related posts should go in the appropriate subforum.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
nick
Posts: 3
Joined: Thu Jan 23, 2003 9:28 am
Location: UK
Contact:

Upgrading from 6.5.2f to 6.5.16f

Unread postby nick » Thu Jan 23, 2003 3:41 pm

OK, having managed to acquire an Indigo2 and the installation CDs for IRIX 6.5.2, I'm wanting to upgrade to 6.5.16 (as that's the latest version that's availble for general download on SGI's site, or so it seems). Currently I've installed a fairly minimal version of 6.5.2, and I've selected the feature stream.

When it comes to upgrading however, I have a couple of conflicts that I simply cannot seem to resolve, which are the following:

Image

(Saves me typing it out!)

I've already STFW, and although someone else has posted a very similar problem the suggested 'solution' is that the user is trying to install a different release stream, which I'm certain isn't the case here.

Sooo, suggestions anyone? It's probably something simple, as I'm relatively new to IRIX (but not UNIX in general) so I might just be missing the obvious.

vegac
Posts: 745
Joined: Thu Jan 23, 2003 11:34 am
Contact:

Unread postby vegac » Thu Jan 23, 2003 8:24 pm

well, I have the same issue with ftn_eoe.sw.libblas, I just told it not to install that package...

as for the compiler, it seems you haven't installed the dev foundation/libraries from the base 6.5 cds. Since the overlays are updates only you need the base irix 6.5 cd's to install any packages not already installed (you can't just update, you need the base as well).

nick
Posts: 3
Joined: Thu Jan 23, 2003 9:28 am
Location: UK
Contact:

Unread postby nick » Fri Jan 24, 2003 7:12 am

Ahah, I *thought* I had during the initial install but when I double checked I found that that obviously wasn't the case. I loaded it off the base CDs, and all was well. 6.5.16f is now installed and working fine.

Cheers!

waldo
Posts: 25
Joined: Sat Feb 01, 2003 5:09 pm
Location: MN/IA, USA
Contact:

Unread postby waldo » Sat Feb 01, 2003 5:13 pm

fwiw, .17m is available from planetmirror ... http://public.planetmirror.com/pub/sgi/patches/irix/6.5/

User avatar
dexter1
Moderator
Moderator
Posts: 2735
Joined: Thu Feb 20, 2003 6:57 am
Location: Zoetermeer, The Netherlands

Unread postby dexter1 » Fri Feb 21, 2003 6:37 am

libblas is something most users don't need anyway, because these are optimised fortran routines for scientific code. They are Matrix manipulation routines, also found at http://www.netlib.org/blas

JAD692003
Posts: 83
Joined: Wed Feb 26, 2003 8:54 am

IRIX 6.5.1 base Install to IRIX 6.5.16 Maintenance Release

Unread postby JAD692003 » Wed Feb 26, 2003 9:11 am

Hello, Iam new to this Forum as well as SGI computers in general, So please bare with me, on my question(s). My computers, SGI Indy , Indigo 2, Iris Indigo (Missing parts/HD/SLED/etc) , the other 2 machines are happy..My Indy computer is Running Irix 5.3 with Desktop Special Edition 1.1, Its ok, Iam getting Irix 6.5.1 Soon. My Indigo 2 has no OS installed as of yet. My question is: I know i can install Irix 6.5.1 on both machines (Indy, I2) . I was on SGI's web site and they have, IRIX 6.5.16 Maintenance Release over 1074
mb, I have a fast DSL so Downloading it is not a Problem. The File format is IRIX6.5.16m.tar.gz , Do i Download it to my machine (I2) , UN- GZ/TAR it, then install it from the desktop Manager app, Cant remember the name of it, The program that keeps track of whats installed and such.. My 2nd Question related to the 1st, If i can DL it and install it that way, Then can i use DHCP on my I2 ? iam currently using a Linksys DSL/Router. Is DHCP easy to setup and supported under Irix 6.5.1? Anyway thanks for any help or direction you can provide.. Jason

User avatar
dexter1
Moderator
Moderator
Posts: 2735
Joined: Thu Feb 20, 2003 6:57 am
Location: Zoetermeer, The Netherlands

Unread postby dexter1 » Wed Feb 26, 2003 12:52 pm

Hello jason,

You ask alot :) but i think i can help you, although you're a bit vague in explaining:

First of all, the tarball you just downloaded is what we call a maintenance release. This means that it is not a complete/full install of IRIX 6.5.16, just an upgrade from previous 6.5.x version to 6.5.16. This means that if you run Irix 5.3 you cannot use this file alone to upgrade to irix 6.5.16. You must have a disk of at least 2 Gb and be prepared to erase irix 5.3 entirely... Also you need to have atleast 4 additional CD's to complete the upgrade: irix foundation 1 and 2 and Development foundation and Libraries...

Now if you get irix 6.5.1 as well, i hope for you that it is a complete set with 6.5.1 overlays, the aforementioned 4 extra CD's and probably more CD's like an application CD, documentation CD, freeware CD and other minor stuff...

So with the 6.5.1 CD's and the 6.5.16 tarball you might be able to install both machines from scratch. Start with the indigo2 leaving the indy running as remote installer with a CD player attached. You *do* have a CD-player hooked up to one of your SGI machines, have you? If so, then you should be able to start a miniroot install on the indigo2. See http://futuretech.mirror.vuurwerk.net/6.5inst.html for all the gory details...

The program which manages all your software packages is called 'swmgr'

DHCP can be set up just fine, see the DHCP thread in "Getting Started"

Hope this helps, see ya

JAD692003
Posts: 83
Joined: Wed Feb 26, 2003 8:54 am

Irix Install

Unread postby JAD692003 » Wed Feb 26, 2003 3:28 pm

Thanks for your info, Yes i have a Toshiba XM-6401B 40X SCSI CDROM Drive in External Scsi Case , My Indigo 2 Machine has a New 4gig Scsi Barracuda 7200rpm drive in it..I guess, i should wait until i get my Irix 6.5.1 then see how the install goes..Then mess around with the Overlay Files later..Irix 5.3 seems pretty limited..Thanks for the link http://futuretech.mirror.vuurwerk.net/6.5inst.html , Great Site for info..

User avatar
Shtoink
Posts: 839
Joined: Mon Jan 27, 2003 1:46 am
Location: Port Orchard, WA

Unread postby Shtoink » Thu Feb 27, 2003 8:51 am

Hmm... a sinlge 4GB HDD can be a bit limiting depending on what you want to install and how you go about doing it. Usually I would recomend putting things like an update from the 6.5.16f tarball on to another HDD so you have some space to work with withough cluttering up your HDD with so much stuff that you have no more room to move about. On a single 4 GB drive, it would be ideal if upi had all of the stuff you wanted to install on CDs.

JAD692003
Posts: 83
Joined: Wed Feb 26, 2003 8:54 am

IRIX 6.5 Core Install to 6.5.16

Unread postby JAD692003 » Wed Mar 05, 2003 7:41 pm

Ok, so i got my IRIX, 6.5 Core cd's
1) IRIX 6.5 Installation Tools CD, June 1998
2) IRIX 6.5 Foundation 1 CD
3) IRIX 6.5 Foundation 2 CD
4) IRIX 6.5 Applications CD, June 1998
5) IRIX 6.5 Development Foundation CD
6) IRIX 6.5 Development Libraries CD
7) IRIX 6.5 Base Documentation CD, June 1998
8) ONC3/NFS Version 3 CD
9) SNMP Access to HP-UX MIB 1.1.2 CD
I installed just the base set
1. Foundation 1
2. Applications
3. Foundation 2
4. Installation Tools
Everything went very good, had no problems. I thought i was getting 6.5.1 but got 6.5 instead. I took the plunge and Downloaded IRIX 6.5.16 Maintenance Release onto my PC. I was planning on putting it onto a External 4 gig HD. I asked this question before, But still little confused.
OK, Let me back up a bit. on my INDY COmputer IRIX 6.5 Base is installed. I will be soon copying over the Maintenance Release to my Ext HD ( on the INDY ), after that do i uncompress it? then run 'swmgr' to start the upgrade? Sorry again about my writing not very good at expressing my thoughts..PLease bear with me..Thank you for all your help so far.

User avatar
Shtoink
Posts: 839
Joined: Mon Jan 27, 2003 1:46 am
Location: Port Orchard, WA

Unread postby Shtoink » Wed Mar 05, 2003 9:55 pm

It sounds like you have the idea of what needs to happen just about down..

At first glance, I don't see anything that sticks out in your process as wrong or needs much adjustemnt.

JAD692003
Posts: 83
Joined: Wed Feb 26, 2003 8:54 am

Thanks.

Unread postby JAD692003 » Thu Mar 06, 2003 7:42 am

Thank you..I will let you know how it went..

JAD692003
Posts: 83
Joined: Wed Feb 26, 2003 8:54 am

Not good

Unread postby JAD692003 » Fri Mar 07, 2003 1:46 pm

Hello again. So after 1:50min of Downloading IRIX 6.5.16 Maintenance Release (1.1gig). I then from my peeCee , Ftp the large file over too my INDY machine, Took 35min..OK, after it was Copied over, I then moved it too my External 4 gig hd. Put the File into a Temp dir. i ran gunzip on the file, it took a while 15min, after it was done i had the same file but with a .tar ext. SO i used the command tar xvf (then the filename.tar) it took a while, THEN I GET THIS Error.
tar:**omitting Data Block**
tar:Discard file: performer_eoe.sw
tar:tape read error: I/O error
I tried it several time, Each time same error..There is about 100megs still left to decompress..SO i went too my PeeCee , and uncompressed the whole file
to a Folder, After that. I ftp the folder that i just uncompressed on the pc, Over too the INDY BOX, THinking..My PC uncompressed it fine, so the file must me ok..Took me another 45min.Then i ran the software mgr, Told the mgr where too look for the folder containing the Release, It read the folder, Then i started to proced to install, it gets to 75% then the app closes. Annoying. So i deleted it all, Umpressed the .tar file again..Let it complain about the tape read error..Looked at the Dir on my PeeCee to see what files it didnt finish uncompressing, Quite a few, So i thought ok, Most the files are allready on the INDY, So i could ftp the files that were missing..After that is seemed like all the files where there..Doubled Checked.Ran software mgr, Proceded to install, 75% app goes away..After several hours i give up, THINKING its a bad file or iam doing somthing wrong with the TAR command..Should i DL another Ver of the Maintenance Release, Like 6.5.15 ? Any ideas would be great , Thanks again...Hope this makes sence..

vegac
Posts: 745
Joined: Thu Jan 23, 2003 11:34 am
Contact:

Unread postby vegac » Fri Mar 07, 2003 2:36 pm

Sounds like either the place you downloaded it from has a corrupted copy, or your download got messed up somehow...unfortunately your choices are a) download it from them again and hope it comes through ok, or b) try to find somewhere else to get it from...

User avatar
Shtoink
Posts: 839
Joined: Mon Jan 27, 2003 1:46 am
Location: Port Orchard, WA

Unread postby Shtoink » Fri Mar 07, 2003 3:14 pm

I would have to agree..

If you are downloading it with your windows machine, I recomend getting it with some sort of download manager. I personally like getright even though it has alot of funky crap that comes with it, I still find it to wrok well. I have had many occasions that a download would have been corrupted or impossible to grab at all and I got a clean download with getright. I'm sure tehre are others out there, I just have no experience with them.

Although, wget is One Bad Mutha!


Return to “SGI: Discussion”

Who is online

Users browsing this forum: Yandex [Bot] and 1 guest