Reverse Fuel mod

Have some gear for sale? Post it here!
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
regan_russell
Posts: 888
Joined: Tue Jul 18, 2006 9:32 pm
Location: Sydney, Australia
Contact:

Re: Reverse Fuel mod

Unread postby regan_russell » Thu Aug 02, 2007 4:38 am

Correct.

Hooking a null modem serial cable 8N1 speed is 38400 for Origin if i recall, 9600 for some other SGI systems.
You should get a text menu or a login: prompt.
Hitting Control and T, should get you into L1.
There should be a command set on techpubs.sgi.com for L1..
I type help and figure out the commands from there for my L1 and L2.
From memory, stuff I have typed lately in L1 include "env" and "power down" to show environment settings and I recall fan speeds and temperatures... Sorry I hope this makes sense... really really tired..

Hope this helps,

Regan
:Onyx2R: :Onyx2R: :0300: :0300: :0300: :O200: :Octane: :Octane: :O2: :O2: :Indigo2IMP: :Indy: :Indy: :Indy: :Indy: :Indy: :Indy: :Indy: :Indy:
:hpserv: J5600, 2 x SUN, 2 x Mac, 3 x Alpha, 2 x RS/6000

User avatar
mia
Posts: 1055
Joined: Wed Feb 19, 2003 1:54 pm

Re: Reverse Fuel mod

Unread postby mia » Thu Aug 02, 2007 7:27 am

regan_russell wrote:Correct.

Hooking a null modem serial cable 8N1 speed is 38400 for Origin if i recall, 9600 for some other SGI systems.
You should get a text menu or a login: prompt.
Hitting Control and T, should get you into L1.
There should be a command set on techpubs.sgi.com for L1..
I type help and figure out the commands from there for my L1 and L2.
From memory, stuff I have typed lately in L1 include "env" and "power down" to show environment settings and I recall fan speeds and temperatures... Sorry I hope this makes sense... really really tired..

Hope this helps,

Regan


Most importantly, can we power up the machine thru L1? (yes this involves that L1 is active all the time). It's my understanding that L1 is available even in the case that the machine is down, correct?

Thanks,
Mia
:Onyx2:

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8145
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Re: Reverse Fuel mod

Unread postby nekonoko » Thu Aug 02, 2007 7:44 am

mia wrote:Most importantly, can we power up the machine thru L1? (yes this involves that L1 is active all the time). It's my understanding that L1 is available even in the case that the machine is down, correct?

Thanks,
Mia


Yes, the L1 command "power up" will bring the system online (same as hitting the front power button). The L1 becomes active as soon as you plug the Fuel into a power outlet (it's always on).
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

loonvf
Posts: 341
Joined: Wed May 05, 2004 12:15 am
Location: Netherlands

Re: Reverse Fuel mod

Unread postby loonvf » Thu Aug 02, 2007 11:25 am

That is very good news Neko!
But do you know how to access the L1 from the Fuel, and what serial settings + cable are needed?

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8145
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Re: Reverse Fuel mod

Unread postby nekonoko » Thu Aug 02, 2007 11:27 am

As mentioned above, 8N1 38400 should do it.
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

loonvf
Posts: 341
Joined: Wed May 05, 2004 12:15 am
Location: Netherlands

Re: Reverse Fuel mod

Unread postby loonvf » Sat Aug 04, 2007 10:44 pm

Hi All,

Allright, thanks for all your help & inputs so far.
Yesterday again we connected the power supply to the motherboard (nothing else was connected to it)
and via a full nullmodem cable with hardware flow control and the settings as mentioned (8N1 38400) this immediately gave access to the L1 when the power cord was put in the PSU.

Then the experimentation could start.
running env etcetera showed that the mobo was missing CPU and GFX.

Code: Select all

001a01-L1>

SGI SN1 L1 Controller
Firmware Image B: Rev. 1.26.9, Built 02/14/2004 00:05:50

#env
Environmental monitoring is enabled and running.

Description    State       Warning Limits     Fault Limits       Current
-------------- ----------  -----------------  -----------------  -------
           12V   Wait Pwr  10%  10.80/ 13.20  20%   9.60/ 14.40    0.19
        12V IO   Wait Pwr  10%  10.80/ 13.20  20%   9.60/ 14.40    0.06
            5V   Wait Pwr  10%   4.50/  5.50  20%   4.00/  6.00    0.70
          3.3V   Wait Pwr  10%   2.97/  3.63  20%   2.64/  3.96    0.91
          2.5V   Wait Pwr  10%   2.25/  2.75  20%   2.00/  3.00    0.00
          1.5V   Wait Pwr  10%   1.35/  1.65  20%   1.20/  1.80    0.00
        5V aux   Wait Pwr  10%   4.50/  5.50  20%   4.00/  6.00    5.12
      3.3V aux   Wait Pwr  10%   2.97/  3.63  20%   2.64/  3.96    3.27
PIMM0 12V bias   Wait Pwr  10%  10.80/ 13.20  20%   9.60/ 14.40    0.06
     Fuel SRAM   Wait Pwr  10%   2.25/  2.75  20%   2.00/  3.00    0.46
      Fuel CPU   Wait Pwr  10%   1.44/  1.76  20%   1.28/  1.92    0.18
    PIMM0 1.5V   Wait Pwr  10%   1.35/  1.65  20%   1.20/  1.80    0.00
PIMM0 3.3V aux   Wait Pwr  10%   2.97/  3.63  20%   2.64/  3.96    3.27
  PIMM0 5V aux   Wait Pwr  10%   4.50/  5.50  20%   4.00/  6.00    5.12
  XIO 12V bias <not present>
        XIO 5V <not present>
      XIO 2.5V <not present>
  XIO 3.3V aux <not present>

Description    State       Warning RPM  Current RPM
-------------- ----------  -----------  -----------
FAN 0  EXHAUST   Wait Pwr          920            0
FAN 1       HD   Wait Pwr         1560            0
FAN 2      PCI   Wait Pwr         1120            0
FAN 3    XIO 1   Wait Pwr         1600            0
FAN 4    XIO 2   Wait Pwr         1600            0
FAN 5       PS   Wait Pwr         1349            0

                              Advisory   Critical   Fault      Current
Description       State       Temp       Temp       Temp       Temp       
----------------- ----------  ---------  ---------  ---------  --------- 
0 NODE 0           Wait Pwr    [Autofan Control]    75C/167F   25C/ 77F
1 NODE 1           Wait Pwr    [Autofan Control]    75C/167F   25C/ 77F
2 NODE 2           Wait Pwr    [Autofan Control]    75C/167F   25C/ 77F
3 PIMM             <not present>
4 ODYSSEY        <not present>
5 BEDROCK          Wait Pwr  Not currently available



So removed the power cable, connected the CPU and 2 DIMMS and power cable connected again.
L1 then indeed shows it has the CPU (still no GFX offcourse) and this was the output:

Code: Select all

001a01-L1>

SGI SN1 L1 Controller
Firmware Image B: Rev. 1.26.9, Built 02/14/2004 00:05:50

001a01-L1>cpu
CPU Present Enabled
--- ------- -------
A    1       1
001a01-L1>fan
fan(s) are off.
fan 0 EXHAUST  rpm 0
fan 1 HD       rpm 0
fan 2 PCI      rpm 0
fan 3 XIO 1    rpm 0
fan 4 XIO 2    rpm 0
fan 5 PS       rpm 0
001a01-L1>brick
rack: 001, slot: 01, partition: none, type: A [2MB flash], serial: NEJ376, source: EEPROM
001a01-L1>leds
CPU  A: 0xff:   Console poll found data for reading
001a01-L1>ver
L1 1.26.9 (Image B), Built 02/14/2004 00:05:50    [Fuel/PE 1MB image]
001a01-L1>env
Environmental monitoring is enabled and running.

Description    State       Warning Limits     Fault Limits       Current
-------------- ----------  -----------------  -----------------  -------
           12V   Wait Pwr  10%  10.80/ 13.20  20%   9.60/ 14.40    0.19
        12V IO   Wait Pwr  10%  10.80/ 13.20  20%   9.60/ 14.40    0.06
            5V   Wait Pwr  10%   4.50/  5.50  20%   4.00/  6.00    0.70
          3.3V   Wait Pwr  10%   2.97/  3.63  20%   2.64/  3.96    0.91
          2.5V   Wait Pwr  10%   2.25/  2.75  20%   2.00/  3.00    0.00
          1.5V   Wait Pwr  10%   1.35/  1.65  20%   1.20/  1.80    0.00
        5V aux   Wait Pwr  10%   4.50/  5.50  20%   4.00/  6.00    5.12
      3.3V aux   Wait Pwr  10%   2.97/  3.63  20%   2.64/  3.96    3.27
PIMM0 12V bias   Wait Pwr  10%  10.80/ 13.20  20%   9.60/ 14.40    0.06
     Fuel SRAM   Wait Pwr  10%   2.25/  2.75  20%   2.00/  3.00    0.46
      Fuel CPU   Wait Pwr  10%   1.44/  1.76  20%   1.28/  1.92    0.18
    PIMM0 1.5V   Wait Pwr  10%   1.35/  1.65  20%   1.20/  1.80    0.00
PIMM0 3.3V aux   Wait Pwr  10%   2.97/  3.63  20%   2.64/  3.96    3.27
  PIMM0 5V aux   Wait Pwr  10%   4.50/  5.50  20%   4.00/  6.00    5.10
  XIO 12V bias <not present>
        XIO 5V <not present>
      XIO 2.5V <not present>
  XIO 3.3V aux <not present>

Description    State       Warning RPM  Current RPM
-------------- ----------  -----------  -----------
FAN 0  EXHAUST   Wait Pwr          920            0
FAN 1       HD   Wait Pwr         1560            0
FAN 2      PCI   Wait Pwr         1120            0
FAN 3    XIO 1   Wait Pwr         1600            0
FAN 4    XIO 2   Wait Pwr         1600            0
FAN 5       PS   Wait Pwr         1349            0

                              Advisory   Critical   Fault      Current
Description       State       Temp       Temp       Temp       Temp       
----------------- ----------  ---------  ---------  ---------  --------- 
0 NODE 0           Wait Pwr    [Autofan Control]    75C/167F   25C/ 77F
1 NODE 1           Wait Pwr    [Autofan Control]    75C/167F   25C/ 77F
2 NODE 2           Wait Pwr    [Autofan Control]    75C/167F   25C/ 77F
3 PIMM             Wait Pwr    [Autofan Control]    75C/167F   25C/ 77F
4 ODYSSEY        <not present>
5 BEDROCK          Wait Pwr  Not currently available

001a01-L1>pimm
PIMM clock source is internal
PIMM mode is synchronous
001a01-L1>usb

Device: 0  Disconnects: 0  Bus Resets:  1

Endpoint State    Status    Stalls Errors Timeouts
-------- -----    ------    ------ ------ --------
Control  Stalled  Suspended 32     0      0   
Read     Unconfig Ready     0      0      0   
Write    Unconfig Ready     0      0      0   
001a01-L1>sel
console input:  001a01 console
console output: not filtered.
001a01-L1>mgn
Supply          State Voltage    Margin  Value Index
--------------  ----- ---------  ------- ----- -----
          3.3V     NC    0.912V   normal     0   0
          2.5V    off    0.000V   normal     0   1
          1.5V     NC    0.000V   normal     0   2
     Fuel SRAM     NC    0.455V   normal     0   3
      Fuel CPU    off    0.183V   normal   130   4
    PIMM0 1.5V     NC    0.000V   normal     0   5
      XIO 2.5V     <not present>



Then trying the power up L1 command gave a disappointing result (debugging stuff included too):

Code: Select all

001a01-L1>power up
ERROR: I2C:not present

001a01-L1>l1dbg
L1 irouter debugging is off
L1 junkbus debugging is slab 0, mask 0x0
L1 environmental debugging is off
L1 port interrupt debugging is off
L1 i2c interrupt debugging is off
L1 voltage margin debugging is off
L1 PROM request debugging is off
L1 irouter req/rsp suspend is 300, event suspend is 50
L1 data dump on PPP error is off
L1 malloc failure PANICs are disabled
001a01-L1>debug
debug switches set to 0x0003
001a01-L1>DEBUG: i2cInt.c line 365 ; I2C interrupts enabled, int_level: 1
DEBUG: i2cInt.c line 351 ; I2C interrupts disabled, int_level: 1
DEBUG: i2cInt.c line 365 ; I2C interrupts enabled, int_level: 1
DEBUG: i2cInt.c line 351 ; I2C interrupts disabled, int_level: 1
DEBUG: i2cInt.c line 365 ; I2C interrupts enabled, int_level: 1
DEBUG: i2cInt.c line 351 ; I2C interrupts disabled, int_level: 1
DEBUG: i2cInt.c line 365 ; I2C interrupts enabled, int_level: 1
DEBUG: i2cInt.c line 351 ; I2C interrupts disabled, int_level: 1
001a01-L1>l1de# #bg
L1 irouter debugging is off
L1 junkbus debugging is slab 0, mask 0x0
L1 environmental debugging is off
L1 port interrupt debugging is off
L1 i2c interrupt debugging is on
L1 voltage margin debugging is off
L1 PROM request debugging is off
L1 irouter req/rsp suspend is 300, event suspend is 50
L1 data dump on PPP error is off
L1 malloc failure PANICs are disabled
001a01-L1>DEBUG: i2cInt.c line 365 ; I2C interrupts enabled, int_level: 1
DEBUG: i2cInt.c line 351 ; I2C interrupts disabled, int_level: 1
001a01-L1>eepro# #om
NODE (CH)
00 20 01 06 00 00 00 d9
NODE (CIA)
00 02 17 c2 4e 41 c2 4e 41 c1 00 00 00 00 00 84
NODE (BIA)
00 09 00 33 47 41 c9 53 4f 4c 45 43 54 52 4f 4e
c4 49 50 33 34 c6 4e 45 4a 33 37 36 cc 30 33 30
5f 31 37 30 37 5f 30 30 34 00 c2 5f 43 01 02 c2
30 30 04 ff ff ff ff 04 ff ff ff ff 04 ff ff ff
ff c1 00 00 00 00 00 e9
NODE (PIA), no data available (1)
NODE (IUA)
00 03 30 01 00 03 00 00 00 00 00 08 00 01 00 0c
0b 45 01 03 00 20 1f 00 01 02 03 4a 00 03 4a 06
50 26 06 3f fc 06 3f b7 06 08 88 06 02 46 06 00
ec 18 00 6b 00 00 00 72
MAC (CH)
00 00 01 03 00 00 00 fc
MAC (CIA)
00 02 17 c2 4e 41 c2 4e 41 c1 00 00 00 00 00 84
MAC (BIA)
00 0b 00 00 00 00 c2 4e 41 cb 4d 41 43 20 41 44
44 52 45 53 53 c6 4e 41 20 20 20 20 cc 4e 41 20
20 20 20 20 20 20 20 20 20 00 c2 4e 41 01 02 c2
4e 41 04 ff ff ff ff 04 ff ff ff ff 04 ff ff ff
ff cc 30 38 30 30 36 39 31 30 32 36 31 41 00 c1
00 00 00 00 00 00 00 ce
MAC (PIA), no data available (1)
MAC (IUA), no data available (1)
PIMM (CH)
00 20 00 01 00 00 00 df
PIMM (CIA), no data available (1)
PIMM (BIA)
00 07 00 80 17 34 c9 53 4f 4c 45 43 54 52 4f 4e
c8 49 50 33 34 50 49 4d 4d c6 4d 4d 4d 35 33 32
cc 30 33 30 5f 31 37 30 38 5f 30 30 32 00 c2 5f
48 01 02 c2 30 30 c1 9c
PIMM (PIA), no data available (1)
PIMM (IUA)
00 01 60 01 00 01 00 04 00 14 00 2e 00 2e 00 3e
00 4a 00 4a 00 4a 00 4a 00 4a 00 4a 00 4a 00 4a
00 3e 00 4a 00 4a 00 4a 00 4a 00 4a 00 4a 00 4a
00 4a 04 44 01 00 00 00 0f 00 01 01 01 70 00 01
70 00 04 03 01 01 20 07 01 00 46 00 46 00 04 03
01 01 20 07 01 00 33 00 33 00 00 00 00 00 00 00
00 00 00 00 00 00 00 7d
XIO - no hardware detected
DIMM 0 (JEDEC-SPD)
80 08 07 0d 0a 02 48 00 04 a0 80 02 82 08 08 01
0e 04 0c 01 02 26 00 00 00 00 00 50 3c 50 30 40
b0 b0 60 60 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 5c
ce 00 00 00 00 00 00 00 01 4d 33 20 34 37 4c 36
34 32 33 44 54 32 2d 43 41 30 20 32 44 03 09 0c
31 30 00 00 57 4d 43 34 38 30 56 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
DIMM 2 - no hardware detected
DIMM 1 (JEDEC-SPD)
80 08 07 0d 0a 02 48 00 04 80 80 02 82 08 08 01
0e 04 0c 01 02 26 00 a0 80 00 00 50 3c 50 32 40
c0 c0 60 60 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 7e
7f 7f fe 00 00 00 00 00 4a 43 4d 32 32 30 32 42
31 20 20 20 20 20 20 20 20 20 20 32 20 04 05 12
00 3c 41 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
DIMM 3 - no hardware detected
001a01-L1>
001a01-L1>ver
L1 1.26.9 (Image B), Built 02/14/2004 00:05:50    [Fuel/PE 1MB image]
001a01-L1>test intr
I2C interrupts, High: 29  Low: 6600
         NODE 0  Env Monitor:    0
         NODE 1  Env Monitor:    0
         NODE 2  Env Monitor:    0
           PIMM  Env Monitor:    0
        ODYSSEY  Env Monitor: not present
        BEDROCK  Env Monitor:    0
     BUS SELECT I/O Expander:    0
MARGIN CONTROL I/O Expander:    0
       LED0 LOW I/O Expander:    0
ASIC CONTROL 1 I/O Expander:    0
ASIC CONTROL 2 I/O Expander:    0
   POWER ENABLE I/O Expander:    0
     XB CONTROL I/O Expander:    0
   PIMM CONTROL I/O Expander:    0
    ODYSSEY GFX I/O Expander: not present
DISPLAY CONTROL I/O Expander:    0
001a01-L1>log
08/04/07 04:14:05 L1 booting 1.26.9
08/04/07 04:14:06 PSC: 0x0f
08/04/07 04:14:06 Unknown PSC
08/04/07 04:14:06 ALERT: Unknown PSC: 15
08/04/07 04:14:09 ALERT: Error configuring PIMM power (Fuel SRAM) monitoring: not present
08/04/07 04:14:09 USB0: waiting on open
08/04/07 04:19:46 L1 booting 1.26.9
08/04/07 04:19:46 PSC: 0x06
08/04/07 04:19:46 USB0: waiting on open
08/04/07 04:20:51 power up (COMMAND)
08/04/07 04:20:51 Error enabling fans on device 0
08/04/07 04:20:51 Error enabling fans on device 0
08/04/07 04:20:51 Error disabling fans on device 4
08/04/07 04:20:51 Error disabling fans on device 4
08/04/07 04:20:51 Error disabling fans on device 4
08/04/07 04:20:51 Error disabling fans on device 4
08/04/07 04:20:51 Error disabling fans on device 4
08/04/07 04:20:51 Error disabling fans on device 4
08/04/07 04:25:40 power up (COMMAND)
08/04/07 04:25:40 Error enabling fans on device 0
08/04/07 04:25:40 Error enabling fans on device 0
08/04/07 04:25:40 Error disabling fans on device 4
08/04/07 04:25:40 Error disabling fans on device 4
08/04/07 04:25:40 Error disabling fans on device 4
08/04/07 04:25:40 Error disabling fans on device 4
08/04/07 04:25:40 Error disabling fans on device 4
08/04/07 04:25:40 Error disabling fans on device 4
08/04/07 04:31:58 power up (COMMAND)
08/04/07 04:31:58 Error enabling fans on device 0
08/04/07 04:31:58 Error enabling fans on device 0
08/04/07 04:31:58 Error disabling fans on device 4
08/04/07 04:31:58 Error disabling fans on device 4
08/04/07 04:31:58 Error disabling fans on device 4
08/04/07 04:31:58 Error disabling fans on device 4
08/04/07 04:31:58 Error disabling fans on device 4
08/04/07 04:31:58 Error disabling fans on device 4
08/04/07 04:34:20 L1 booting 1.26.9
08/04/07 04:34:20 PSC: 0x06
08/04/07 04:34:20 USB0: waiting on open
08/04/07 04:35:23 power up (COMMAND)
08/04/07 04:35:23 Error enabling fans on device 0
08/04/07 04:35:23 Error enabling fans on device 0
08/04/07 04:35:23 Error disabling fans on device 4
08/04/07 04:35:23 Error disabling fans on device 4
08/04/07 04:35:23 Error disabling fans on device 4
08/04/07 04:35:23 Error disabling fans on device 4
08/04/07 04:35:23 Error disabling fans on device 4
08/04/07 04:35:23 Error disabling fans on device 4
08/04/07 04:39:01 power up (COMMAND)
08/04/07 04:39:01 Error enabling fans on device 0
08/04/07 04:39:01 Error enabling fans on device 0
08/04/07 04:39:01 Error disabling fans on device 4
08/04/07 04:39:01 Error disabling fans on device 4
08/04/07 04:39:01 Error disabling fans on device 4
08/04/07 04:39:01 Error disabling fans on device 4
08/04/07 04:39:01 Error disabling fans on device 4
08/04/07 04:39:01 Error disabling fans on device 4
08/04/07 04:43:45 power down (COMMAND)
08/04/07 04:43:46 Error disabling fans on device 4
08/04/07 04:43:46 Error disabling fans on device 4
08/04/07 04:43:46 Error disabling fans on device 4
08/04/07 04:43:46 Error disabling fans on device 4
08/04/07 04:43:46 Error disabling fans on device 4
08/04/07 04:43:46 Error disabling fans on device 4



So main question is, is it the missing GFXcard that makes my Fuel mobo not start or is it something more serieus and do I really have a broken mobo that can only function as a fancy temperature meter and a clock?

The fact that no fans were attached should not be a problem as we tested that on a working Fuel and it still starts at power up command.

Has anyone an idea what this problem indicates?

User avatar
nekomusume
Posts: 152
Joined: Tue Jul 31, 2007 10:54 pm
Location: Sunderland, UK
Contact:

Re: Reverse Fuel mod

Unread postby nekomusume » Sat Aug 04, 2007 10:57 pm

loonvf wrote:So main question is, is it the missing GFXcard that makes my Fuel mobo not start or is it something more serieus and do I really have a broken mobo that can only function as a fancy temperature meter and a clock?

The fact that no fans were attached should not be a problem as we tested that on a working Fuel and it still starts at power up command.

Has anyone an idea what this problem indicates?


any cpu fan that might of became lose and if the fuel has a cpu fan when you the working fuel did you disable the cpu fan too?

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8145
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Re: Reverse Fuel mod

Unread postby nekonoko » Sat Aug 04, 2007 11:14 pm

Since you have basically a bare motherboard with no fans (looking at your output), you'll need to disable environmental monitoring in order to power it up.
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

User avatar
jan-jaap
Donor
Donor
Posts: 4882
Joined: Thu Jun 17, 2004 11:35 am
Location: Wijchen, The Netherlands
Contact:

Re: Reverse Fuel mod

Unread postby jan-jaap » Sun Aug 05, 2007 3:57 am

nekonoko wrote:Since you have basically a bare motherboard with no fans (looking at your output), you'll need to disable environmental monitoring in order to power it up.

We tried that, but it doesn't even fire up the power supply.

We also tried the inverse: pull all memory, most fans, switches and leds from my Fuel and power it up from the L1. It does power up (and power down after 30 seconds due to the expected env. issues). At that point, the only difference between my Fuel and Francois' motherboard was that mine still had the graphics installed.

It's the "I2C: Error: <something>" message that's the problem, I think. And the question is: is it due to the missing grahics, or due to a broken motherboard?
:PI: :Indigo: :Indigo: :Indy: :Indy: :Indy: :Indigo2: :Indigo2: :Indigo2IMP: :Octane: :Octane2: :O2: :O2+: Image :Fuel: :Tezro: :4D70G: :Skywriter: :PWRSeries: :Crimson: :ChallengeL: :Onyx: :O200: :Onyx2: :O3x02L:
To accentuate the special identity of the IRIS 4D/70, Silicon Graphics' designers selected a new color palette. The machine's coating blends dark grey, raspberry and beige colors into a pleasing harmony. (IRIS 4D/70 Superworkstation Technical Report)

User avatar
tillin9
Posts: 591
Joined: Sat Mar 31, 2007 8:39 pm
Location: New York, NY / Westport, CT / #mupen64plus on freenode

Re: Reverse Fuel mod

Unread postby tillin9 » Sun Aug 05, 2007 5:25 pm

I2C is the protocol used by sensors to let the BIOS know things like temps, fan speeds, and supply voltages.

The

Code: Select all

12V   Wait Pwr  10%  10.80/ 13.20  20%   9.60/ 14.40    0.19

vs.

Code: Select all

5V aux   Wait Pwr  10%   4.50/  5.50  20%   4.00/  6.00    5.12

looks like the issue to me. You seem to have a problem with your PSU adaptor (i.e. not all rails are getting power).

If you're sure the wiring is okay, you may have damaged your voltage monitoring IC.

Finally, since the video card does have an I2C connection to monitor fans and voltage on most newer cards. It may be on the Fuel this system is integrated to the central I2C controller and not on a secondary one on the XIO bus, so the lack of a video card means an I2C error. Or the PROM is smart enough to sense the secondary chip. You may be able to disbale this somehow.

loonvf
Posts: 341
Joined: Wed May 05, 2004 12:15 am
Location: Netherlands

Re: Reverse Fuel mod

Unread postby loonvf » Mon Aug 06, 2007 11:34 am

Not so sure about the damaged voltage monitoring.
I measured the same values with a VoltMeter at these pins.

The powersupply is not "running" that means, it only supplies the 5V standby supply and some minor others.
This is the mode where you just put the power cable in the Fuel PSU and in your wall socket and the PSU fan is not even spinning.
It is before pressing the start button or giving the "power up" command in the L1 controller.

This also shows that the L1 controller runs at this 5V standby voltage.

On a working Fuel, when the PSU fan is spinning the start button (on the front of the Fuel) is pressed or a "power up" command is given successfully. While in my case I just get that strange error message when I give the "power up" command.

So the main question is, who has ever started a Fuel when the graphics card was removed from the machine and what was the effect (did it work at all) ?

User avatar
mia
Posts: 1055
Joined: Wed Feb 19, 2003 1:54 pm

Re: Reverse Fuel mod

Unread postby mia » Mon Nov 05, 2007 11:39 pm

Sorry to ask again, but I just can't figure this out, how can I turn a fuel on, remotely, assuming it's off to start with, and I have access to "L1 diag", network and serial console only.


Halp!
Mia
:Onyx2:


Return to “Hardware For Sale/Trade”

Who is online

Users browsing this forum: No registered users and 3 guests