Page 6 of 7

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Thu Jan 07, 2016 8:10 am
by Axatax_
I gave it a shot on my r5k o2, and it seg faulted on cps1 and cps2 games


The binary is compiled for IP27/R12K.

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Thu Jan 07, 2016 9:58 pm
by Axatax_
gijoe77,

Can you try this -- specifically, if there is improvement WRT to the non-working systems... This is based on a *much* newer MAME.

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Thu Jan 07, 2016 10:01 pm
by Axatax_
OK, so I can't attach, probably due to the file size -- Will send to /incomming.

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Thu Jan 07, 2016 10:20 pm
by Axatax_
Thank you for helping out with this!! -- Just one thing, when you mention systems (ie. cps*), please state which game failed.

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Thu Jan 07, 2016 10:28 pm
by Axatax_

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Thu Jan 07, 2016 10:35 pm
by gijoe77
ok will do - I'm currently at work with some other IRIX boxes (r5k 02, single 600 v12 octane, dual 360 MXE octane, tezro v12 quad 700). I'll try to do some testing with the different mames I have (mame.xgl .98, sdlmane .149 for kicks), and I'm also testing the mplayer 1.1.1 I was planning on testing for you months ago (btw, early results testing with my tezro - it was smoking fast with -vo gl_nosw)

I'll have to wait for bossman to move that file to contrib :)

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Thu Jan 07, 2016 11:56 pm
by Axatax_
On the MPlayer/MIPS mailing list, we have a 4x1GHz Tezro decoding "IMAX: Journey into Amazing Caves [Blu-ray]", somewhat imperfectly. Nobody really thought you could watch DVDs on an Octane, either...

If there was only 25 hours in a day...

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Fri Jan 08, 2016 11:27 pm
by gijoe77
I gotta say, I forgot just how slow an o2 really is - I dunno how I put up with it for so many years as a desktop system in the early 2000's. I had outdated neko libraries so I had to update a few to just be able to run the SDLmame .149 and mplayer 1.1.1 - after each wave of nekoware installs it took 60+ min for swmgr to run rqsall. after like 6+hours of this I still had unresolved symbols and had to just abandon ship with the o2. my old blue toaster really is a Frankenstein - it still has the original install from around 2001, with all the various stuff I tried installing through the years - its amazing anything runs on it as it is. I do think there is a serious bottleneck on those systems with bus speed to the system disk, I dunno why it takes so long to install stuff on those systems.

But anyway, I did get to do more mplayer testing on my 4x1ghz Tezro, seems the H264 MP4 video's don't perform as great as I thought they originally did - the ones I tried with no real command line ju-jitsu started playing fine but eventually slowed down and lost sync (but they have a great start, first 30 sec or so they run perfect). The XViD MP4 files I played worked absolutely great, ran without any issues with no loss of sync - currently watching Game of Thrones on my Tezro. I tried some H264 1920 videos from my Samsung Note 3 cell phone and it didn't really work at all.

Is there something more I can do to help with the mplayer testing? particular videos, formats, command lines to try? I'm not well versed in mplayer, but I'd love to know what the blue-ray fellow was doing as a command line to try out on other formats..

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Mon Jan 11, 2016 2:02 pm
by Axatax_
Yeah, the 1.1.1 Mplayer has sync issues. This was just a "test" build of something newer than what we had. I wanted to see if others could re-produce my results (ie. run the binary), and if I had the ability to actually do the port. You can run 480p H.264 on a top-of-the-line Octane with this version (with sync issues).

SGI MIPS is "officially" supported on MPlayer now and that's where my changes go, so if you want the latest and greatest, you have to go to Mplayer SVN.

Just be warned, Mplayer in its entirety is in 1000 pieces right now, so any official release, SGI or otherwise, is a ways off.

When things stabilize, I'll do another release. I haven't given up - there's upstream issues that need to clear out before we have something worthwhile to package up. I think the "re-spin" of the 1.0.4 I did is pretty darn good - just don't expect miracles.

EDIT: -- WRT to the 1.0.4. - I don't think there's a DVD this won't play now, either with AC3 or DTS. If you find a problem child, let me know, but I don't think that'll happen. I'm pretty confident I nicked *all* the DVD-related issues...

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Mon Jan 11, 2016 8:39 pm
by Axatax_
Probably should move this to an Mplayer thread...

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Mon Jan 11, 2016 9:30 pm
by Axatax_
Guys -- the Mplayer stuff is really another thread.

Please LMK if this MESS/MAME is cool, and I'll do a proper Neko package. (I think it hits the mark 10000% - but I'd like some feedback outside of one forum member).

The -06 version doesn't incorporate my OpenGL work - I'm just trying to assess games compatibility.

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Tue Jan 12, 2016 4:55 pm
by gijoe77
I had some free time at work and gave the glmame .94 a run with a quad 700mhz V12 Tezro, everything was perfect when running in a window - I went up as high as a scale factor of 3 - no issues with any games I tried. Some neogeo and cps2 games started to suffer once in fullscreen, but everything else was perfect.

I have a single 600 v12 octane and a dual 360 MXE octane i'll try to try tonight, along with the .106 build.

I have spent a lot of time through the years playing with various builds of mame on various SGI's (Indigo2's, o2's, octanes, etc), there have been some really good fast builds earlier in xmames history, there were great builds that cut out sound for playable builds - but this has been the best I have seen out all of them. Def congrats on a great job. If only I could twist your arm into looking into adding a working cps3 driver!

pics from the quad 700 V12 Tezro:

20160112_045331.jpg

20160112_044913.jpg

20160112_044240.jpg

20160112_044054.jpg

20160112_043155.jpg

20160112_042924.jpg

20160112_042920.jpg

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Tue Jan 12, 2016 5:03 pm
by gijoe77
Well I suppose I will never have a more appropriate thread to post my arcade boards with SGI equipment, so here it is - my 2 slot neogeo, CPS2 and CPS3 SF3 arcade boards!

20160112_195112.jpg


I have a whole lot more boards, not sure if we have any other arcade hardware guys here?

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Fri Jan 15, 2016 4:27 pm
by Axatax_
If only I could twist your arm into looking into adding a working cps3 driver!


You don't need to ;) . You just need to identify which version of MAME the CPS3 stuff started shining.

I'm totally cool with trying to back port known-working and important drivers. I think this is a better strategy @ this time than trying to chase the latest MAME on SGI. We have a really good, working base right now. You do the research, and I'll attempt the port.

Re: sdlmame 0.149 sent to /incoming. Need testers/feedback.

Posted: Mon Jan 18, 2016 3:54 pm
by gijoe77
Ran some tests on a single 600 V12 octane, it pretty much performed close to my quad 700 V12 Tezro (not surprised, the octane is a production machine, it has everything turned off and nothing running as per regular discreet spec, so for a single threaded program it was pretty close).

20160118_055155.jpg

20160115_042625.jpg

20160115_042750(0).jpg

20160115_043011.jpg

20160115_043236.jpg

20160115_043520.jpg

20160115_043537.jpg


I have another octane (dual 360 MXE) I want to try out tonight if time permits