Page 1 of 1

SCSI2SD v6 vs Indy

Posted: Sun Dec 31, 2017 7:21 am
by jcs
I've been attempting to resuscitate an Indy R5k using a SCSI2SD v6 board. I'm installing from a Toshiba external CD (also tried a Plextor writer - same problem). I have a Class 10 card configured without termination, parity enabled, and SCSI2 mode. My v6 board has the latest firmware. The end of the chain is terminated at the CD using an active terminator.

I can boot sash and run fx from the CD. I can install the miniroot and get to inst. Once the installation has started, I start seeing the following errors:

Code: Select all

Reading product descriptions .. 54% WARNING: wd93 SCSI Bus = 0 ID=4 LUN = 0: SCSI cmd=0x28
timeout after 60 sec.  Resetting SCSI bus
dksc0d4: Device not ready: Not ready to perform command (asc-0x4, asq=0x1)

... bunch more "not ready" lines

Too much data requested (probable SCSI bus cabling problem).  Resetting SCSI bus


Has anyone had any luck with the v6 card on the wd93 controller using a CD or am I going to need to install from the network?

Re: SCSI2SD v6 vs Indy

Posted: Sun Dec 31, 2017 9:00 am
by GRudolf94
The CDROM sits on the external bus and should be terminated there, using a terminator attached to the daisychain port of the drive, as you probably have already done. The internal bus must be terminated either using a cable with a terminator crimped to the end, or at the last device, which would be the SCSI2SD, so you have to enable termination on it. Actually, they're both different ends of the same bus, but I guess I made myself understandable. With no CD attached, keep the terminator on the Indy's rear port.

Beware, the SCSI2SD does not support sync negotiation and IRIX will keep nagging you about that.

Re: SCSI2SD v6 vs Indy

Posted: Sun Dec 31, 2017 9:12 am
by jcs
Thanks for the reply. I have both ends terminated - one with the Indy's own (on cable) and the other end has an active terminator. I've also tried
using the terminator on the SCSI2SD card instead of the on-cable one, but no dice. Reading here, people seem to have success with the v5 board. Perhaps it's a firmware problem on the v6 board?

The "too much data" thing usually means a termination problem, but the system is terminated properly and the cables are fine (tried changing those out).

Re: SCSI2SD v6 vs Indy

Posted: Sun Dec 31, 2017 10:02 am
by GRudolf94
It would seem to me the v5 is a more reliable solution, being a single-chip thing. Are there any firmwares you can downgrade this v6 to? I wouldn't count out a possible hardware failure on the card itself, too.

Re: SCSI2SD v6 vs Indy

Posted: Sun Dec 31, 2017 10:41 am
by jcs
I'll try rolling the firmware back.

Re: SCSI2SD v6 vs Indy

Posted: Mon Jan 01, 2018 2:27 am
by dexter1
See this tread: viewtopic.php?f=3&t=16731287&hilit=scsi2sd+cdrom

Apparently the SCSI2SD v5 does not like to be paired with other devices on the SCSI chain, this may happen to the v6 as well.
Since the Indy only has one controller, i'm afraid you're stuck with either netbooting the indy or preparing the install on a regular HDD and clone it

Re: SCSI2SD v6 vs Indy

Posted: Mon Jan 01, 2018 8:59 am
by jcs
Well, that's a bit annoying. I'll pursue the netbooting route next chance I get. Thanks.