Onyx 10000 deskside keyboard issues

SGI hardware problems, solutions, tips, hacks, etc.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
MrBill
Posts: 271
Joined: Fri Dec 28, 2012 12:50 pm
Location: Vero Beach, Florida

Onyx 10000 deskside keyboard issues

Unread postby MrBill » Mon Nov 20, 2017 8:39 pm

Ive been using my onyx deskside without issue, until today where mid session my keyboard and mouse stopped working.
Upon restart the reyboard no longer beeps at bootup, and says something along the lines of keyboard error.

I do not have the correct cable to connect the machine to my desktop and capture the bootup log, and the message flys by to fast for me to catch.

Anything I can try? The machine has not behaved in this way before. even setting console=g does not appear to change anything.
:Octane: :Octane: :Octane: :Octane2: :Indy: :Indy: :Indigo: :Indigo2: :Crimson:Image :Tezro: :Tezro: :Onyx2: :Onyx2: :Onyx: :OnyxR: :BA213:

User avatar
jan-jaap
Donor
Donor
Posts: 4937
Joined: Thu Jun 17, 2004 11:35 am
Location: Wijchen, The Netherlands
Contact:

Re: Onyx 10000 deskside keyboard issues

Unread postby jan-jaap » Tue Nov 21, 2017 5:20 am

Try to replace the keyboard, mouse and the cable which connects them to the system? Alternatively, test the keyboard and mouse with a compatible system (Indigo).

At least you'll know whether to blame the system, or the peripherals.

I believe the keyboard controller is on the IO4 board, but there's also a bunch of fuses behind the bulkhead where you plug in the keyboard and mouse.
:PI: :Indigo: :Indigo: :Indy: :Indy: :Indy: :Indigo2: :Indigo2: :Indigo2IMP: :Octane: :Octane2: :O2: :O2+: Image :Fuel: :Tezro: :4D70G: :Skywriter: :PWRSeries: :Crimson: :ChallengeL: :Onyx: :O200: :Onyx2: :O3x02L:
To accentuate the special identity of the IRIS 4D/70, Silicon Graphics' designers selected a new color palette. The machine's coating blends dark grey, raspberry and beige colors into a pleasing harmony. (IRIS 4D/70 Superworkstation Technical Report)

MrBill
Posts: 271
Joined: Fri Dec 28, 2012 12:50 pm
Location: Vero Beach, Florida

Re: Onyx 10000 deskside keyboard issues

Unread postby MrBill » Wed Nov 22, 2017 4:49 pm

Alright. Some progress. I pulled the memory board out of the onyx terminator rack and put it in the deskside. No more memory errors at bootup. over 1500MB of memory compared to 256mb with the other board. a big improvement. I also pulled out the io4 controller from the terminator rack and installed it in the deskside. Still no activity on the keyboard. Im beginning to suspect that board that the IO4 connects to with a cable, the one with all the io ports on it. I think its unlikely that both io4 controllers are bad. Ive tried a different keyboard too, no luck.

I will port back after i try swapping out that front io plate board and see if anything changes.
:Octane: :Octane: :Octane: :Octane2: :Indy: :Indy: :Indigo: :Indigo2: :Crimson:Image :Tezro: :Tezro: :Onyx2: :Onyx2: :Onyx: :OnyxR: :BA213:

MrBill
Posts: 271
Joined: Fri Dec 28, 2012 12:50 pm
Location: Vero Beach, Florida

Re: Onyx 10000 deskside keyboard issues

Unread postby MrBill » Wed Nov 22, 2017 5:27 pm

it was indeed that front "IO4 filter secondary" board. upon swapping it out the keyboard works once again.

This is actually a pretty good looking place for something to break, looks simple enough that with volt meter it can be troubleshooted and repaired.
:Octane: :Octane: :Octane: :Octane2: :Indy: :Indy: :Indigo: :Indigo2: :Crimson:Image :Tezro: :Tezro: :Onyx2: :Onyx2: :Onyx: :OnyxR: :BA213:


Return to “SGI: Hardware”

Who is online

Users browsing this forum: Semrush [Bot] and 4 guests