Origin 3200 Not Booting

SGI hardware problems, solutions, tips, hacks, etc.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
Posts: 20
Joined: Thu Aug 17, 2017 2:25 pm

Origin 3200 Not Booting

Unread postby r1200gsDave » Mon Sep 25, 2017 11:58 am

I have gotten past some struggles and still not getting the Origin to boot up. I think that the wrong devices are set in the PROM to boot off of.

I can get to the Command Monitor from the L1 and do ls commands on both of the hard drives and cd. I have a couple of CD burned that I have verified with Linux as burned correctly that are a couple of the Installation tools disks.

From the command monitor the devices look like this:

Integral SCSI controller 1: Version Fibre Channel QL2200
Disk drive: unit 1 on SCSI Controller 1, (dksc(1,1,0))
Disk drive: unit 2 on SCSI Controller 1, (dksc(1,2,0))
Integral SCSI controller 5: Version IEEE-1394/Firewire
CDROM: unit 1 on SCSI Controller 5, (cdrom(5,1,7))

But on boot it looks like it is trying to boot off a different drive.
Starting up the system...

To perform system maintenance instead, press <Esc>
kl_parse_path: dev_info = NULL
Unable to execute dksc(0,1,8)/sash: no such device
Unable to load bootfile: no such device

Unable to boot; press any key to continue:

If I try to boot off the CD it again tries a different drive.

Insert the installation CD-ROM, then press <enter>:

kl_parse_path: dev_info = NULL
Unable to open "dksc(0,1,0)": no such device

Looking at the file system on the drives is successful and I am sure that I do not have a failed drive or controller. or a cd burned the wrong way.

What is the magick to point it at the correct disk to boot.

Also I was pretty amazed that the L1 knew what the date was. Not bad for a system that is at least 15 years old.
09/25/2017 10:17:02 EDT

User avatar
Posts: 1021
Joined: Thu Nov 08, 2007 4:35 pm
Location: Lynnwood, WA

Re: Origin 3200 Not Booting

Unread postby japes » Mon Sep 25, 2017 2:00 pm

Do you have another FC card as well? My Origin 3k had the FC card as controller 0 (I have more than one now, but originally). If so I suspect if you move the short FC cable to the other interface so your drives are on controller 0 instead of 1 you'll get more signs of life.

Alternatively, head over to the command monitor and use printenv to see the PROM variables and use setenv to change the boot device from dksc(0,1,8)...... to dksc(1,1,0)......

Odd to see the booting from the CD not picking the correct device, you're using the install system software option when it tries to boot from dksc(0,1,0)? I'm not sure if I ever booted from the CDROM come to think of it - I probably installed from a network source.

You could try resetenv from the command monitor as well to set everything default.
:O3000: :Fuel: :Tezro: :Tezro: :Octane2: :Octane: :Octane: :Indigo: :Indigo: :Indigo: :Indigo: :O2: :1600SW: :O2: :1600SW: :1600SW: :Indigo2: :Indigo2: :Indigo2: :Indigo2: :Indigo2IMP: :Indy: :Indy: :Indy: :Indy: :O3x0: :O3x02L: :O3x02L:

Posts: 20
Joined: Thu Aug 17, 2017 2:25 pm

Re: Origin 3200 Not Booting

Unread postby r1200gsDave » Mon Sep 25, 2017 2:21 pm

I pulled all the cards except for the local FC and ethernet card. and giving it another try.

I still have voltage errors though so I am not out of the power supply problem woods.

001i14 ATTN: 3.3V high warning limit reached 3.698V.

Posts: 20
Joined: Thu Aug 17, 2017 2:25 pm

Re: Origin 3200 Not Booting

Unread postby r1200gsDave » Wed Sep 27, 2017 9:00 am

I have the 3200 booted up but now I am struggling with miniroot to get to repair the system.

I have tried to boot off of a OpenBSD disk, 2 different Install Overlay disks and no luck. I get to the system menu and try to boot the installer or recovery programs. Each complain about the miniroot missing the file unix. I have tried all of the options to fix miniroot none of which work.

The OpenBSD disk does not like the format of the executable.

I can take a look at the disk with sash and see the password file and have even tried takign a look at the disks with fx.

I am thinking that the disks that I am trying to boot off of are not the right ones. The latest I have is the 6.5.6 from Nov 1999.

Any thoughts would be appreciated.

The system does boot up and I can see hints of who owned this machine and am currently trying to crack the root password with JtR.

Fun fun....

User avatar
Posts: 5021
Joined: Thu Jun 17, 2004 11:35 am
Location: Wijchen, The Netherlands

Re: Origin 3200 Not Booting

Unread postby jan-jaap » Wed Sep 27, 2017 10:44 am

You need at least 6.5.9.

Newer overlays can be downloaded from archive.org these days.
:PI: :Indigo: :Indigo: :Indy: :Indy: :Indy: :Indigo2: :Indigo2: :Indigo2IMP: :Octane: :Octane2: :O2: :O2+: Image :Fuel: :Tezro: :4D70G: :Skywriter: :PWRSeries: :Crimson: :ChallengeL: :Onyx: :O200: :Onyx2: :O3x02L:
To accentuate the special identity of the IRIS 4D/70, Silicon Graphics' designers selected a new color palette. The machine's coating blends dark grey, raspberry and beige colors into a pleasing harmony. (IRIS 4D/70 Superworkstation Technical Report)

Posts: 20
Joined: Thu Aug 17, 2017 2:25 pm

Re: Origin 3200 Not Booting

Unread postby r1200gsDave » Sun Oct 01, 2017 8:51 am

I have the Origin 3200 running very well now! Pretty fun to figure out.

Thanks for all of the help along the way!

Return to “SGI: Hardware”

Who is online

Users browsing this forum: Google [Bot] and 2 guests