Finally got my onyx2 running

SGI hardware problems, solutions, tips, hacks, etc.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
opcode
Posts: 155
Joined: Fri Oct 27, 2006 10:35 am
Contact:

Finally got my onyx2 running

Unread postby opcode » Sun Sep 10, 2017 9:21 am

I finally got my onyx2 up and running this weekend with a fresh 6.5.30 install. I thought I would post because it was kind of a pain figuring out the net install. I was lucky that I had a bootable disk from the previous owner. I could not figure out how to pull the "MAC" address for the ethers file. From what I understand, the system has a "NIC" and isn't like a normal system. I finally used lmhostid and added the first portion of the sgi Ethernet addresses of 0800. Everything worked using that. I was lucky to have a wyse terminal so I could get in because the console was set to d in the prom env. I wasn't getting the graphics start menu during boot to enter the graphics prom. I set it to console g1.

I was kind of shocked that the display settings didn't have a 1280x1024@76hz. I am running reality graphics with a dg-2. I wanted to ask if it supports that before trying to make my own settings file.

One more question. How would you find the hardware network address if you only had asscess to the prom console?

I'm still getting everything setup so I'd like to post some photos soon.
:PrismDT: :Tezro: :Onyx2: :Indigo: :Indigo: :Indigo: :Indigo: :Indigo: :Indigo: :Indy: :Indy: :Indy: :Indy: :Indy: :Indy: :O2: :O2: :O2: :O2: :O2: :1600SW: :1600SW: :320: :Indigo2IMP: :Indigo2: :Octane2: :Octane2: :Octane: :Fuel: :Fuel:
Stolen! :4D310: :Crimson:

User avatar
uunix
Donor
Donor
Posts: 1808
Joined: Sun Mar 27, 2011 12:48 pm
Location: Stourbridge / England / UK

Re: Finally got my onyx2 running

Unread postby uunix » Sun Sep 10, 2017 9:30 am

printenv. which will show you the eaddr
-----------------------------------------------------------------------
Hey Ho! Pip & Dandy!
:Octane2: :O2: :Indigo: :Indy:
-----------------------------------------------------------------------

User avatar
opcode
Posts: 155
Joined: Fri Oct 27, 2006 10:35 am
Contact:

Re: Finally got my onyx2 running

Unread postby opcode » Sun Sep 10, 2017 9:48 am

Of course I tried printenv. The eaddr wasn't listed. Even after I reset the env, it still wasn't listed.
:PrismDT: :Tezro: :Onyx2: :Indigo: :Indigo: :Indigo: :Indigo: :Indigo: :Indigo: :Indy: :Indy: :Indy: :Indy: :Indy: :Indy: :O2: :O2: :O2: :O2: :O2: :1600SW: :1600SW: :320: :Indigo2IMP: :Indigo2: :Octane2: :Octane2: :Octane: :Fuel: :Fuel:
Stolen! :4D310: :Crimson:

User avatar
Irinikus
Posts: 323
Joined: Wed Apr 27, 2016 4:25 am
Location: Cape Town, South Africa

Re: Finally got my onyx2 running

Unread postby Irinikus » Sun Sep 10, 2017 9:56 am

Maybe this link might help:

http://nixdoc.net/man-pages/IRIX/hinv.1.html

"hinv -c network"
Image................. Image Image Image Image Image Image Image Image; Image...... Image Image Image Image Image Image Image Image;
Image Image; Image........... Image; Image... ImageImage Image.... Here they are: :arrow:

User avatar
opcode
Posts: 155
Joined: Fri Oct 27, 2006 10:35 am
Contact:

Re: Finally got my onyx2 running

Unread postby opcode » Wed Sep 13, 2017 9:36 am

I tried that. My power has been off for three days because of the hurricane. I'll run it again when I can boot it.
:PrismDT: :Tezro: :Onyx2: :Indigo: :Indigo: :Indigo: :Indigo: :Indigo: :Indigo: :Indy: :Indy: :Indy: :Indy: :Indy: :Indy: :O2: :O2: :O2: :O2: :O2: :1600SW: :1600SW: :320: :Indigo2IMP: :Indigo2: :Octane2: :Octane2: :Octane: :Fuel: :Fuel:
Stolen! :4D310: :Crimson:


Return to “SGI: Hardware”

Who is online

Users browsing this forum: No registered users and 1 guest