Page 1 of 1

SGI Octane: IRIX always outputs to serial terminal

Posted: Sun Jul 09, 2017 2:05 pm
by swarm
Hi everyone!

I have a strange error which is probably caused by a software configuration from a previous owner. I have SGI Octane2 with two hard drives. Each contains its own IRIX 6.5 installation but both should be configured for this machine. Both OS installations behave the same way:

Octane2 can output to either 13W3 monitor or serial console according to what is set in PROM (console d/g). However, no matter what is set or if the serial terminal is connected, IRIX always outputs all messages to serial terminal. Picture on the local screen hangs (mouse pointer is not updated) after the first OS message was displayed on the serial terminal.

Mouse and keyboard work fine in PROM monitor. I tried to boot using the command "single", but with the same result. See attached screenshots.

Thanks,

J

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Sun Jul 09, 2017 10:12 pm
by pierocks
Your graphics board is conspicuously absent from your hinv. Try re-seating the board.

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Sun Jul 09, 2017 10:18 pm
by swarm
I've tried a different video board from another Octane (the same type). It is still not visible in IRIX, however if I use hinv in PROM, it shows me "ODYSSEY" graphics.

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Sun Jul 09, 2017 11:38 pm
by miod
I wouldn't be surprised if your kernels lack support for V6/V8. Do you have an impact board to try?

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Mon Jul 10, 2017 1:47 am
by swarm
Unfortunately I have no Impact board for Octane.

I will find IRIX updates, configure network using the serial terminal and then install necessary updates. I'm surprised that somebody used it without drivers for the video board but this is worth a try.

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Mon Jul 10, 2017 10:21 am
by pierocks
If the previous owner installed Irix on that machine and the graphics board was not showing up due to a poor connection to the frontplane or a dead graphics board, I don't believe the installer would include the graphics subsystem. Could explain why Irix is lacking the required drivers. Somebody correct me if I'm wrong, though...

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Tue Jul 11, 2017 9:45 am
by swarm
I've checked /usr/gfx and it looks like there are drivers only for MGRAS and not ODYSSEY.

So I need to install correct drivers. I will try to install 6.5.22 app and overlay CDs . They should contain the driver as it was not a part of original IRIX 6.5.

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Sat Jul 15, 2017 3:40 pm
by swarm
So the result is that I didn't find a way to get the graphics board working. I've installed 6.5.22 including drivers on overlay CDs but there is no driver for vPro. I've searched on the Internet and found that there are somewhere patches 4103 and 4104 which contain the driver.

Unfortunately google cannot find them and SGI support page doesn't work anymore. I have no idea what to do now...

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Sat Jul 15, 2017 4:05 pm
by dexter1
What IRIX version are you running on that Octane? Do a 'uname -aR'

What is troubling is that the hinv still doesn't show your gfx card in IRIX. I'm not sure if this is caused by the current kernel in /unix preventing hinv to detect your odyssey card.

If you can list the contents of the root file system, can you see a file called /unix.install ?
If it is not there, try to perform '/etc/autoconfig -vf' as root to reconfigure your kernel to use the current gfx and perform a reboot after that.
Let us know how that goes.

If that fails, a reinstall of IRIX is probably in order.

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Sun Jul 16, 2017 8:53 am
by swarm
dexter1: I was followed your last advice and installed a new system of a clean HDD (the old installation was already corrupted).

I've installed in using serial terminal just to have more convenient environment with prepared paths for all files. IRIX now outputs all boot messages to the local screen but doesn't ask me for login. I can log in only using a terminal connected to Serial Port 1 (which I used for installation). The local screen still shows all system messages and I can start X server from my serial terminal (just with shell windows, not with the standard desktop environment).

Kernel: IRIX64 IRIS 6.5 6.5.22f 10070055 IP30
NVRAM:
ConsoleIn=keyboard()
ConsoleOut=video()
gfx=alive
console=g

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Sun Jul 16, 2017 9:12 am
by swarm
Ok, solved. I just had to replace empty* /usr/lib/X11/xdm/Xservers with /usr/lib/X11/xdm/Xservers.N.

*) Probably caused by initial installation of 6.5.5 -> adding inst patch -> 6.5.22 (I was not able to start directly with 6.5.22 when installed over network... not sure where was the problem).

Re: SGI Octane: IRIX always outputs to serial terminal

Posted: Mon Jul 17, 2017 2:14 am
by dexter1
swarm wrote:Ok, solved. I just had to replace empty* /usr/lib/X11/xdm/Xservers with /usr/lib/X11/xdm/Xservers.N.

*) Probably caused by initial installation of 6.5.5 -> adding inst patch -> 6.5.22 (I was not able to start directly with 6.5.22 when installed over network... not sure where was the problem).

If you started with installing 6.5.5 first that might explain why your gfx and thus the /usr/lib/X11/xdm/Xservers was missing completely. Support for Odyssey (VPro)cards appeared only later in 6.5.10 and 6.5.11.

Code: Select all

install hardware
in inst should solve these problems, but you probably need to reinstall X and Desktop eoe packages.

Congratulations in getting it to work, BTW :)