Messed up my VBOB - trying to recover

SGI hardware problems, solutions, tips, hacks, etc.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
tweakoz
Posts: 11
Joined: Thu Aug 11, 2011 3:07 am

Messed up my VBOB - trying to recover

Unread postby tweakoz » Fri Jun 16, 2017 12:34 am

I was a little too brave one day, not satisfied with my vbob experience to date, and decided to flash the firmware.
(by running /usr/dmedia/bin/vbob/vbob_update1 and vbob_update2)

Oops :?

It was on 1.3.22
Now It is on 1.3.8

I no longer get the color bars , and confidence tests no longer pass....
the flash commands no longer work.

Code: Select all

-bash-4.2$ sudo ./vbob_update1
Password:
************* vbob_update1 *****************************
* updating non-active firmware version
* Note, one of the following vbob_flash cmds might fail.
********************************************************

vbob_flash: Doing a killall on any dmdaemon or mldaemon.
process <dmdaemon> not found
process <mldaemon> not found
[libvboblvds] I/O ERROR: VBOB possibly disconnected!
vbob_flash: Internal Error! vbobReadData failed.
vbob_flash: Checking for vbob on pipe 0 (:0.0)
vbob_flash: Vbob not found on :0.0
vbob_flash: ERROR: No VBOBs found.
Connect VBOB to the system and re-run /usr/dmedia/bin/vbob/vbob_flash to update the VBOB firmware
vbob_flash: Doing a killall on any dmdaemon or mldaemon.
process <dmdaemon> not found
process <mldaemon> not found
[libvboblvds] I/O ERROR: VBOB possibly disconnected!
vbob_flash: Internal Error! vbobReadData failed.
vbob_flash: Checking for vbob on pipe 0 (:0.0)
vbob_flash: Vbob not found on :0.0
vbob_flash: ERROR: No VBOBs found.
Connect VBOB to the system and re-run /usr/dmedia/bin/vbob/vbob_flash to update the VBOB firmware
********************************************************
vbob_flash: Doing a killall on any dmdaemon or mldaemon.
process <dmdaemon> not found
process <mldaemon> not found
[libvboblvds] I/O ERROR: VBOB possibly disconnected!
vbob_flash: Internal Error! vbobReadData failed.
vbob_flash: Checking for vbob on pipe 0 (:0.0)
vbob_flash: Vbob not found on :0.0
vbob_flash: ERROR: No VBOBs found.
Connect VBOB to the system and re-run /usr/dmedia/bin/vbob/vbob_flash to update the VBOB firmware

------------------------------
Error:
vbob_flash failed.
check vbob cables and power.
aborting...
------------------------------




luckily, at least I can still cu in from the serial port.
:x

the following snippet looks a bit promising (If only I knew what bsend was, and what type of file it expects, and which part of the flash it would update).

Code: Select all

vbob> u
FLASH IMAGE UPDATE
Disconnect the terminal program and run 'bsend'
to send the new flash image.......

After 'bsend' completes, reconnect with the terminal
and hit <ENTER> to see the final status of the update.


I have also taken some notes on which DM3 FPGA's do what and can probably deduce which FPGAs
are which on the board based on proximity and connections to other components. I might be able to
do the same for the FPGA's in the vbob. and correlating xilinx bitstream sizes for different fpga types
might also help ID which bitstream goes to which FPGA.

The mcs files in the vbob ucode folder should be loadable via xilinx impact software,
which I actually have (along with a jtag adapter). and it looks like there is a jtag port on the VBOB motherboard.

Not sure if I feel brave enough yet to attempt it.
Anyone have any other ideas ?

Thanks,

mtm
Attachments
vbobnotes.txt
(9.27 KiB) Downloaded 8 times

Return to “SGI: Hardware”

Who is online

Users browsing this forum: No registered users and 1 guest