Indigo 2 and Galileo

SGI hardware problems, solutions, tips, hacks, etc.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
leaknoil
Posts: 426
Joined: Fri Aug 29, 2008 3:29 pm
Location: San Francisco, California

Indigo 2 and Galileo

Unread postby leaknoil » Mon Apr 20, 2009 10:36 am

I have a Indigo 2 with 6.5.6 on it. It has the Extreme graphics which show up as GU1-Extreme in hinv. I had a Galileo sitting around from another lot of gear I decided to put in there. It looks like it installed fine but, hinv isn't reporting it. This mean its dead or are there drivers or applications I need to install first ?

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8145
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Re: Indigo 2 and Galileo

Unread postby nekonoko » Mon Apr 20, 2009 10:50 am

Yes, you need to install the Galileo base driver and the 6.5.6 upgrade overlay (from the /unbundled directory on your overlay distribution CDs). The base driver can be found on Nekochan FTP:

ftp://ftp.nekochan.net/pub/irix/Drivers/IRIX_6.5
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

leaknoil
Posts: 426
Joined: Fri Aug 29, 2008 3:29 pm
Location: San Francisco, California

Re: Indigo 2 and Galileo

Unread postby leaknoil » Mon Apr 20, 2009 10:57 am

Awesome. Thanks.

User avatar
silicium
Posts: 174
Joined: Thu Oct 04, 2007 2:27 am
Location: Périgord, France

how to get Indycam working on Indigo2 + I2V ?

Unread postby silicium » Fri Apr 22, 2011 4:25 pm

After installing 6.5.15 on my I2, I installed galileo base driver + 6.5.14/cd3/dist/unbundled for the I2V + indycam, ran vcp after reboot, but couldn't find the indycam or select it as video input. If it is digital, I should be able to select digital input in vcp despite the lack of Galileo board, but only analog is available. Are there any diag program to probe for the indycam ? Nothing said about it in the outputs of 'gfxinfo' and 'vlinfo'. Can anyone with a successful indycam on I2 post details of installed software and config files ? Or is it a just bad connection ? I noticed the indycam connector does not fit well because it touches the I2 top skin as the I2V board has to be in the top slot (extreme gfx 3-board set taking all the space from the bottom up).
:Indigo2IMP:extreme :Octane2:V8 :O200: :Onyx2:IR2e

User avatar
recondas
Moderator
Moderator
Posts: 5440
Joined: Sun Jun 06, 2004 5:55 pm
Location: NC - USA

Re: how to get Indycam working on Indigo2 + I2V ?

Unread postby recondas » Sat Apr 23, 2011 4:50 am

silicium wrote:After installing 6.5.15 on my I2, I installed galileo base driver + 6.5.14/cd3/dist/unbundled for the I2V + indycam,
If those weren't an accidental typo they might be the source of your problem.
***********************************************************************
Welcome to ARMLand - 0/0x0d00
running...(sherwood-root 0607201829)
* InfiniteReality/Reality Software, IRIX 6.5 Release *
***********************************************************************

User avatar
silicium
Posts: 174
Joined: Thu Oct 04, 2007 2:27 am
Location: Périgord, France

how to diag Indycam on I2V ?

Unread postby silicium » Sun Apr 24, 2011 4:42 am

Quite a typo. Confusion came from an 'Applications' directory found with the 6.5.14 media, but not with 6.5.15. Galileo drivers are the same version (or inst would have complained about conflicts, and I did not override any).
After a new install of 6.5.15m an Indycam appears on the desktop but there is the same problem. Video input window only displays some garbage vertical stripes from graphics, with any input setting in video control panel. chkconfig videod is on. What else should be checked ?
hinv: http://forums.nekochan.net/viewtopic.php?f=14&t=16725147
:Indigo2IMP:extreme :Octane2:V8 :O200: :Onyx2:IR2e

User avatar
recondas
Moderator
Moderator
Posts: 5440
Joined: Sun Jun 06, 2004 5:55 pm
Location: NC - USA

Re: Indigo 2 and Galileo

Unread postby recondas » Sun Apr 24, 2011 6:25 am

I might have been fortunate to have completely missed it, but there have been a number of comments here that suggest that the IRIX 6.5.15 release had problems (or caused some).

The last time I looked, IRIX 6.5.22 was still available for download for those with a free Supportfolio account. 6.5.22 is the most recent IRIX revision an I2 is able to run, and would eliminate 6.5.15 as a potential source of problems (not to mention the unfortunate need to mix the 6.5.15 and 6,5,14 streams to complete an install).

If you do elect to try IRIX 6.5.22, be sure to grab patch 5086 while you're in Supportfolio - it's required to perform a live upgrade from any IRIX revision earlier than 6.5.21 to 6.5.21 or higher).
***********************************************************************
Welcome to ARMLand - 0/0x0d00
running...(sherwood-root 0607201829)
* InfiniteReality/Reality Software, IRIX 6.5 Release *
***********************************************************************

User avatar
silicium
Posts: 174
Joined: Thu Oct 04, 2007 2:27 am
Location: Périgord, France

Re: Indycam + I2V not working

Unread postby silicium » Sun Apr 24, 2011 11:39 am

Updating to 6.5.22 did not help - could only update the overlays since Supportfolio does not give applications CD's, and was undable to download those elsewhere - I'm stuck with 6.5.14 apps. Also have downloaded .27 and .30 apps CD's, but are they supported on a lower revision system ?
Last edited by silicium on Sun Apr 24, 2011 2:12 pm, edited 1 time in total.
:Indigo2IMP:extreme :Octane2:V8 :O200: :Onyx2:IR2e

User avatar
recondas
Moderator
Moderator
Posts: 5440
Joined: Sun Jun 06, 2004 5:55 pm
Location: NC - USA

Re: Indycam + I2V not working

Unread postby recondas » Sun Apr 24, 2011 1:04 pm

silicium wrote:Updating to 6.5.22 did not help - could only update the overlays since Supportfolio does not give applications CD's
Yes - the publicly available downloads provided at Supportfolio (now reduced to only 6.5.22m) were limited to maintenance releases. Maintenance in this case meaning no new features or applications, but you shouldn't have any less than you started with. SGI would only provide feature releases to those with paid support contracts.

That shouldn't prevent you from updating to IRIX 6.5.22m - but be sure to include the unbundled directory (for your I2 video driver), and patch 5086 if you install the .22 overlays from within IRIX.

silicium wrote:Also have .27 and .30 apps CD's, but are they supported on a lower revision system ?
Sounds like a headache in the making. Support for the I2 was removed from IRIX after 6.5.22, and there is almost certainly linkage between the applications and post 22 libraries.
***********************************************************************
Welcome to ARMLand - 0/0x0d00
running...(sherwood-root 0607201829)
* InfiniteReality/Reality Software, IRIX 6.5 Release *
***********************************************************************

User avatar
silicium
Posts: 174
Joined: Thu Oct 04, 2007 2:27 am
Location: Périgord, France

Re: Indycam + I2V not working

Unread postby silicium » Sun Apr 24, 2011 2:31 pm

recondas wrote:Sounds like a headache in the making. Support for the I2 was removed from IRIX after 6.5.22, and there is almost certainly linkage between the applications and post 22 libraries.

Thanks for preventing me from doing stupid things.
According to other hinv posts with resp. Extreme/GR2/Impact gfx, it tells when the Indycam is connected.
http://hardware.majix.org/computers/sgi.indigo2/teal.shtml
http://forums.nekochan.net/viewtopic.php?f=14&t=2151&p=15598
http://forums.nekochan.net/viewtopic.php?f=14&t=2058&p=15056
EDIT: found a ding on an oscillator case on the I2V board. With such a proof of rough handling, the board is more likely to be faulty than the Indycam.
:Indigo2IMP:extreme :Octane2:V8 :O200: :Onyx2:IR2e

User avatar
silicium
Posts: 174
Joined: Thu Oct 04, 2007 2:27 am
Location: Périgord, France

Re: Indycam + I2V not working

Unread postby silicium » Sat Jun 11, 2011 2:21 pm

silicium wrote:found a ding on an oscillator case on the I2V board.

Update: testing its output with an oscilloscope is OK but the board is still not working with Indycam (not detected, no digital input in the drop-down menu of vcp) nor composite input (got only a black windows once before system froze, then videoin displays screen garbage after reset).
Too disappointed to consider video I/O on I2 again after buying another Galileo board from same eBay seller, but received a board full of scratches :cry: (PM for seller details if you don't want to buy e-waste sold as working :evil:, but not worth returning for refund since shipping is not refundable).
:Indigo2IMP:extreme :Octane2:V8 :O200: :Onyx2:IR2e

User avatar
silicium
Posts: 174
Joined: Thu Oct 04, 2007 2:27 am
Location: Périgord, France

Re: Indigo 2 and Galileo

Unread postby silicium » Thu Feb 23, 2017 11:50 am

Indycam now working thanks Galileo Jr thread and replacement of missing oscillators.
But the video is very dim even when putting all settings to the maximum value.
Since the link seems to be digital, could it be an effect of component aging in or around the sensor ?
I remember it was also not very bright on the Indy I had in the late 90's, and could get correct colors and contrast only under direct sunlight in summer (not the same Indycam).
:Indigo2IMP:extreme :Octane2:V8 :O200: :Onyx2:IR2e

robespierre
Posts: 1551
Joined: Mon Sep 12, 2011 2:28 pm
Location: Boston

Re: Indigo 2 and Galileo

Unread postby robespierre » Thu Feb 23, 2017 12:43 pm

The IndyCam was not known for its image quality, but it is also possible that the sensor is dusty.
:PI: :O2: :Indigo2IMP: :Indigo2IMP:


Return to “SGI: Hardware”

Who is online

Users browsing this forum: No registered users and 1 guest