Nekochan Net

Official Chat Channel: #nekochan // irc.nekochan.net
It is currently Wed Nov 26, 2014 4:02 pm

All times are UTC - 8 hours [ DST ]


Forum rules


Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.



Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Octane2 with V8 and ESI
Unread postPosted: Sat Nov 18, 2006 1:41 pm 
Offline
User avatar

Joined: Mon Sep 12, 2005 8:32 pm
Posts: 352
Location: New York, USA
Hello all,

I didn't see much info on this while searching through the forums, so if this is a repeat I apologize in advance, but in case it isn't here we go....

I am running an Octane2 with both a V8 and an ESI board. I am told this is an unsupported configuration but it seems to work nicely!! It took a little bit to get it working, namely I only had OpenGL and thus MPlayer, Quake3, etc on the ESI driven monitor (worked intermittently and not much fun). So....I got it to switch over to the V8 by re-symlinking libGL.so and libGLcore.so in:

/var/arch/lib
/var/arch/lib32
/var/arch/lib64

To the ones present in:

/usr/gfx/arch/IP30ODSY
/usr/gfx/arch/IP30ODSY32
/usr/gfx/arch/IP30ODSY64

respectively. After that I didn't even need a reboot and everything just worked. It would seem that the only drawback is that I can't have OpenGL on both screens, but that's fine with me, I'm using the other one for gaim, firefox, etc. You CAN also run at different refresh rates across the two monitors too, so don't worry about that.

To get it running from scratch install the XiO card load IRIX from or boot into the miniroot and do:

keep *
install fresh

This will add the additional drivers you need for the extra card. After it reboots do the fix described above and if your machine works as well as mine did you should be all set! Additionally, you can do:

chkconfig -f xinerama on

to enable xinerama (desktop spanned across both monitors) which also seems to work great.

Let me know if this works for anyone else.

Here's the info on my machine:
Code:
# uname -R
6.5 6.5.30f

# hinv -mv
Location: /hw/node
      PM10600MHZ Board: barcode MCY566     part 030-1774-002 rev  A
Location: /hw/node/xtalk/15
            IP30 Board: barcode JPE588     part 030-1467-001 rev  C
Location: /hw/node/xtalk/15/pci/2
             FP1 Board: barcode LZF537     part 030-0891-003 rev  H
    PWR.SPPLY.ER Board: barcode AAE1020875 part 060-0035-002 rev  A
Location: /hw/node/xtalk/11
          ODY128 Board: barcode KWM926     part 030-1404-003 rev  A
Location: /hw/node/xtalk/9
           MOT10 Board: barcode JHV680     part 030-1241-002 rev  H
1 600 MHZ IP30 Processor
Heart ASIC: Revision F
CPU: MIPS R14000 Processor Chip Revision: 2.4
FPU: MIPS R14010 Floating Point Chip Revision: 0.0
Main memory size: 2048 Mbytes
Xbow ASIC: Revision 1.4
Instruction cache size: 32 Kbytes
Data cache size: 32 Kbytes
Secondary unified instruction/data cache size: 2 Mbytes
Integral SCSI controller 0: Version QL1040B (rev. 2), single ended
  Disk drive: unit 1 on SCSI controller 0 (unit 1)
Integral SCSI controller 1: Version QL1040B (rev. 2), single ended
  CDROM: unit 2 on SCSI controller 1
IOC3/IOC4 serial port: tty1
IOC3/IOC4 serial port: tty2
IOC3 parallel port: plp1
Graphics board: V8
Graphics board: ESI
Integral Fast Ethernet: ef0, version 1, pci 2
Iris Audio Processor: version RAD revision 12.0, number 1
  PCI Adapter ID (vendor 0x10a9, device 0x0003) PCI slot 2
  PCI Adapter ID (vendor 0x1077, device 0x1020) PCI slot 0
  PCI Adapter ID (vendor 0x1077, device 0x1020) PCI slot 1
  PCI Adapter ID (vendor 0x10a9, device 0x0005) PCI slot 3


Code:
# /usr/gfx/gfxinfo
Graphics board 0 is "ODYSSEY" graphics.
        Managed (":0.0") 1280x1024
        BUZZ version A.1
        PB&J version 1
        128MB memory
                Banks: 4, CAS latency: 3
         Monitor 0 type: Unknown
        Channel 0:
         Origin = (0,0)
         Video Output: 1280 pixels, 1024 lines, 100.00Hz (1280x1024_100s)
Graphics board 1 is "IMPACTSR" graphics.
        Managed (":0.1") 1280x1024
        Product ID 0x2, 1 GE, 1 RE, 0 TRAMs
        MGRAS revision 4, RA revision 0
        HQ rev B, GE12 rev A, RE4 rev C, PP1 rev H,
        VC3 rev A, CMAP rev F, Heart rev F
        unknown, assuming 19" monitor (id 0xf)

        Channel 0:
         Origin = (0,0)
         Video Output: 1280 pixels, 1024 lines, 75.92Hz (1280x1024_76_32db)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group