Two questions, one quick and one less so

IBM workstations/servers/mainframes and operating systems (AIX, OS/2, etc.)
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
thunderbird32
Posts: 53
Joined: Thu Sep 20, 2012 7:33 pm
Location: Joliet, United States
Contact:

Two questions, one quick and one less so

Unread postby thunderbird32 » Tue Dec 19, 2017 12:30 pm

Question #1:
I have AIX 4.3.3 installed on my 7011-250 (w/ SCSI2SD and 256MB RAM), and it is really glacial. Is the very slow speed because of the SCSI2SD adapter, or is the 7011 just that slow with 4.3.3? If it's the former, do you think it would be wise to buy one of the new, faster SCSI2SD adapters, or would the speed increase not be that major?

Question #2:
I'm attempting to install AIX 5.3 on my new 7044-170 and I'm having a bit of trouble. AIX 4.3.3 works perfectly fine, and installs just fine. With 5.3, the system just stops at the code "0c45". This code apparently has to do with configuring the console. I'm running a GXT300P video card, if that makes any difference. I've yet to try over serial, but I'd rather install over the local terminal if at all possible. I have updated the firmware to the most recent from IBM's website, as I am aware that 5.3 needs the newer versions, but that hasn't seemed to help.
Digital Personal Workstation 500au
HP Visualize C3700 (HP-UX 11.11)
IBM RS/6000 7011-250 (AIX 4.3.3) | IBM RS/6000 7044-170 (AIX 5.3)
Sun SPARCclassic (SunOS 4.1.4) | Sun Ultra 1 (Solaris 2.6)

User avatar
ClassicHasClass
Donor
Donor
Posts: 2131
Joined: Wed Jul 25, 2012 7:12 pm
Location: Sunny So Cal
Contact:

Re: Two questions, one quick and one less so

Unread postby ClassicHasClass » Tue Dec 19, 2017 4:55 pm

The 7011-250, IIRC, is a 66MHz 601. That's not going to be very fast running *any* version of AIX 4. I've never had a SCSI2SD run slower than spinning rust, so I doubt it's the cause.

For the other problem, you might be able to make the service processor reset what it thinks the console is. See this thread: viewtopic.php?t=17262
smit happens.

:Fuel: bigred, 900MHz R16K, 4GB RAM, V12 DCD, 6.5.30
:Indy: indy, 150MHz R4400SC, 256MB RAM, XL24, 6.5.10
:Indigo2IMP: purplehaze, 175MHz R10000, Solid IMPACT
probably posted from Image bruce, Quad 2.5GHz PowerPC 970MP, 16GB RAM, Mac OS X 10.4.11
plus IBM POWER6 p520 * Apple Network Server 500 * RDI PrecisionBook * BeBox * Solbourne S3000 * Commodore 128 * many more...

User avatar
thunderbird32
Posts: 53
Joined: Thu Sep 20, 2012 7:33 pm
Location: Joliet, United States
Contact:

Re: Two questions, one quick and one less so

Unread postby thunderbird32 » Tue Dec 19, 2017 7:38 pm

Yeah, I've considered going with an older version of AIX for my 7011 (it looks like it originally came with 4.1.4 or 3.2.5), but I'm worried about hardware compatibility. I have an Ultimedia sound card and a 10/100 Ethernet card in the machine, and it's my understanding that Ultimedia support wasn't available in the base OS until 4.1 and support for the 9-K Ethernet card came even later than that.

As far as my project to install 5.3 goes, I seem to have fixed that issue. It turns out that the CD-ROM drive needed updated microcode. I was aware that CD-ROM drives have firmware on them, but I've never heard of one needing an update to install an Operating System. Talk about picky software, yikes! Luckily IBM is pretty good about still having that kind of stuff online.
Digital Personal Workstation 500au
HP Visualize C3700 (HP-UX 11.11)
IBM RS/6000 7011-250 (AIX 4.3.3) | IBM RS/6000 7044-170 (AIX 5.3)
Sun SPARCclassic (SunOS 4.1.4) | Sun Ultra 1 (Solaris 2.6)

User avatar
ClassicHasClass
Donor
Donor
Posts: 2131
Joined: Wed Jul 25, 2012 7:12 pm
Location: Sunny So Cal
Contact:

Re: Two questions, one quick and one less so

Unread postby ClassicHasClass » Tue Dec 19, 2017 11:38 pm

In that case, yeah, you're stuck. I would have recommended 3.2.5 on that hardware generally were it not for your hardware requirements.
smit happens.

:Fuel: bigred, 900MHz R16K, 4GB RAM, V12 DCD, 6.5.30
:Indy: indy, 150MHz R4400SC, 256MB RAM, XL24, 6.5.10
:Indigo2IMP: purplehaze, 175MHz R10000, Solid IMPACT
probably posted from Image bruce, Quad 2.5GHz PowerPC 970MP, 16GB RAM, Mac OS X 10.4.11
plus IBM POWER6 p520 * Apple Network Server 500 * RDI PrecisionBook * BeBox * Solbourne S3000 * Commodore 128 * many more...

User avatar
vishnu
Donor
Donor
Posts: 3238
Joined: Sun Mar 18, 2007 3:25 pm
Location: Minneapolis, Minnesota USA

Re: Two questions, one quick and one less so

Unread postby vishnu » Wed Dec 20, 2017 5:23 pm

This is probably crazy but wouldn't it be possible to use AIX kernel extensions to drive that hardware from a 3-point-something version? For example:

https://www.ibm.com/developerworks/aix/library/au-aix-device-driver/index.html

If there were already open source drivers for that hardware (I have no idea if there are), obviously it would become a much simpler proposition...
Project:
Temporarily lost at sea...
Plan:
World domination! Or something...

:Tezro: :Octane2:

User avatar
ClassicHasClass
Donor
Donor
Posts: 2131
Joined: Wed Jul 25, 2012 7:12 pm
Location: Sunny So Cal
Contact:

Re: Two questions, one quick and one less so

Unread postby ClassicHasClass » Thu Dec 21, 2017 7:14 am

I'm not aware that there are any open-source drivers for Ultimedia, even if the other hurdles were cleared.
smit happens.

:Fuel: bigred, 900MHz R16K, 4GB RAM, V12 DCD, 6.5.30
:Indy: indy, 150MHz R4400SC, 256MB RAM, XL24, 6.5.10
:Indigo2IMP: purplehaze, 175MHz R10000, Solid IMPACT
probably posted from Image bruce, Quad 2.5GHz PowerPC 970MP, 16GB RAM, Mac OS X 10.4.11
plus IBM POWER6 p520 * Apple Network Server 500 * RDI PrecisionBook * BeBox * Solbourne S3000 * Commodore 128 * many more...

User avatar
thunderbird32
Posts: 53
Joined: Thu Sep 20, 2012 7:33 pm
Location: Joliet, United States
Contact:

Re: Two questions, one quick and one less so

Unread postby thunderbird32 » Thu Dec 21, 2017 8:29 am

I know there was a desire to get an open source driver going. MCA soundcards are pretty thin on the ground, and I believe the hobbyists wanted a driver so they could use them in PS/2s (presumably in DOS or Win 3.x). As is, I think there's only drivers for AIX and NT, and then only the official IBM ones.

Maybe one day I'll get a faster MCA RS/6000. Perhaps I'll get a 7009-C20 or something.
Digital Personal Workstation 500au
HP Visualize C3700 (HP-UX 11.11)
IBM RS/6000 7011-250 (AIX 4.3.3) | IBM RS/6000 7044-170 (AIX 5.3)
Sun SPARCclassic (SunOS 4.1.4) | Sun Ultra 1 (Solaris 2.6)

kev009
Posts: 107
Joined: Wed Nov 12, 2008 8:02 pm
Location: Tempe, Arizona
Contact:

Re: Two questions, one quick and one less so

Unread postby kev009 » Sun Dec 24, 2017 2:31 am

I would check the scsi2sd vs any reasonable SCSI disk, those are painfully slow. Use something simple like lmbench http://www.bitmover.com/lmbench/lat_fs.8.html. I put a 4-C enhanced corvette into my 250 and ran a wide scsi cable to a wide drive. It's not as speedy as the POWER boxes, but it seems usable to me under 4.3.3.
SGI Fuel, Indy R5k
IBM RS/6000 7006-42T, 7011-250, 7012-397, 7012-G40 (upgraded to 4x 200MHz PPC), ThinkPad 710TE vintage tablet, ThinkPad T400, various System X, NetVista 2800
Sun Ultra 27 Xeon Quad Core 3.20GHz, Sunblade 2500 Silver, SunFire V445
HP c8000

http://ps-2.kev009.com:8081/ - IBM Retro
http://www.kev009.com/ - Blog
Free Usenet access for comp.* heirarchy. Send me a message for posting access.

User avatar
thunderbird32
Posts: 53
Joined: Thu Sep 20, 2012 7:33 pm
Location: Joliet, United States
Contact:

Re: Two questions, one quick and one less so

Unread postby thunderbird32 » Wed Dec 27, 2017 2:44 pm

I suppose I could do that, but I'd have to drop either the Ethernet card or sound card. I wish the 7011 had three MCA slots instead of two. Would make things much easier. I do have the original drive that came with the machine (1GB narrow SCSI). AIX 4.3.3 is a bit big for a 1GB drive, though.
Digital Personal Workstation 500au
HP Visualize C3700 (HP-UX 11.11)
IBM RS/6000 7011-250 (AIX 4.3.3) | IBM RS/6000 7044-170 (AIX 5.3)
Sun SPARCclassic (SunOS 4.1.4) | Sun Ultra 1 (Solaris 2.6)


Return to “IBM”

Who is online

Users browsing this forum: No registered users and 2 guests