Page 1 of 1

Installing SunOS 4.1.4

Posted: Thu May 25, 2017 2:36 pm
by thunderbird32
Does anyone have instructions (or a link to) for setting up a Solaris or Linux boot server for installing SunOS 4.1.4? From my internet searching, it should be possible. However, all the guides I find are for setting up a JumpStart server for pushing out Solaris. I have no external CD-ROM drives that want to play nice with my SPARCclassic (weirdly not even the IBM built one for my RS/6000, which I would have thought would work). I can get it to show up during a SCSI probe, but I just get the "Bad Magic number in disk label" error when trying to boot it.


Re: Installing SunOS 4.1.4

Posted: Thu May 25, 2017 4:53 pm
by ClassicHasClass
I'm not sure if it's the same, but on my Solbourne systems, I needed rarpd and tftpd, with TFTP having the install kernel image.

Re: Installing SunOS 4.1.4

Posted: Thu May 25, 2017 5:47 pm
by thunderbird32
Thanks for the help. Turns out my install media is actually f'd. I can't mount the CD on my Linux machine either, so it's likely bad. I guess I'll have to settle for Solaris.

Re: Installing SunOS 4.1.4

Posted: Fri May 26, 2017 10:59 am
by ClassicHasClass
Mount it? It's not an ISO 9660 file system, it's actually FFS (which SunOS calls "4.2"). What were you trying to mount it as?

Re: Installing SunOS 4.1.4

Posted: Fri May 26, 2017 11:16 am
by thunderbird32
Yeah, I realized that later. Learn something new every day, I guess.

I'll be honest, it was a burned CD from an ISO. At first I thought the drive just couldn't read the CD-R, but it turns out it doesn't support 512 byte block mode. I, incorrectly, assumed it would since I was under the impression that AIX required it, and it works fine on my RS/6000. It's possible that only the earlier versions did, or I'm entirely wrong. The drive is a Toshiba XM-3401BMA. Apparently, it can be modified to work (, but I don't want to have to hack it.

At this point, unless I'm mistaken, it looks like my options are:
1. Buy a Sun compatible CD-ROM
2. Do a network install
3. Modify my existing CD-ROM
4. Just install a newer version of Solaris that doesn't care about the block size (I think 2.6+)

If I do #1, is there any trouble I'll run into burning it (like I did mounting)? Alternatively, if I do #2, I'll have to find a way to mount it somehow so I can pull the required data off for the boot server.

Sorry, I'm kinda fumbling around with this. This has been a fun little project, but I'm a bit out of my depth.

Re: Installing SunOS 4.1.4

Posted: Fri May 26, 2017 8:49 pm
by ClassicHasClass
No, it shouldn't be a problem. OS/MP, which I use on my Solbournes, is a modified SunOS and it works fine with a burned disc. I think #1 is going to be the least amount of headache and if you're interested in old Unix workstations you'll need one sooner or later anyway. I use a Toshiba also, I forget the model.

Re: Installing SunOS 4.1.4

Posted: Fri May 26, 2017 11:24 pm
by astouffer
Those old Toshiba XM series drives can read CDR discs but not CDRW. The NetBSD diskless HOWTO explains the netboot process ... o.sun.html

Re: Installing SunOS 4.1.4

Posted: Thu Jun 01, 2017 9:04 pm
by thunderbird32
So, I got a Sun CD-ROM, and spent the night getting SunOS installed. It's not the most user-friendly operating system in the world, but that's to be expected due to its age.

I'm using a SCSI2SD card instead of a hard drive, and my first mistake was to set it to a 4GB "drive" size. As SunOS doesn't have a Type for a drive that size, I would have had to set it up by CHS, and I have no idea what I would put there. It's not a physical drive, so it doesn't have any true geometry, and I have no idea what geometry it's emulating. So I switched to a 2.1GB "drive" so I could select the built-in Type for a Sun 2.1GB drive. That way not only did I not have to futz with setting the geometry, I didn't have to fight the partitioner. I need to do some real research on how SunOS does drive partitions (slices?) as that's not a way I'm used to thinking about partitions. At least for future reference.

After getting that to behave, I had trouble getting it to install. I decided to have it do a full install (everything it could), and that turned out to be a bad idea as well. It eventually got to extracting a package (versatec), and it failed saying I needed to mount volume 1 (and that volume -1 was currently mounted!). Maybe I ran out of hard drive space, or maybe that package isn't actually on my install disk? In any case, I restarted and did a minimal install just to see if it would work. The install finished as expected, and after a reboot... it still didn't work.

Turns out the SPARCclassic is expecting the drive to be at a different SCSI ID than I thought. Normally SCSI boot disks need to be at ID 0, but it looks like it's expecting the drive to be at ID 3? After figuring that out, it seems I have a working system. Now all I have to do, is either figure out how to install packages from the CD post install, or do a re-install. That way I can get SunView going.

Thanks for the help everybody. If you have any further suggestions on where to go from here, or resources to educate myself, send them my way.

Re: Installing SunOS 4.1.4

Posted: Fri Jun 02, 2017 12:33 am
by ClassicHasClass
My Solbourne system uses a SCSI2SD and I just used 2GB partitions. Much of the OS/MP installation procedure applies to SunOS since it's just a variant of SunOS. See

A 2GB partition is more than enough for every single thing on the SunOS disc. The Versatec package is optional, so just skip that and install everything else if it doesn't seem to be working. The packages on the SunOS 4.1 CD are just tarballs.

I don't know why it wants to be ID 3 unless it's something about that particular model. My SCSI2SD has two partitions, 0 and 1. That works just fine here.

Re: Installing SunOS 4.1.4

Posted: Sat Jun 03, 2017 5:02 am
by escimo
ClassicHasClass wrote:I don't know why it wants to be ID 3 unless it's something about that particular model. My SCSI2SD has two partitions, 0 and 1. That works just fine here.
SunOS expacting the primary hard disk to have SCSI ID 3, second drive with SCSI ID 1. It seems to be hard coded into the the (default) kernel:

Code: Select all

The SunOS kernel is hard-wired to map sd0 to SCSI target 3, and sd3 to SCSI target 0.

Unit#  Target#  Name
-----  -------  ----------
   0    3       sd0 (disk)
   1    1       sd1 (disk)
   2    2       sd2 (disk)
   3    0       sd3 (disk)
   4    4       st0 (tape)
   5    5       st1 (tape)
   6    6       cdrom
   7    7       hba/ctrl
Source: ... STALL.html (+ supplements)
EDIT: I'm out of my mind. ID 7 has to be the HBA/Ctrl.

Code: Select all

Drive   SCSI    Physical  4.x
Number  Target  Device    Device
        Number  Number    Number
------  ------  --------  ------ 
   1      3     sd@3,0    sd0
   2      1     sd@1,0    sd1
Source: SMCC, Manual 800-566-11 (reduced information)

I never tried to change the kernel settings for SCSI ID 3 and 0 or know if it's possible to change before recompiling the SunOS kernel.
If this is possible you have to change the harddisk ID's 3->0 before trying to start the next time with the new kernel.
Looking into the sources could show you if this is easy made or not. I suppose not.

Cheers, escimo

Re: Installing SunOS 4.1.4

Posted: Sat Jun 03, 2017 8:12 pm
by thunderbird32
In that case, perhaps I will change the SCSI ID to 3. It does seem to work fine if I just do a

Code: Select all

boot disk0
though. Maybe I'll just leave it that way for now.

I got everything going, BTW. :mrgreen: