Discreet Stone problems

Video, software tools and techniques on SGI systems.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
Timberoz
Posts: 284
Joined: Fri Apr 25, 2003 8:06 pm
Location: Brisbane Australia
Contact:

Discreet Stone problems

Unread postby Timberoz » Sun Nov 23, 2008 4:50 pm

I am after some assistance with a stubborn O2 Effect system (version 6.1.2)
I have a D9 stone (4 x 4gig drives) & the flint dongle attached to serial port two. (thanks to Grant & Rangi) I now know that I my IP address changes it causes problems with the stones.

To be honest my IRIX skills are close to zero, but here is what I am attempting.

I log into the effect account. type Effect -vr & the interface starts at the project splash screen as it should with no errors.
VOLUMEMGT : Warning ( I choose Y) & can hear the drives respond.
If I choose a <New> project
I now have a new screen with no project
Name, [blank]
Description, [blank]
Partition <new>
Setup Dir. [/usr/discreet/project/effecrs/untitled]
Cfg Template film.cfg
Memory 0 (what should this be if my 02 has 1gig of ram?)

I go to Partition & click on <new> & it opens the Framestore Setup window.
I can see that the stonefs has no partitions & plenty of free space. I change the default NTSC tab to PAL click on 4:3 change the name to PAL TEST the apply (ERROR : VOLUMEMGT: PARTITION NAME IS TOO LONG OR CONTAINS INVALID CHARACTERS) so instead I have PAL & click "Apply"

I get an instant flash of white onscreen
then
PANIC: swf age_cut: Mismatched links in list
Kernel/Interrupt Stack Overflow @0x801c4494 sp:0x803a7918 K1:0x40
ra:0x801c4494 stkflag:1

DOUBLE PANIC: Stack underflow/overflow

I have tried numerous button clicks but these all result in the flash of death & a long sigh.
In the project window I can see 3 projects one with a (NTSCDefault : non-existent) & the other (PALDefault : non-existent) & then <new>

Any help or advise would be gratefully received & really appreciated. I am one step closer than I was before, but I am still not quiet there.

Thanks in Advance
Timberoz>Craig

Timberoz
Posts: 284
Joined: Fri Apr 25, 2003 8:06 pm
Location: Brisbane Australia
Contact:

Discreet Stone problems

Unread postby Timberoz » Sun Dec 07, 2008 4:34 am

Would anyone be able to give me help or tips on the following please, as I am still banging my head against the wall with this machine.

#1 Where is the licence kept for Effect? & Also the Sapphire 3.0 Sparks? (So I can do a back up)

#2 When I go to start the software, I use effect -riv. (VOLUMEMGT: WARNING: All Data on Volume stonefs will be DESTROYED !) I choose Y
This brings me to the start screen. I am starting to think that the Stone is ok & there is a problem with the Software?

I have the following Clues.....
In the xwsh window after I have typed effect -riv & I go to create at new partition & the system crashed I can see the following
PROJECT: Happy_Meal
USER : default
CONFIG : Warning -could not read /usr/discreet/project/effects/Happy_Meal/cfg?Happy_Meal.cfg

Error reading config file--aborting.

If I jump into that director /usr/discreet/project/effects I can only see a folder Destination_AXN & project.rdb project.rdb.bak
In Destination_AXN is XFERS.omf

At the splash screen I have Project Happy_Meal (NTSCDefault :non-existent)If I hold the mouse over the project bar & click I can see 2 new options <NEW> & default (PALDefault :non-existant) I can't find any files in the Project folder?? Is this part of the problem. Why is the Happy_Meal project the NTSC default?

Could the problem be with the init.cfg file in usr/discreet/effect_6.1.2/cfg/init.cfg?

Any help or suggestions would be greatly appreciated.

Thanks in Advance
Timberoz>Craig

User avatar
zafunk
Posts: 1060
Joined: Thu Feb 12, 2004 11:51 pm
Location: Victoria, BC, Canada

Re: Discreet Stone problems

Unread postby zafunk » Sun Mar 15, 2009 7:19 am

Timberoz wrote:#1 Where is the licence kept for Effect? & Also the Sapphire 3.0 Sparks? (So I can do a back up)


/usr/local/flexlm/licenses/DL_license.dat

for Effect's license. The sparks are probably in the same place.

Timberoz wrote:#2 When I go to start the software, I use effect -riv. (VOLUMEMGT: WARNING: All Data on Volume stonefs will be DESTROYED !) I choose Y
This brings me to the start screen. I am starting to think that the Stone is ok & there is a problem with the Software?


Have you tried changing your init.cfg and your NTSC.cfg (or PAL, etc...) to point to a non-stone storage? Just to see if it's effect that's acting up or the stone. Then start effect and create a new project/framestore. Of course, comment out anything that's looking for a Stone in the cfg files.

winchester
Posts: 18
Joined: Sat Feb 03, 2007 3:23 pm

Re: Discreet Stone problems

Unread postby winchester » Mon Mar 16, 2009 6:26 am

I think the problem is with your config files, not the stones. The "NTSCDefault" and "PALDefault" refer to partitions on the framestore for NTSC and PAL, respectively. If you open /usr/discreet/effect_6.1.2/cfg/pal.cfg or ntsc.cfg you may find a framestore config in there looking something like:

FrameStore stonefs "NTSCDefault"

If the NTSCDefault partition does not exist, this will give you problems. The fact that you see a message like: (NTSCDefault :non-existent) does indicate that.

The reason you still see the Happy_Meal project might be because the project.rdb file still has a reference to the project. Project.rdb is the project database, you can edit it with jot/nmap.

Timberoz
Posts: 284
Joined: Fri Apr 25, 2003 8:06 pm
Location: Brisbane Australia
Contact:

Re: Discreet Stone problems

Unread postby Timberoz » Wed Jun 03, 2009 4:27 am

Thanks, I have just got the machine out of storage. I will check on that & report back.

Thanks for the help

Timberoz

User avatar
archaic
Posts: 354
Joined: Mon Mar 08, 2004 9:28 pm
Location: Houston, TX

Re: Discreet Stone problems

Unread postby archaic » Thu Oct 15, 2009 7:54 pm

Timberoz wrote:
I go to Partition & click on <new> & it opens the Framestore Setup window.
I can see that the stonefs has no partitions & plenty of free space. I change the default NTSC tab to PAL click on 4:3 change the name to PAL TEST the apply (ERROR : VOLUMEMGT: PARTITION NAME IS TOO LONG OR CONTAINS INVALID CHARACTERS) so instead I have PAL & click "Apply"



It does not like spaces in the name. If you press enter after you type it it should go ahead and put the underscores in there for you and set the project directory to the same name.

As far as the crashing, I don't know. :(
Patrick

- You have got to be kidding... -


Return to “SGI: Video”

Who is online

Users browsing this forum: No registered users and 2 guests