product.image.subsystem + "+"

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
whiter
Posts: 972
Joined: Tue Apr 29, 2003 2:02 pm
Location: Winterthur, Switzerland
Contact:

product.image.subsystem + "+"

Unread postby whiter » Sun Apr 04, 2004 2:16 am

I just finished the optimized GTK+-2.4.0 build with MipsPro (look here :)) and am packaging it but encounter some weirdness with gendist. It is unable to parse the 'exp' (for example "exp nekopro_gtk+.sw.base") lines in my .spec file because of the "+".
But I see packages like "ifl_eoe.sw.c++" from SGI itself. How can you make gendist understand the "+" characters !???
Shall I describe it to you? Or do you want me to get you a box?

User avatar
SkyBound
Posts: 136
Joined: Tue Jan 13, 2004 11:57 am
Location: Enschede, The Netherlands
Contact:

Re: product.image.subsystem + "+"

Unread postby SkyBound » Mon Apr 05, 2004 2:19 am

whiter wrote:I just finished the optimized GTK+-2.4.0 build with MipsPro (look here :)) and am packaging it but encounter some weirdness with gendist. It is unable to parse the 'exp' (for example "exp nekopro_gtk+.sw.base") lines in my .spec file because of the "+".
But I see packages like "ifl_eoe.sw.c++" from SGI itself. How can you make gendist understand the "+" characters !???


I worked around that problem once by editing the .spec file and adding double quotes ("")around the product name.

Erik

User avatar
whiter
Posts: 972
Joined: Tue Apr 29, 2003 2:02 pm
Location: Winterthur, Switzerland
Contact:

Unread postby whiter » Mon Apr 05, 2004 3:05 am

well... I tried that ofcourse. Also tried escaping the characters. But none of that works here. gendist keeps complaining.
Shall I describe it to you? Or do you want me to get you a box?

User avatar
SkyBound
Posts: 136
Joined: Tue Jan 13, 2004 11:57 am
Location: Enschede, The Netherlands
Contact:

Unread postby SkyBound » Tue Apr 06, 2004 1:49 am

Then I'm not sure I'll be able to help here.
I tried to search for it without any luck and my attempts are at least two years old.

Sorry.

Erik


Return to “SGI: Development”

Who is online

Users browsing this forum: khalidschofield and 2 guests