DMedia Video Input?

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
Posts: 744
Joined: Thu Jan 23, 2003 11:34 am

DMedia Video Input?

Unread postby vegac » Thu Mar 11, 2004 8:48 am

I'm working on my o2 a bit...
I've looked at the bigVideoIn and other bits of dmedia code for reference, and am currently modifying those bits to try to just get a simple video input program that will display fullscreen...currently trying to grab the movie to a texture and then display...

Unfortunately, ALL of these sample programs (bigVideoIn included) just grab 512x512 and use that...which means the right quarter of my video is just gone! Now using this to play video games on, it doesn't work all that well...

Obviously I can't grab into a 640x512 texture (640 isn't a power of 2) so I tried to do a 1024x512 texture, however when I do that, the program just sits there, apparently working, but I get nothing displaying...

Has anyone done any dmedia/vl programming that might have a clue?

User avatar
Posts: 603
Joined: Thu Apr 03, 2003 11:31 am
Location: Maryland

Unread postby wolflord » Thu Mar 11, 2004 11:18 am

I had a similar problem...when trying to capture anysize video. I'm running 6.5.19 on my O2 btw. Apparently there is a bug in 6.5.15-16? onward that causes problems with video that is processed thru software at non-standard resolutions. I've yet to rebuild my O2 on a seperate drive and test this theory though.
WolfLord - :4D70G: :Octane2:

"Two Minus Three Equals Negative Fun" - Troy McClure

Return to “SGI: Development”

Who is online

Users browsing this forum: No registered users and 1 guest