Nekoware-current

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
thunng8
Posts: 92
Joined: Fri Jul 29, 2005 1:35 am
Location: Sydney, Australia
Contact:

Unread postby thunng8 » Tue Sep 26, 2006 6:38 pm

schleusel wrote:
Well, here is another test build i uploaded for Dan yesterday, feel free to try it:
http://www.kanera.de/mplayer/mplayer.gz

The test.avi in the same dir is a small sample quickly transcoded to h.264 that shows the issue. No other vo has that problem and switching to the external software colorspace routines (-vf format=rgb24) works around it for vo_sgi too - but thats obviously not a satisfying solution.

I just gave this build a go. Here are my results:
* -vo sgi : Not usable becuase of horizontal distortion on h264 content. Doing a -benchmark -quiet gets ~8% frameskip on the fountain trailer.
* -vo sgi -v format=rgb24: Works very well on all content. Gets ~12% frameskip, but this time you can actually see the image. I tried another h264 trailer (http://trailers.gametrailers.com/gt_vau ... 6_h264.mov) with this option with -fs and can get 0% frameskip, while the -vo gl2 -fs gets 37% frameskip. Quite a big improvement!

Anyway, keep up the great work! I look forward to the neko build
My Systems:
Apple MacBookPro, 2.66Ghz Dual Core i7, Nvidia 330M GT, 8GB RAM, 240GB SSD + 750GB (optibay)
AMD Phenom II X4 3.4Ghz, Nvidia 9800GT, 8Gb RAM, 2TB + 1.5TB
Apple iBook G4, 1.2ghz G4, ATI 9200, 768MB RAM, 80GB.
HP c8000, 1.1Ghz Dual Core PA-8900, ATI FireGL X3, 6GB RAM, 2x73GB

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8040
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Unread postby nekonoko » Wed Sep 27, 2006 3:26 pm

Uploaded new openssh/openssl tardists:

neko_openssh-4.4p1.tardist
neko_openssl-0.9.7k.tardist
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

User avatar
joerg
Posts: 2223
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

Unread postby joerg » Fri Sep 29, 2006 6:41 am

nekonoko wrote:Uploaded new openssh/openssl tardists:

neko_openssh-4.4p1.tardist
neko_openssl-0.9.7k.tardist


Thx for these updates, both runs fine. Good to have these important packages up to date :)

Note:
The mips3 version of neko_openssh comes with a already enabled chkconfig setting. Wouldnt it be better to disable by default?

The latest neko_firefox(mips4) install some files with the ownership 'neko' which doesnt exists on the most systems :).

Note to my self:
neko_pari, neko_apache2_prefork, neko_viruskiller and neko_unixodbc have the same 'problem'.

regards
Joerg

User avatar
joerg
Posts: 2223
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

Unread postby joerg » Fri Sep 29, 2006 9:45 am

I have updated
neko_lighttpd-1.4.12 - fast and secure webserver

regards
Joerg

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8040
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Unread postby nekonoko » Fri Sep 29, 2006 11:31 pm

joerg wrote:
nekonoko wrote:Uploaded new openssh/openssl tardists:

neko_openssh-4.4p1.tardist
neko_openssl-0.9.7k.tardist


Thx for these updates, both runs fine. Good to have these important packages up to date :)


Not a problem; thanks for testing! I'll move these to 'current' since they address security issues.

Note:
The mips3 version of neko_openssh comes with a already enabled chkconfig setting. Wouldnt it be better to disable by default?


Probably so - I'll fix that on the next version update, hopefully this weekend sometime.

The latest neko_firefox(mips4) install some files with the ownership 'neko' which doesnt exists on the most systems :).


I'll catch that one on the next version bump as well.
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

User avatar
joerg
Posts: 2223
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

Updated package

Unread postby joerg » Sat Sep 30, 2006 11:08 am

I have updated the following package:
neko_samba-3.0.23c - print and file services for SMB/CIFS clients

I have removed the mysql support from this packages to decrease the dependancies. Schleusel have already test the package and it works like expected. People which runs 6.5.22 needs this version because of our ldap updates some weeks ago breaks some application.

Note:
Is looks likes that this version have a need for a library which comes with the IRIX OS. This wasnt the case for the last version. So if some of you get a message that smbd doesnt found 'libdm.so' please install 'eoe.sw.dmi' from your overlay/base media.

regards
Joerg
Last edited by joerg on Mon Oct 02, 2006 1:41 pm, edited 2 times in total.

User avatar
nekonoko
Site Admin
Site Admin
Posts: 8040
Joined: Thu Jan 23, 2003 1:31 am
Location: Pleasanton, California
Contact:

Re: Updated package

Unread postby nekonoko » Mon Oct 02, 2006 1:37 pm

joerg wrote:I have update the following package:
neko_samba-3.0.23c - print and file services for SMB/CIFS clients


Nice, thanks!

I've uploaded mips3 versions of openssh-4.4p1 and openssl-0.9.7k into nekoware-mips3/beta. The 'chkconfig' issue should be fixed.
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.

User avatar
joerg
Posts: 2223
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

Unread postby joerg » Mon Oct 02, 2006 1:55 pm

I have updated

neko_openexr-1.4.0a - EXR image library
neko_exrtools-0.4 - EXR image tools

and a new package:
neko_djv-0.5.0 - Imaging software

Read also the following thread.
DJV 0.5.0 - New release of flipbook and image utilities.

These 3 packages have to stay at bottom of /beta until someone have recompile cinepaint, blender and kde/kde_base. For those who would like to test these packages keep in mind that the lib*.so.5 replace a lib*.so.3. A workaround would be to place a symlink... but i didnt test it.

Note to all:
From our last update we have some apps left (the evolution stuff) which needs a update because of our new libldap.so.

@Squeen
Any chance that you can create a newer neko_lua? I have a need for the 5.1.x version but i dont know how to create also the shared libs. I have read your relnotes but it looks like the configure have changed.

regards
Joerg

User avatar
squeen
Moderator
Moderator
Posts: 2932
Joined: Fri May 09, 2003 6:10 am
Location: Maryland, USA

Unread postby squeen » Tue Oct 03, 2006 3:35 am

joerg wrote:@Squeen
Any chance that you can create a newer neko_lua? I have a need for the 5.1.x version but i dont know how to create also the shared libs. I have read your relnotes but it looks like the configure have changed.

regards
Joerg


I'll give lua a shot.
Also nice to see OpenEXR compiles under IRIX even after official support was dropped.

User avatar
squeen
Moderator
Moderator
Posts: 2932
Joined: Fri May 09, 2003 6:10 am
Location: Maryland, USA

Unread postby squeen » Tue Oct 03, 2006 4:19 am

Looks like the lua build system has been redone alright. There is no shared lib mechanism and liblualib is gone. The only thing in nekoware built against it right now was SciTE, which will need a recompile anyways. Although I did get lua to build a shared lib,

Code: Select all

sgi:
   $(MAKE) all MYCFLAGS="-DLUA_USE_POSIX -DLUA_USE_DLOPEN $(CFLAGS) $(LDFLAGS)";\
   $(LD) -shared -o liblua.so.$(V) -set_version sgi$(V) $(CORE_O) $(LIB_O)



I think it's simpiler to just force a static lib build on the next neko_scite, so go ahead and redo neko_lua as static only and move neko_scite to OBSOLETE.

User avatar
VenomousPinecone
Moderator
Moderator
Posts: 2092
Joined: Mon Jun 20, 2005 2:10 pm
Location: Northern Nevada

Unread postby VenomousPinecone » Wed Oct 04, 2006 12:25 pm

Upgraded to latest neko_glib (2.12), and gimp bombs on large files with a:

Code: Select all

GLib-ERROR **: gmem.c:135: failed to allocate


This had been mentioned elsewhere on the forums as being a glib problem, so I downgraded to 2.8 and it works just fine. :wink:

Regards,
Will

thunng8
Posts: 92
Joined: Fri Jul 29, 2005 1:35 am
Location: Sydney, Australia
Contact:

Unread postby thunng8 » Wed Oct 04, 2006 7:43 pm

VenomousPinecone wrote:Upgraded to latest neko_glib (2.12), and gimp bombs on large files with a:

Code: Select all

GLib-ERROR **: gmem.c:135: failed to allocate


This had been mentioned elsewhere on the forums as being a glib problem, so I downgraded to 2.8 and it works just fine. :wink:

Regards,
Will


Yep, the latest glib is a problem for me and it seems quite a lot of other people as well. Luckily I kept the previous version as it seems the problem glib is now in Current and is the only one that can downloaded from nekoware now.

edit: sorry, its still obsolete/archive
My Systems:
Apple MacBookPro, 2.66Ghz Dual Core i7, Nvidia 330M GT, 8GB RAM, 240GB SSD + 750GB (optibay)
AMD Phenom II X4 3.4Ghz, Nvidia 9800GT, 8Gb RAM, 2TB + 1.5TB
Apple iBook G4, 1.2ghz G4, ATI 9200, 768MB RAM, 80GB.
HP c8000, 1.1Ghz Dual Core PA-8900, ATI FireGL X3, 6GB RAM, 2x73GB

User avatar
joerg
Posts: 2223
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

New and updated packages

Unread postby joerg » Thu Oct 05, 2006 8:55 am

Updates in /beta
neko_php5_imagick - 0.9.11
neko_nessus_libraries-2.2.8 - nessus base libraries

There are some packages left which are currently broken because of whiters new imagemagick.

New packages in /beta
neko_libnasl-2.2.8
neko_nessus_core-2.2.8 - security scanner
neko_nessus_plugins-2.2.8 - plugins for nessus security scanner

Nessus is a server/client apps which scan hosts and its application for known vulnerabilities. The clients comes as a GKT1 base one.

Steps to get the thing up and running.
1. use sbin/nessus-adduser to create a new account. Choose [pass] for password. Dont specify a rule for that account. Without a rule the user can scan every host.
2. Start /sbin/nessusd. At first start the daemon needs a long time because all plugins have to be register first.
3. Open a new shell and start the client "nessus". (Hint you can start "nessusd -D" to run it in daemon mode).
Login into your account. Select a target and perform a full systems scan. Later you can create profiles and so on.

If you would use the scanner for serious work you have to update the plugins from time to time. Visit http://www.nessus.org/plugins/?view=register-info and click the 'free' thing. After insert your e-mail adress you get a keycode by mail and also information how to register your client.

Run nessus-fetch --register XXXX-XXXX-XXXX-XXXX-XXXX and verify the settings with a

Code: Select all

[o2k]:/usr/nekoware/bin $ ./nessus-fetch --check
nessus-fetch is properly configured to receive a plugin feed


Now run sbin/nessus-update-plugins -v or setup a cronjob. Omit the -v if you dont interested in the output

regards
Joerg

schleusel
Posts: 495
Joined: Mon Oct 20, 2003 6:49 am
Location: NRW, Germany
Contact:

Unread postby schleusel » Thu Oct 05, 2006 12:03 pm

new in beta:

neko_faac-1.25 aac encoder - new version (and actually working this time ;-) )
neko_faad2-2.5.tardist aac decoder - new version. The package now also includes the xmms aac plugin as separate selection
neko_id3lib-3.8.3.tardist ID3v1/ID3v2 tagging library

User avatar
joerg
Posts: 2223
Joined: Thu Jan 08, 2004 6:57 am
Location: In an origin rack - Germany
Contact:

Unread postby joerg » Thu Oct 19, 2006 12:08 pm

New and updated packages in /beta.
neko_apr-0.9.12 - Apache portable runtime
neko_apr_util-0.9.12 - Apache portable runtime Utilitities
neko_neon-0.26.1 - HTTP and WebDAV client library
neko_subversion-1.4.0 - version control system


The Subversion package now ships with header and libs. I have also included the mod_dav_svn.so module for the Apache2 webserver (extra subimage, and not selected for default installation). It would be fine if some one can test this svn build with a test/real-life repository and also the client.

From the apr software are 2 major releases available. I have check both apr-0.x and apr-1.x and the use different suffixes so we can use both packages at once. The neko_apr1 would be apr-1.2.x which i would try to release later this week. Same is true for the apr-utils.

regards
Joerg


Return to “SGI: Development”

Who is online

Users browsing this forum: No registered users and 1 guest