Page 1 of 1

LGeneral (Panzer General) compiled for IRIX

Posted: Tue Sep 12, 2017 10:17 am
by necron2600
This still needs testing and review of bugs/IRIX issues, so consider this a beta.
It runs far better natively than trying to run Panzer General in Dosbox on an SGI.

"LGeneral is a turn-based strategy engine heavily inspired by Panzer General. You play single scenarios or whole campaigns turn by turn against a human player or the AI. Entrenchment, rugged defense, defensive fire, surprise contacts, surrender, unit supply, weather influence, reinforcements and other implementations contribute to the tactical and strategic depth of the game."

It is compiled with GCC on an Octane (mips4) with nekoware installed. Installs to /usr/local (extracts to a usr directory).

Only the K.u.k data (WWI scenario) is included, the pg-data was not, or at least does not seem to work.

I verified the Kukgen campaign works for at least a few turns. I compared it to LGeneral running on Ubuntu.. all looks the same (but no sound so far for me)
I will see what is going on with the default PG campaign later. Maybe it requires the original DOS data files, I am not sure yet.

No sound? It does seem to open the sound device with SDL.
Converter software does not work (you could use a Linux system to convert.. Ubuntu has lgeneral available in its repos)

(3.22 MiB) Downloaded 5 times

Re: LGeneral (Panzer General) compiled for IRIX

Posted: Tue Sep 12, 2017 11:40 am
by necron2600
So I was able to take the DOS version of panzer general, convert it, and runs fine on IRIX's compiled lgeneral.
On ubuntu, I ran lgc-pg --separate-bridges DAT (DAT is the directory from panzer general and --separate-bridges is needed to get a bridge.bmp (and a couple others) file that seems to be required (google searches indicate this is a known bug). And then copy in pg related files into the IRIX version.

Still no sound though.

Re: LGeneral (Panzer General) compiled for IRIX

Posted: Wed Sep 13, 2017 10:59 am
by necron2600
Looks like sound always worked. My Octane was set to default audio output to AES/optical .. and it seems SDL-based apps do not agree and go out on regular analog out.