SDL and Xinerama not working

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
necron2600
Posts: 262
Joined: Tue May 26, 2015 10:38 pm
Location: Boston

SDL and Xinerama not working

Unread postby necron2600 » Thu Mar 24, 2016 7:58 pm

I have a problem with SDL apps when using Xinerama (3840x1200 res). Everything works without xinerama, but once xinerama is in use then anything related to SDL fails to start:

Few examples:
[octane]:/usr/local/bin $ ./scummvm
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 128 (XINERAMA)
Minor opcode of failed request: 4 ()
Serial number of failed request: 9
Current serial number in output stream: 9

[octane]:/usr/local/bin $ abuse.sdl
Added himem block (3072000 bytes)
Memory available : 3071864
Abuse-SDL 0.7.0
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 128 (XINERAMA)
Minor opcode of failed request: 4 ()
Serial number of failed request: 9
Current serial number in output stream: 9

octane]:/usr/local/bin $ BasiliskII
Basilisk II V1.0 by Christian Bauer et al.
The program 'BasiliskII' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
(Details: serial 9 error_code 1 request_code 128 minor_code 4)

They all link to:
libSDL-1.2.so.1 => /usr/nekoware/lib/libSDL-1.2.so.1.4

I am using nekoware's 'Beta' version of neko_sdl which gives libSDL-1.2.so.1.4. However I did try nekoware's regular neko_sdl tardist that comes with libSDL-1.2.so.1.2 and there was no difference. (I extracted the older lib by showfiles -f . -x -- libSDL-1.2.so.1.2 from the tardist)

Below is the neko_sdl package I have installed: Not sure why its 1.2.15 when the library file has 1.2.so.1.4 .. but oh well

octane 26# versions -n neko_sdl
I = Installed, R = Removed
Name Version Description
I neko_sdl 12 SDL 1.2.15 simple directmedia library
I neko_sdl.man 12 man mages
I neko_sdl.man.man 12 man pages
I neko_sdl.sw 12 software
I neko_sdl.sw.eoe 12 execution only env
I neko_sdl.sw.hdr 12 header files
I neko_sdl.sw.lib 12 shared libraries

Anyone have any ideas? SDL not supporting Xinerama?
If I search the library file itself for text with XINERAMA.. it comes back:
octane 22# strings libSDL.so |grep -i xine
SDL_VIDEO_X11_XINERAMA
XINERAMA

So it seems to be compiled with Xinerama support. Maybe my resolution is too large? Maybe IRIX' xinerama is not compatible? Maybe there is a trick to fix this, or something undocumented?

Thanks!

Return to “SGI: Development”

Who is online

Users browsing this forum: No registered users and 1 guest