Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
dieu
Posts: 13
Joined: Fri Nov 20, 2015 5:31 pm

Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dieu » Tue Jan 12, 2016 2:01 am

Hi everyone,

I download kdevelop 3.3.1 from Nekochan but I cannot use it since it requires Qt 4.5.8 or higher.
Does anyone have Qt 4.5 tardist or Qt 4.8 tardist on hand, please let me have it.
I tried to download Qt source and compiled but got so many template errors. I gave up.
Thank you in advance,

User avatar
dexter1
Moderator
Moderator
Posts: 2738
Joined: Thu Feb 20, 2003 6:57 am
Location: Zoetermeer, The Netherlands

Re: Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dexter1 » Tue Jan 12, 2016 5:43 am

Why do you think neko_kdevelop 3.3.1 requires Qt 4.5.8?
I just looked into the package and it states:

qt.png

So neko_qt with a version number of at least 2 will suffice the dependency, which in nekoware/current is neko_qt-3.3.1.tardist

It is possible the kdevelop programs actually depends on qt-4.5.8, but this is considered a packaging error and you should contact the package creator.
:Crimson: :PI: :Indigo: :O2: :Indy: :Indigo2: :Indigo2IMP:

dieu
Posts: 13
Joined: Fri Nov 20, 2015 5:31 pm

Re: Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dieu » Tue Jan 12, 2016 9:50 pm

Dexter,
Thanks for the response. When I run it, It needs libqt-mt.so.xxx which I don't have.
I read and some said it is in Qt and I could not find it in Qt 3.3.1 nor neko_qt4-4.3.0.tardist.
I'm stuck with libqt-mt.so.X.
I compile 4.8.6 from Qt source but no luck. Is anyway that I can get Qt with libqt-mt.so ?
thanks,
Last edited by dieu on Wed Jan 13, 2016 9:19 pm, edited 1 time in total.

dieu
Posts: 13
Joined: Fri Nov 20, 2015 5:31 pm

Re: Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dieu » Tue Jan 12, 2016 9:52 pm

.
Last edited by dieu on Wed Jan 13, 2016 9:21 pm, edited 1 time in total.

dieu
Posts: 13
Joined: Fri Nov 20, 2015 5:31 pm

Re: Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dieu » Tue Jan 12, 2016 9:56 pm

Add on: I did untar all kde tardist(s) required and at this time kde looks for libqt-mt.so.

User avatar
dexter1
Moderator
Moderator
Posts: 2738
Joined: Thu Feb 20, 2003 6:57 am
Location: Zoetermeer, The Netherlands

Re: Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dexter1 » Wed Jan 13, 2016 4:20 am

First, for future forum posts: please edit your last post instead of making new posts correcting typo's and adding information.

Only install neko_qt.3.3.5 since that has qt version 2 and will be picked up by neko_kdevelop

libqt-mt.so is installed by default in /usr/nekoware/qt/lib both for neko_qt-3.3.1 and neko_qt-3.3.5 so please check that. If it is there but not picked up by kdevelop, you might want to add that path to your LD_LIBRARY_PATH environment variable.
:Crimson: :PI: :Indigo: :O2: :Indy: :Indigo2: :Indigo2IMP:

dieu
Posts: 13
Joined: Fri Nov 20, 2015 5:31 pm

Re: Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dieu » Thu Jan 14, 2016 10:06 pm

Dexter,
Thanks for the tips.
I installed Qt-3.3.5 as you recommended and start 'kdevelop', KDevelop GUI came up but ..
it's display language text was not English (text on pulldown menu, menu bar, dialog, messages, ... are little squares, cannot read)
I tested by closing 'kdevelop' and running Qt/bin/assistant alone and it came up but also Not in English text.

In this case, you know what is the cause or how to fix it Dexter ? I'm so close to be done.
(Does it cause by 'locale' folder some where or by fontconfig or by freetype2 or something else ? - I am not sure)
I installed neko fontconfig-2.8.0 and neko freetype2-2.4.12

Thanks,

User avatar
dexter1
Moderator
Moderator
Posts: 2738
Joined: Thu Feb 20, 2003 6:57 am
Location: Zoetermeer, The Netherlands

Re: Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dexter1 » Fri Jan 15, 2016 2:49 am

If the characters in the qt assistant do not display correctly, then it is most likely a font library problem:
My linker information from qt/bin/assistant is:

Code: Select all

mech003 /usr/nekoware/qt/bin> ldd assistant
        libqt-mt.so.3  =>        /usr/nekoware/qt/lib/libqt-mt.so.3     
        libGLU.so  =>    /usr/lib32/libGLU.so   
        libGL.so  =>     /usr/lib32/libGL.so   
        libXmu.so  =>    /usr/lib32/libXmu.so   
        libXrender.so.1  =>      /usr/nekoware/lib/libXrender.so.1     
        libXft.so.2  =>  /usr/nekoware/lib/libXft.so.2 
        libfreetype.so.7  =>     /usr/nekoware/lib/libfreetype.so.7     
        libfontconfig.so.2  =>   /usr/nekoware/lib/libfontconfig.so.2   
        libXext.so  =>   /usr/lib32/libXext.so 
        libX11.so.1  =>  /usr/lib32/libX11.so.1
        libm.so  =>      /usr/lib32/libm.so     
        libXt.so  =>     /usr/lib32/libXt.so   
        libpthread.so  =>        /usr/lib32/libpthread.so       
        libCsup.so  =>   /usr/lib32/libCsup.so 
        libC.so.2  =>    /usr/lib32/libC.so.2   
        libCio.so.1  =>  /usr/lib32/libCio.so.1
        libc.so.1  =>    /usr/lib32/libc.so.1   
        libGLcore.so  =>         /usr/lib32/libGLcore.so       
        libXsgivc.so  =>         /usr/lib32/libXsgivc.so       
        libgen.so  =>    /usr/lib32/libgen.so   
        libz.so  =>      /usr/nekoware/lib/libz.so     
        libexpat.so.1  =>        /usr/nekoware/lib/libexpat.so.1       

Can you post yours? This way one can quickly see if the problem lies in a different library version.
Can you start the assistant program remotely on your system and displaying the output on a different system? Are the characters displaying correctly?
What IRIX version are you running btw?
:Crimson: :PI: :Indigo: :O2: :Indy: :Indigo2: :Indigo2IMP:

dieu
Posts: 13
Joined: Fri Nov 20, 2015 5:31 pm

Re: Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dieu » Fri Jan 15, 2016 6:24 pm

Dexter,

Mine is Tezro IRIX 6.5. I'm currently out of town. I'll check Qt 3.3.5 assistant app's dyn. link libs of mine on Tue.
My system is working fine no problem with text or font at all (such as cvd, ddd, , tkdiff, desktop,...), only with Qt 3.3.5 recently.

Here is the history:
After I installed Qt 3.3.5, I ran Kdevelop and it complained about FT_Filter...something. I searched the error and they said it caused by freetype,
then I installed neko freetype2-2.4.12 and also installed fonconfig 2.8 then Kdevelop and assistant came up but with little squares and not readable.
This is the first time ever that Qt Assistant and Kdevelop come up!

I think from your 'ldd' listing above, only some are neko lib., so we can easy to isolate:
- Runtime Link Libraries From Neko: freetype, fontconfig, libXft, libXrender (expat, qt-mt, libz are not involve, i think)
- Since my Tezro is good, so system libraries are all good.

I will try to figure out on Tue. Any idea/thought is very welcome and appreciate.

I have another question: Can I install and use Neko_..._mips3....tardist software for my Tezro IRIX 6.5 ?

Thanks,

dieu
Posts: 13
Joined: Fri Nov 20, 2015 5:31 pm

Re: Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dieu » Sat Jan 30, 2016 2:53 pm

The problem solved. It is not libraries, just set FONTCONFIG_PATH to location where font.conf can be located.

User avatar
dexter1
Moderator
Moderator
Posts: 2738
Joined: Thu Feb 20, 2003 6:57 am
Location: Zoetermeer, The Netherlands

Re: Qt 4 tardist on IRIX6.5 needed for Kdevelop 3,4

Unread postby dexter1 » Sat Jan 30, 2016 4:05 pm

Thanks for reporting back the solution.

In reply to your question, yes you can use binaries from lower MIPS architecture set than the mips4 architecture your R14K in the Tezro supports. Binaries with mips3 should be fine. For programs with even lower architecture sets like mips1 and mips2 it is possible that different/older libraries are required for running the program.
:Crimson: :PI: :Indigo: :O2: :Indy: :Indigo2: :Indigo2IMP:


Return to “SGI: Development”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest