New package: Updated MPlayer

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
Trippynet
Donor
Donor
Posts: 812
Joined: Thu Aug 15, 2013 6:22 am
Location: Aberdeen, Scotland, UK

Re: New package: Updated MPlayer

Unread postby Trippynet » Wed Mar 18, 2015 8:30 am

Awesome news! Anything that helps get useful tools like MPlayer developed in a more MIPS/IRIX-friendly way has got to be a good thing :)
Systems in use:
:Indigo2IMP: - Nitrogen: R10000 195MHz CPU, 384MB RAM, SolidIMPACT Graphics, 36GB 15k HDD & 300GB 10k HDD, 100Mb/s NIC, New/quiet fans, IRIX 6.5.22
:Fuel: - Lithium: R14000 600MHz CPU, 4GB RAM, V10 Graphics, 72GB 15k HDD & 300GB 10k HDD, 1Gb/s NIC, New/quiet fans, IRIX 6.5.30
Other system in storage: :O2: R5000 200MHz, 224MB RAM, 72GB 15k HDD, PSU fan mod, IRIX 6.5.30

Axatax_
Posts: 92
Joined: Wed Jan 21, 2015 3:08 pm

Re: New package: Updated MPlayer

Unread postby Axatax_ » Wed Jun 10, 2015 12:13 pm

Just an update on this, and sorry for jurking you guyz around :? . I just haven't had the time I had back in Jan. That said, I'm *really* going to try to get something out by the end of the weekend, and I have been working on this diligently.

I'm not going to make any performance claims, but I'm going to post up a youtube video of the current player in action. Maybe there will be some surprises. :D

gijoe77
Posts: 242
Joined: Sat Jun 21, 2003 2:20 pm
Location: NJ

Re: New package: Updated MPlayer

Unread postby gijoe77 » Mon Jan 18, 2016 3:41 pm

I gave this a try on a single 600 V12 octane with -vo gl_nosw, the XVID MP4 movie played full speed with sound, same with fullscreen.

20160118_053800.jpg

20160118_053951.jpg


if time permits, I'll give my dual 360 MXE octane a spin tonight

gijoe77
Posts: 242
Joined: Sat Jun 21, 2003 2:20 pm
Location: NJ

Re: New package: Updated MPlayer

Unread postby gijoe77 » Wed Jan 20, 2016 4:44 am

Ran into issues with the MXE octane, was the openGL implementation specific to 1.2? Seems impact graphics are openGL 1.1 - i got a white screen with options -gl_nosw and/or -gl, -sdl worked but it was slooow, default ( -gl2?) didn't work

If this has something to do with openGL 1.1, I guess Impact series and o2's would share this issue

20160120_044248.jpg

20160120_044425.jpg

20160120_044937.jpg

Axatax_
Posts: 92
Joined: Wed Jan 21, 2015 3:08 pm

Re: New package: Updated MPlayer

Unread postby Axatax_ » Wed Jan 20, 2016 10:36 pm

Here's the deal with MPlayer --

The version in the /beta directory is absolutely boss on 480i and below. Physical DVD media now works 100%, AFAIK (nobody has reported any disc that doesn't play, yet). DTS works in this version, which was completely absent in the prior version (think the "white noise barrage" during the LOTR 2nd disk changeout...)

The 1.1.1 version can deal with 480p x.264 on a *really* good Octane, sometimes with sync issues, and probably more-or-less correct on an Origin w/graphics or Tezro.

The SVN version of MPlayer is **much** better, but is in a state of flux, so it will take sometime before a proper package appears here (although anyone is welcome to build their own).
Last edited by Axatax_ on Wed Jan 20, 2016 10:48 pm, edited 1 time in total.

Axatax_
Posts: 92
Joined: Wed Jan 21, 2015 3:08 pm

Re: New package: Updated MPlayer

Unread postby Axatax_ » Wed Jan 20, 2016 10:38 pm

I can't test on an MXE or an O2's or an Indy's or anything else than VPro (that's all I have), and I suspect an MXE isn't going to deal with x.264 @ > 480p, ever. Sorry. And if it can, it won't be from me. It will require someone with a much bigger brain than I have.


Return to “SGI: Development”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest