Netsurf 3.1

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
foetz
Moderator
Moderator
Posts: 6483
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: Netsurf 3.1

Unread postby foetz » Tue Aug 12, 2014 2:43 pm

jpstewart wrote:compile NetSurf with MIPSpro. That one fails even earlier in the launch process (no window ever appears, it just prints an error message and exits)

i remember that it's been mentioned that some libs required by netsurf were compiled with g++?
if so that's a likely reason

User avatar
canavan
Posts: 754
Joined: Mon Jul 21, 2003 6:19 am

Re: Netsurf 3.1

Unread postby canavan » Sun Sep 07, 2014 7:47 am

i remember that it's been mentioned that some libs required by netsurf were compiled with g++?
if so that's a likely reason
If that were the case, it would already fail when linking, and not produce an executable at all.

User avatar
foetz
Moderator
Moderator
Posts: 6483
Joined: Mon Apr 14, 2003 4:34 am
Contact:

Re: Netsurf 3.1

Unread postby foetz » Sun Sep 07, 2014 7:54 pm

canavan wrote:
i remember that it's been mentioned that some libs required by netsurf were compiled with g++?
if so that's a likely reason
If that were the case, it would already fail when linking, and not produce an executable at all.

sure, assuming that nothing has been "updated" after

User avatar
Knezzen
Donor
Donor
Posts: 48
Joined: Wed Nov 04, 2015 4:51 am
Location: Sweden

Re: Netsurf 3.1

Unread postby Knezzen » Fri Jun 10, 2016 12:53 am

Resurrecting this a bit. Would be nice to have a working NetSurf 3.5 with JS enabled on IRIX.
Never having tried to build anything on IRIX, I don't think im the right person to try to make it work.

All I can do is encurage someone to do it. So come on, someone try building it! ;)

NetSurf is speedy and works terribly well for what it is on my Atari Falcon 060 running FreeMiNT, would be wonderful to have it running on IRIX.
:Octane: Dual 300mhz R12k - 256mb RAM - 146GB 15k RPM HD - V6 Graphics

User avatar
ClassicHasClass
Donor
Donor
Posts: 1955
Joined: Wed Jul 25, 2012 7:12 pm
Location: Sunny So Cal
Contact:

Re: Netsurf 3.1

Unread postby ClassicHasClass » Fri Jun 10, 2016 9:20 pm

ISTR having endian trouble getting it working on OS X/ppc (10.4, anyway). That was 3.0, however, so maybe it's fixed.
smit happens.

:Fuel: bigred, 900MHz R16K, 4GB RAM, V12 DCD, 6.5.30
:Indy: indy, 150MHz R4400SC, 256MB RAM, XL24, 6.5.10
:Indigo2IMP: purplehaze, 175MHz R10000, Solid IMPACT
probably posted from Image bruce, Quad 2.5GHz PowerPC 970MP, 16GB RAM, Mac OS X 10.4.11
plus IBM POWER6 p520 * Apple Network Server 500 * RDI PrecisionBook * BeBox * Solbourne S3000 * Commodore 128 * many more...

User avatar
Dodoid
Posts: 461
Joined: Mon Jul 04, 2016 1:36 pm
Location: Ottawa, Canada
Contact:

Re: Netsurf 3.1

Unread postby Dodoid » Sun Jan 08, 2017 10:03 am

Any progress made on this? Like some others here, I don't really have the knowledge required to make it work, but if anyone else has made progress I would love to know.
:Fuel: :Octane: :Octane: :Octane: :O2: :Indigo2: :Indigo2: :Indy: :Indy:


Return to “SGI: Development”

Who is online

Users browsing this forum: No registered users and 3 guests