neko_apache2-2.2.21 and dependencies

IRIX/Nekoware development, porting and related topics.
Forum rules
Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.
User avatar
ianj
Posts: 155
Joined: Wed Nov 14, 2007 11:43 am
Location: 費府

neko_apache2-2.2.21 and dependencies

Unread postby ianj » Fri Sep 23, 2011 4:28 am

I recently sent the following packages to incoming:

neko_apache2-2.2.21 (13)
neko_cyrus_sasl-2.1.25 (3)
neko_db4-4.8.30 (8)
neko_krb5-1.9.1 (3)
neko_openldap-2.4.26 (5)

cyrus_sasl, db4, and openldap are incompatible with a number of packages in current, but the packages know about this and should prevent any scenarios where previously-installed software gets broken. Any help rebuilding packages to work with the new software would be much appreciated, although I plan to work on some of them as well.
:Fuel: :Octane: :Octane2: :Indigo2IMP: :O3x0:

zuluchas
Posts: 269
Joined: Wed Jun 25, 2008 10:41 am
Location: Washington, DC, USA

Re: neko_apache2-2.2.21 and dependencies

Unread postby zuluchas » Thu Sep 13, 2012 9:48 pm

looks like there are some incompatibilities (either real or inst-perceived) between dovecot, openldap, db4, and cyrus_sasl. ironically, i ran into this while trying to upgrade git (to 1.7.10 from nekoware)

Code: Select all

neko_openldap.sw.lib (5) is incompatible with neko_dovecot.sw.lib (3)
  1a. Do not install neko_openldap.sw.lib (5)
  1b. Remove neko_dovecot.sw.lib (3)
  1c. Open new distribution to resolve conflict

neko_openldap.sw.lib (5) is incompatible with neko_apache2_prefork.sw.lib
(5)
  2a. Do not install neko_openldap.sw.lib (5)
  2b. Remove neko_apache2_prefork.sw.lib (5)
  2c. Open new distribution to resolve conflict

neko_db4.sw.lib (8) is incompatible with neko_php5.sw.lib (4)
  3a. Do not install neko_db4.sw.lib (8)
  3b. Remove neko_php5.sw.lib (4)
  3c. Open new distribution to resolve conflict

neko_db4.sw.lib (8) is incompatible with neko_apache2_prefork.sw.lib (5)
  4a. Do not install neko_db4.sw.lib (8)
  4b. Remove neko_apache2_prefork.sw.lib (5)
  4c. Open new distribution to resolve conflict

neko_cyrus_sasl.sw.lib (3) is incompatible with neko_dovecot.sw.lib (3)
:A350R: :Onyx2: :4D220VGX: :Fuel: :Indigo: :Octane2: :O2: :O3x0: :Indy:

User avatar
ianj
Posts: 155
Joined: Wed Nov 14, 2007 11:43 am
Location: 費府

Re: neko_apache2-2.2.21 and dependencies

Unread postby ianj » Wed Sep 19, 2012 7:25 pm

dovecot and apache2_prefork list openldap as a dependency, so I put incompat lines in my spec to prevent an installation of the new openldap package from breaking them. I supplied newer versions of apache2 and php in /beta that will work with my openldap package, though. The dovecot package in /current is old and will also need to be rebuilt against the new libraries.
:Fuel: :Octane: :Octane2: :Indigo2IMP: :O3x0:


Return to “SGI: Development”

Who is online

Users browsing this forum: No registered users and 1 guest