Page 1 of 4

neko_supertuxkart-0.5 uploaded to incoming

Posted: Sun Jul 13, 2008 10:40 am
by emachine
Heres a screenshot:

supertuxkart.jpg


Its a pretty big tardist... ~128meg.

Runs fine on the Tezro :D

Best regards,
emachine

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Sun Jul 13, 2008 10:47 am
by bplaa.yai
emachine wrote:Runs fine on the Tezro :D

The question is... does it run on anything else than a Tezro ? ;)

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Mon Jul 14, 2008 3:40 am
by fzalfa
got an error......on Octane2 V6
./supertuxkart -w
Data files will be fetched from: '/usr/nekoware/share/games/supertuxkart/'
Config file '//.supertuxkart/config' does not exist, it will be created.
Highscores will be saved in '//.supertuxkart/highscore.data'.
Music information file 'Ethereal_Spectrum_(ver_loop).music' not found - ignored.
Can't find music file 'Ethereal_Spectrum_(ver_loop).music' - ignored.
FATAL: ssgInit called without a valid OpenGL context.


any idea ?

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Mon Jul 14, 2008 9:51 am
by emachine
Interesting. I don't believe its related to the music files because I see the same two lines and runs just fine.

Google search looks like its not an IRIX only "problem"? Most references say that its a problem with the GL library (which seems unlikely to me). Would be interesting to see what others see?

Emachine

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Mon Jul 14, 2008 10:33 am
by deBug
emachine wrote:Interesting. I don't believe its related to the music files because I see the same two lines and runs just fine.

Google search looks like its not an IRIX only "problem"? Most references say that its a problem with the GL library (which seems unlikely to me). Would be interesting to see what others see?

Emachine

I'll see If I can have a go at it tonight when I get home.

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Mon Jul 14, 2008 11:01 am
by VenomousPinecone

Code: Select all

ancalagon 11% /usr/nekoware/games/supertuxkart
95774:/usr/nekoware/games/supertuxkart: rld: Fatal Error: Cannot Successfully map soname 'libopenal.so.0' under any of the filenames /usr/nekoware/lib/libopenal.so.0:/usr/lib32/libopenal.so.0:/usr/lib32/internal/libopenal.so.0:/lib32/libopenal.so.0:/opt/lib32/libopenal.so.0:


It let me install supertuxkart without telling me about openal, so I went and installed openal from nekoware.

Code: Select all

ancalagon 12% /usr/nekoware/games/supertuxkart
Segmentation fault (core dumped)


And now this happens.

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Mon Jul 14, 2008 4:52 pm
by deBug
emachine wrote:Heres a screenshot:

supertuxkart.jpg


Its a pretty big tardist... ~128meg.

Runs fine on the Tezro :D

Best regards,
emachine


Runs pretty well on fuel 600MHz V12 as well.
Sound, working.
Swedish language in menus with no config., go figure.
controls working.
Screen settings not working, always the same size, by design ??

Most games run fine!!!

Great job! another game to IRIX.

update. is to slow on O2 600MHz (5-10fps)

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Mon Jul 14, 2008 6:23 pm
by emachine
Heres a list of the library dependencies on my box. I need to do a better job of getting the library dependencies in the tardist, was kind of in a hurry when I put this together.

Code: Select all

        libglut.so  =>   /usr/nekoware/lib/libglut.so   
        libGLU.so  =>    /usr/lib32/libGLU.so   
        libGL.so  =>     /usr/lib32/libGL.so   
        libm.so  =>      /usr/lib32/libm.so     
        libintl.so.4  =>         /usr/nekoware/lib/libintl.so.4
        libSDL-1.2.so.1  =>      /usr/nekoware/lib/libSDL-1.2.so.1     
        libopenal.so.0  =>       /usr/nekoware/lib/libopenal.so.0       
        libvorbisfile.so.4  =>   /usr/nekoware/lib/libvorbisfile.so.4   
        libalut.so.1  =>         /usr/nekoware/lib/libalut.so.1
        libCsup.so  =>   /usr/lib32/libCsup.so 
        libC.so.2  =>    /usr/lib32/libC.so.2   
        libCio.so.1  =>  /usr/lib32/libCio.so.1
        libc.so.1  =>    /usr/lib32/libc.so.1   
        libXmu.so  =>    /usr/lib32/libXmu.so   
        libXext.so  =>   /usr/lib32/libXext.so 
        libX11.so.1  =>  /usr/lib32/libX11.so.1
        libXi.so  =>     /usr/lib32/libXi.so   
        libGLcore.so  =>         /usr/lib32/libGLcore.so       
        libXsgivc.so  =>         /usr/lib32/libXsgivc.so       
        libiconv.so.3  =>        /usr/nekoware/lib/libiconv.so.3       
        libaudio.so  =>  /usr/lib32/libaudio.so
        libpthread.so  =>        /usr/lib32/libpthread.so       
        libdl.so  =>     /usr/lib32/libdl.so   
        libvorbis.so.1  =>       /usr/nekoware/lib/libvorbis.so.1       
        libogg.so.1  =>  /usr/nekoware/lib/libogg.so.1 
        libXt.so  =>     /usr/lib32/libXt.so   
        libgen.so  =>    /usr/lib32/libgen.so   


Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Mon Jul 14, 2008 7:10 pm
by VenomousPinecone
emachine wrote:Heres a list of the library dependencies on my box.


Ah, thank you sir. I shall check tomorrow when in front of the machine.

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Mon Jul 14, 2008 11:31 pm
by nekonoko
emachine wrote:Runs fine on the Tezro :D


Tried it on my Onyx2 IR3 - runs fine on it too ;)


deBug wrote:Screen settings not working, always the same size, by design ??


Same - seems to have the choice of running in a window or running "full screen" with identical output centered in the middle of the screen.

Nice job - looks and runs great!

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Tue Jul 15, 2008 2:09 pm
by VenomousPinecone
emachine wrote:Heres a list of the library dependencies on my box.


I checked and I have everything, but it is still core dumping.

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Tue Jul 15, 2008 5:26 pm
by Mark_G
Works fine on a Fuel 1600 MHZ MIPS R14k + V12 and 2 GB Ram.

Sound works fine, together with xmms :!:
Strange to see all text in Dutch, but translation is well done.

Mark

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Wed Jul 16, 2008 12:37 pm
by VenomousPinecone
Mark_G wrote:Works fine on a Fuel 1600 MHZ MIPS R14k + V12 and 2 GB Ram.

Sound works fine, together with xmms :!:
Strange to see all text in Dutch, but translation is well done.

Mark


I guess it is just me then...

I am uninstalling it now, I will try again with the next release. :?

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Thu Jul 17, 2008 7:06 am
by Dr. Dave
Worked fine on both a Fuel R14k and an Octane dual R12k-400 here.

Re: neko_supertuxkart-0.5 uploaded to incoming

Posted: Mon Jul 21, 2008 8:03 pm
by hamei
Mark_G wrote:Works fine on a Fuel 1600 MHZ ...

I want that one. Very much. Better lock your doors. :P