Nekochan Net

Official Chat Channel: #nekochan // irc.nekochan.net
It is currently Wed Apr 23, 2014 6:00 am

All times are UTC - 8 hours


Forum rules


Any posts concerning pirated software or offering to buy/sell/trade commercial software are subject to removal.



Post new topic Reply to topic  [ 1 post ] 
Author Message
Unread postPosted: Thu Aug 12, 2004 3:11 am 
Offline
Moderator
Moderator
User avatar

Joined: Fri May 09, 2003 5:10 am
Posts: 2931
Location: Maryland, USA
SGI has re-released a security advisory and patches to address the vulnerabilities associated with CAN-2004-0135, CAN-2004-0136 and CAN-2004-0137.


Description
- -------------------------------------------------------------------------------------
SGI IRIX versions 6.5.20 through 6.5.24 contain vulnerabilities that can allow a local attacker to create a denial of service (DoS) condition and obtain elevated privileges on the affected system.

The first vulnerability (CAN-2004-0135) allows an attacker to exploit a system call to obtain read and write access to kernel memory. This could allow the attacker to gain root privileges on the system.

The second vulnerability (CAN-2004-0136) allows an attacker to use a corrupted binary to crash the system, resulting in a DoS condition.

The third vulnerability (CAN-2004-0137) allows an attacker to cause init to panic, resulting in a DoS condition.

Patches are available.

Impact
- -------------------------------------------------------------------------------------
A local attacker could exploit these vulnerabilities to obtain root privileges on the affected system and create a DoS condition.

Warning Indicators
- -------------------------------------------------------------------------------------
Systems running SGI IRIX versions 6.5.20 through 6.5.24 are vulnerable.

Technical Information
- -------------------------------------------------------------------------------------
The first vulnerability is due to a flaw in the syssgi() system call and allows an attacker to gain read and write access to kernel memory. An attacker could exploit this vulnerability to obtain root privileges by issuing specially crafted SGI_IOPROBE requests.

The second vulnerability exists because of an error in the mapelf32exec() function and allows an attacker to crash the system through a malformed binary.

The third vulnerability exists due to an unspecified page invalidation error. An attacker could exploit this vulnerability to cause init to panic.

TruSecure Comments
- -------------------------------------------------------------------------------------
In order to exploit these vulnerabilities, an attacker requires local access to the affected system. Few details have been released concerning these vulnerabilities. Administrators are advised to restrict local system access to trusted users.

Safeguards
- -------------------------------------------------------------------------------------
Administrators are advised to install the latest patches.

Administrators are advised to restrict local system access to trusted users.

Administrators are advised to closely monitor affected systems until they can be patched.

Vendor Announcements
- -------------------------------------------------------------------------------------
SGI has re-released a security advisory at the following FTP link: 20040601-02-P["ftp://patches.sgi.com/support/free/security/advisories/20040601-02-P.asc"]

Patches/Software
- -------------------------------------------------------------------------------------
SGI has re-released patches for IRIX for registered users at the following FTP link: IRIX["ftp://patches.sgi.com/support/free/security/advisories/20040601-02-P.asc"]

Alert History
- -------------------------------------------------------------------------------------
Version 1, June 16, 2004, 5:03 PM: SGI IRIX contains multiple vulnerabilities that allow a local attacker to create a denial of service condition or obtain elevated privileges. Patches are available.


Product Sets
- -------------------------------------------------------------------------------------
The security vulnerability applies to the following combinations of products.


Primary Products:
- -----------------
[Silicon Graphics, Inc (SGI)] IRIX: 6.5.20 | 6.5.21 | 6.5.22 | 6.5.23 | 6.5.24


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group